Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
[Howto] Install Windows On Your OVH VPS
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

[Howto] Install Windows On Your OVH VPS

BlazeMuisBlazeMuis Member
edited April 2017 in Tutorials

So you want to install Windows on your OVH VPS? Thats possible! I created some cool templates that have been tested and confirmed working on these OVH VPS servers. It even works on the cheapest VPS plan OVH offers, the one with just 10GB disk space, isn't that awesome? Just follow this tutorial and we will have a working Windows installation on your OVH VPS within an hour.



The first thing well have to do is to reboot your VPS in rescue mode. Login at the OVH control panel, choose your VPS and click on the button that says "Reboot my VPS" (you can find that button on the right of the page).



You will see this popup once clicked:







Make sure to have the "Reboot in rescue mode" box selected.



It can take between 2 and 10 minutes before the VPS is booted into rescue mode.
Once your VPS has been booted into the rescue mode you will need to login using PuTTy (any SSH program will do, I like to use PuTTy). You can find the rescue login details in the email that OVH has sent you.



Once you have logged in you will need to unmount the disk by using the following command:

umount /mnt/sdb1

Now we are ready to install Windows on the VPS.


Choose one of the Windows versions, copy the command in the box and paste it in the PuTTy/SSH screen, press enter and it will begin downloading and extracting the template to the disk of your VPS. This can take some time, so grab yourself some coffee, watch a movie or take a walk with your dog (if you have one).



Windows Server 2012 R2 Standard:

 wget -O- 'http://mirror.uneven.eu/vps/WS_2012R2_OVH_VPS.gz' | gunzip | dd of=/dev/sdb

Windows Server 2008 R2 Standard:

 wget -O- 'http://mirror.uneven.eu/vps/WS_2008_R2_OVH_VPS.gz' | gunzip | dd of=/dev/sdb

Windows 10 Pro:

 wget -O- 'http://mirror.uneven.eu/vps/W10_Pro_OVH_VPS.gz' | gunzip | dd of=/dev/sdb

Windows 7 Professional:

 wget -O- 'http://mirror.uneven.eu/vps/W7_Pro_OVH_VPS.gz' | gunzip | dd of=/dev/sdb

Once the download is done, reboot the VPS again and it should have Windows installed and working when it comes back online.

You can login with the following credentials (make sure to change the password after you logged in):

For Windows Server 2008 R2 & 2012 R2:

Username: Administrator
Password: Password147

For Windows 7 Professional & Windows 10 Pro:

Username: Admin
Password: Password147



Original post: https://uneven.eu/howto-install-windows-on-your-ovh-vps/

«1

Comments

  • Nice tip and tutorial for newbies.

    Sakam.Host - If you need a quality web hosting, visit us and see why we are your solution.

  • NekkiNekki Moderator

    @SakamHost said:
    Nice tip and tutorial for newbies. I'm only posting this to inflate my post count.

    Fixxed.

    Here lies Nekki. He loved massive amounts of storage, K-Pop and calling people cunts.

  • jvnadrjvnadr Member
    edited April 2017

    I'm only posting this to inflate my post count.

    The irony is that one of his 5 shitty comments, this one, is about praising pirated software - and he is (dear god) a "provider" himself!

    The others? Hold and laugh:

    First time i heard about this service. (topic: Plivo forgot to renew domain plivo.com)
    Open ticket and offcourse they should do refund if you respect their policy. (topic: Does Vultr do a refund ?).
    Why they are not working? (topic: in .store domains not working??) (EPIC)

    And the Legen - wait for it - dary:

    I like the rules but 14 days to wait just to make an ads is bad idea.
    This posted in topic "Rules for selling on LowEndTalk"!

  • @BlazeMuis Could you create a Windows 10 template as well?

  • BlazeMuisBlazeMuis Member
    edited April 2017

    @brueggus said:
    @BlazeMuis Could you create a Windows 10 template as well?

    I'm working on it :) Should be done soon.

    Edit: Done :)

    Windows 10 Pro:

     wget -O- 'http://mirror.uneven.eu/vps/W10_Pro_OVH_VPS.gz' | gunzip | dd of=/dev/sdb
  • TarZZ92TarZZ92 Member

    Does not work for my testing. results in a failed boot to windows recovery however my old templates with VIRTIO work fine. did you forget to add virtio drivers?

    I AM BACK :)
    Working Windows Server 2012 R2 on 6GB! Beat that!

  • @TarZZ92 said:
    Does not work for my testing. results in a failed boot to windows recovery however my old templates with VIRTIO work fine. did you forget to add virtio drivers?

    Strange, I tested them all on SSD VPS 1.

  • TarZZ92TarZZ92 Member

    BlazeMuis said: Strange, I tested them all on SSD VPS 1.

    i am using VPS SSD 3 and all failed for some reason. carnt seem to find the cause but the recovery console says something about unable to find recovery partition.

    I AM BACK :)
    Working Windows Server 2012 R2 on 6GB! Beat that!

  • dnwkdnwk Member

    Is it because missing VirtIO?

    Designers: www.linkun.info

  • hostnoobhostnoob Member
    edited May 2017

    @TarZZ92 said:

    BlazeMuis said: Strange, I tested them all on SSD VPS 1.

    i am using VPS SSD 3 and all failed for some reason. carnt seem to find the cause but the recovery console says something about unable to find recovery partition.

    https://www.lowendtalk.com/discussion/112692/updated-windows-on-ovh-vps-ssd#latest

    Maybe this?

    For those of you that have the newer VPSs that use the sdb instead of VDB joodle beat me to it for making templates for those https://www.lowendtalk.com/discussion/112860/howto-install-windows-on-your-ovh-vps#latest

    You need VDB from the other thread?

    Favourite host in general: Ramnode (affiliate link)
    Favourite host for hourly billing/custom ISOs: Vultr ($50 free credit for new accounts, affiliate link)

  • dnwkdnwk Member

    I have same problem

    @TarZZ92 said:

    BlazeMuis said: Strange, I tested them all on SSD VPS 1.

    i am using VPS SSD 3 and all failed for some reason. carnt seem to find the cause but the recovery console says something about unable to find recovery partition.

    Designers: www.linkun.info

  • GamerTech24GamerTech24 Member
    edited May 2017

    do lsblk while booted into rescue mode, and post back here with the results.

    Does your lsblk say vdb or sdb?

  • If the install doesn't work @ OVH VPS, check the link in my signature. Windows eval is allowed and can be installed via VNC/ISO.

  • Issam2204Issam2204 Member
    edited May 2017

    A little bit OT, as nt completely related with OVH VPS, but with Hetzner: the primary partition (where the C: partition reside) is MBR, thus limiting partitions on a disk to be a total of 2TB. But Hetzner offers 2 disk each 3TB. I have around 760 GB lost because of this.

    Do you think it is possible to create a template with that fix?

  • @Issam2204 said:
    A little bit OT, as nt completely related with OVH VPS, but with Hetzner: the primary partition (where the C: partition reside) is MBR, thus limiting partitions on a disk to be a total of 2TB. But Hetzner offers 2 disk each 3TB. I have around 760 GB lost because of this.

    Do you think it is possible to create a template with that fix?

    Yeah you could dd over a GPT disk image, or at least I think you can do that with dd, I may be wrong though

  • teamaccteamacc Member

    @Issam2204 said:
    A little bit OT, as nt completely related with OVH VPS, but with Hetzner: the primary partition (where the C: partition reside) is MBR, thus limiting partitions on a disk to be a total of 2TB. But Hetzner offers 2 disk each 3TB. I have around 760 GB lost because of this.

    Do you think it is possible to create a template with that fix?

    GPT requires UEFI boot, which should be enabled in the bios. You could possibly access that by asking hetzner for a LARA

    I like my uptime down low and my servers all hacked. Can see me droppin' twenty-fours with a router in the rack.
    Ya like ya Switch-Ports hot and ya servers all hacked. If ya pings real high and ya networks pitch black.

  • TarZZ92TarZZ92 Member

    dnwk said: Is it because missing VirtIO?

    am willing to bet that is the issue here. unless it's compressed bad because my templates seem to work fine (all uncompressed and virtio) so unable to confirm.

    I AM BACK :)
    Working Windows Server 2012 R2 on 6GB! Beat that!

  • dnwkdnwk Member
    edited May 2017

    Ok. I figure out you need VirtIO-SCSI to be able to run it at OVH VPS. I create one myself using Proxmox and loaded up all those VirtIO drivers. It works.
    I create my template based on this tutorials
    https://joodle.nl/how-to-create-your-own-windows-template-for-kimsufi/

    You don't have to do everything it says you need to do. But basically, install a server and use DD to create the package.

    Thanked by 1xanimewolf

    Designers: www.linkun.info

  • TarZZ92TarZZ92 Member

    thought it was virtio related..

    I AM BACK :)
    Working Windows Server 2012 R2 on 6GB! Beat that!

  • rowboatrowboat Member

    @TarZZ92 said:
    Does not work for my testing. results in a failed boot to windows recovery however my old templates with VIRTIO work fine. did you forget to add virtio drivers?

    Hello there. I am having the same issue here even after 2 attempts. Would you care to share a working template?

  • TarZZ92TarZZ92 Member
    edited May 2017

    rowboat said: Hello there. I am having the same issue here even after 2 attempts. Would you care to share a working template?

    i cannot share it however i will install it for you if you wish?

    PM me if you interested.

    I AM BACK :)
    Working Windows Server 2012 R2 on 6GB! Beat that!

  • WHTWHT Member

    Not working for me also. Tried the Win 10 and Win 7. @TarZZ92 can you please share the template?

  • TarZZ92TarZZ92 Member

    no sorry it's for my internal purposes only however i can install it for you via rescue system (need ssh details) just PM me

    I AM BACK :)
    Working Windows Server 2012 R2 on 6GB! Beat that!

  • WHTWHT Member

    @TarZZ92 said:
    no sorry it's for my internal purposes only however i can install it for you via rescue system (need ssh details) just PM me

    Just post me the template url to wget it and then rename it. Dont be a di...

  • TarZZ92TarZZ92 Member

    WHT said: Just post me the template url to wget it and then rename it. Dont be a di...

    Nope sorry.

    I AM BACK :)
    Working Windows Server 2012 R2 on 6GB! Beat that!

  • rowboatrowboat Member

    @BlazeMuis sorry but could you possibly see what's the problem with your template? It launches the OS into recovery mode, I tried both WS 2008 and 2012. And it seems like I'm not the only one having this issue.

    Thank you very much!

  • WHTWHT Member

    @TarZZ92 said:

    WHT said: Just post me the template url to wget it and then rename it. Dont be a di...

    Nope sorry.

    flaged

  • AuroraZAuroraZ Member

    This might be a stupid question and forgive me if it is, but do you need a license key for these for work?

    Catch me over at Primary DNS. If you want to chat I am done with this cesspool.

  • TarZZ92TarZZ92 Member

    WHT said: flaged

    flaged

    I AM BACK :)
    Working Windows Server 2012 R2 on 6GB! Beat that!

  • TarZZ92TarZZ92 Member

    AuroraZ said: but do you need a license key for these for work?

    Yes.

    I AM BACK :)
    Working Windows Server 2012 R2 on 6GB! Beat that!

  • No boot device found / missing operating system after second/third reboot from the OVH panel. As long as you only reboot from windows itself, everything works.
    Anyone knows solution to this problem? I described it here: https://www.lowendtalk.com/discussion/114445/no-bootable-device-after-reboot#latest

  • I tried installing, but it is showing as not enough space.. I thought it will work for 10 GB ones :/ Can you help me on that?

  • @jylee1997123 said:
    I tried installing, but it is showing as not enough space.. I thought it will work for 10 GB ones :/ Can you help me on that?

    No, I'm afraid not.

    (Not a bad necro for your first comment.)

    "Linux will run happily with only 4 MB of RAM, including all of the bells and whistles such as the X Window System, Emacs, and so on." (M. Welsh & L. Kaufman, Running Linux, 2e, 1996, p. 32)

  • Someone would need to make a dd image of vda1/sdb1 that is 9GB or so, so it fits when you restore it correctly. I managed to do that in the past, it was tricky though and Windows 10/Server 2016 would run out space quickly. The older OS's, when not trying to download updates, would work fine, but database corruption, etc can happen on a full disk when trying to write while 0 bytes free, so I wouldn't advise it. I've had it happen to me before

  • links are not working. please fix.

  • ClouviderClouvider Member, Provider

    What with all this necros ?!

    Thanked by 2FoxelVox WSS

    Clouvider Limited - Leading Hosting & Connectivity Partner || Dedicated Server Sale from £45/m - Our Latest LET Offer

    Cloud Web Hosting | SSD & SAS HA OnApp VPS | US, UK, NL & DE Dedicated Servers | Network Services | Colocation | Managed Services

  • Harsh223Harsh223 Member
    edited September 2017

    @satya said:
    links are not working. please fix. <

    Links aint working coz he is banned :P

  • WSSWSS Member
    edited September 2017

    @Clouvider said:
    What with all this necros ?!

    For whatever reason, the Vanilla parser removes the timestamp jump. Seek to 46s.

  • Thanks

  • todontodon Member

    Links off, anybody could fix it ??
    anybody knows how to make own template ? I need help

  • Down, not across.

  • @todon said:
    Links off, anybody could fix it ??
    anybody knows how to make own template ? I need help

    Dude, did you sign up just to necro old threads?

    "Linux will run happily with only 4 MB of RAM, including all of the bells and whistles such as the X Window System, Emacs, and so on." (M. Welsh & L. Kaufman, Running Linux, 2e, 1996, p. 32)

  • Also, install netbsd.

  • FAT32FAT32 Administrator, Deal Compiler Extraordinaire

    @todon said:
    Links off, anybody could fix it ??
    anybody knows how to make own template ? I need help

    Create your own thread, or get a real license like a man.

    "Everyone you meet is fighting a battle you know nothing about. Be kind. Always."

  • @FAT32 said:

    @todon said:
    Links off, anybody could fix it ??
    anybody knows how to make own template ? I need help

    Create your own thread, or get a real license like a man.

    But last-minute drivers are hard!

    Thanked by 1FAT32
  • todontodon Member

    @FAT32 said:

    @todon said:
    Links off, anybody could fix it ??
    anybody knows how to make own template ? I need help

    Create your own thread, or get a real license like a man.

    Is this the treatment for new users? good to know !!

  • FAT32FAT32 Administrator, Deal Compiler Extraordinaire

    @todon said:
    Is this the treatment for new users? good to know !!

    I guess I will be nice a bit.

    1) Necro old thread doesn't help, try to create a new thread and explain what you want
    2) Most of the time you should just use the control panel to reinstall Windows unless you running a dedicated server. But if that's the case you don't need a custom ISO.

    "Everyone you meet is fighting a battle you know nothing about. Be kind. Always."

  • chrisuchrisu Member

    - this happends to me all the time

  • @chrisu said:
    - this happends to me all the time

    Try to upload the image to a website that doesn't require TLS.

  • Hello,
    Sir linknot work

Sign In or Register to comment.