Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Subscribe to our newsletter

Advertise on LowEndTalk.com

Latest LowEndBox Offers

    Someone Take a Look at My.cnf MySQL File - High MYSQL Ram Usage
    New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

    Someone Take a Look at My.cnf MySQL File - High MYSQL Ram Usage

    GM2015GM2015 Member
    edited August 2015 in Help

    Seeing people running around on unimaginable low mysql usage cases on low ram boxes, I'm wondering why mysql is using seemingly so much FNG ram.

    image

    I hope that's visible. I'd like to know how to configure mysql to run optimised on my Digitalocean server.

    Here's my.cnf:

    [email protected]:~$ cat /etc/mysql/my.cnf
    #
    # The MySQL database server configuration file.
    #
    # You can copy this to one of:
    # - "/etc/mysql/my.cnf" to set global options,
    # - "~/.my.cnf" to set user-specific options.
    #
    # One can use all long options that the program supports.
    # Run program with --help to get a list of available options and with
    # --print-defaults to see which it would actually understand and use.
    #
    # For explanations see
    # http://dev.mysql.com/doc/mysql/en/server-system-variables.html
    
    #ref http://stackoverflow.com/questions/1178736/mysql-maximum-memory-usage
    table_definition_cache = 400 < -- mysql doesn't restart with this uncomment, but reloads fine with service mysql reload .. hmpf
    
    # This will be passed to all mysql clients
    # It has been reported that passwords should be enclosed with ticks/quotes
    # escpecially if they contain "#" chars...
    # Remember to edit /etc/mysql/debian.cnf when changing the socket location.
    [client]
    port            = 3306
    socket          = /var/run/mysqld/mysqld.sock
    
    # Here is entries for some specific programs
    # The following values assume you have at least 32M ram
    
    # This was formally known as [safe_mysqld]. Both versions are currently parsed.
    [mysqld_safe]
    socket          = /var/run/mysqld/mysqld.sock
    nice            = 0
    
    [mysqld]
    #
    # * Basic Settings
    #
    user            = mysql
    pid-file        = /var/run/mysqld/mysqld.pid
    socket          = /var/run/mysqld/mysqld.sock
    port            = 3306
    basedir         = /usr
    datadir         = /var/lib/mysql
    tmpdir          = /tmp
    lc-messages-dir = /usr/share/mysql
    skip-external-locking
    #
    # Instead of skip-networking the default is now to listen only on
    # localhost which is more compatible and is not less secure.
    bind-address            = 127.0.0.1
    #
    # * Fine Tuning
    #
    key_buffer              = 8M
    max_allowed_packet      = 16M
    thread_stack            = 128K
    thread_cache_size       = 4
    # This replaces the startup script and checks MyISAM tables if needed
    # the first time they are touched
    myisam-recover         = BACKUP
    #max_connections        = 100
    #table_cache            = 64
    #thread_concurrency     = 10
    #
    # * Query Cache Configuration
    #
    query_cache_limit       = 512K
    query_cache_size        = 8M
    #
    # * Logging and Replication
    #
    # Both location gets rotated by the cronjob.
    # Be aware that this log type is a performance killer.
    # As of 5.1 you can enable the log at runtime!
    #general_log_file        = /var/log/mysql/mysql.log
    #general_log             = 1
    #
    # Error log - should be very few entries.
    #
    log_error = /var/log/mysql/error.log
    #
    # Here you can see queries with especially long duration
    #log_slow_queries       = /var/log/mysql/mysql-slow.log
    #long_query_time = 2
    #log-queries-not-using-indexes
    #
    # The following can be used as easy to replay backup logs or for replication.
    # note: if you are setting up a replication slave, see README.Debian about
    #       other settings you may need to change.
    #server-id              = 1
    #log_bin                        = /var/log/mysql/mysql-bin.log
    expire_logs_days        = 10
    max_binlog_size         = 100M
    #binlog_do_db           = include_database_name
    #binlog_ignore_db       = include_database_name
    #
    # * InnoDB
    #
    # InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
    # Read the manual for more InnoDB related options. There are many!
    #
    # * Security Features
    #
    # Read the manual, too, if you want chroot!
    # chroot = /var/lib/mysql/
    #
    # For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
    #
    # ssl-ca=/etc/mysql/cacert.pem
    # ssl-cert=/etc/mysql/server-cert.pem
    # ssl-key=/etc/mysql/server-key.pem
    
    
    
    [mysqldump]
    quick
    quote-names
    max_allowed_packet      = 16M
    
    [mysql]
    #no-auto-rehash # faster start of mysql but no tab completition
    
    [isamchk]
    key_buffer              = 16M
    
    #
    # * IMPORTANT: Additional settings that can override those from this file!
    #   The files must end with '.cnf', otherwise they'll be ignored.
    #
    !includedir /etc/mysql/conf.d/
    
    

    I'm a peasant so have mercy on me.

    Willing to cooperate to show command outputs if that helps.

    Edit: server runs on Digitalocean 1GB Plan with free serverpilot and minimal personal customisation made by me.

    Server runs 2 domains, 1 empty, one having wordpress in root, piwik and owncloud in subfolders, so 3 db-s in total on server.

    Mysql is on localhost.

    Go give Vultr(referral) a try. | GNU/Linux http://debian.org

    Comments

    • GM2015 said: Willing to cooperate to show command outputs

      Ah how kind of you

      But really, what's wrong with 92MB RAM?

      Thanked by 1GM2015
    • I'm trying to optimise. Seeing people running sites on servers with lower amount of ram, I see no reason why I shouldn't try to optimise.

      Plus, the server barely gets any visitors.

      classy said: Ah how kind of you

      But really, what's wrong with 92MB RAM?

      Go give Vultr(referral) a try. | GNU/Linux http://debian.org

    • ALinuxNinjaALinuxNinja Member
      edited August 2015

      If this is the standard mysql, add the following under [mysql] block

      performance_schema = 0

      Thanked by 1GM2015

      Devops Consultant | GitHub

    • budi1413budi1413 Member
      edited August 2015

      Add this

      ignore-builtin-innodb
      

      Restart mysql. Tadaa.

      edit: Use nginx + ph5-fpm for lower ram usage.

      Thanked by 1GM2015
    • endor:~# cat > /etc/mysql/conf.d/lowendbox.cnf<br /> [mysqld]<br /> key_buffer = 16K<br /> max_allowed_packet = 1M<br /> table_cache = 4<br /> sort_buffer_size = 64K<br /> read_buffer_size = 256K<br /> read_rnd_buffer_size = 256K<br /> net_buffer_length = 2K<br /> thread_stack = 64K<br /> skip-bdb<br /> skip-innodb

      Taken from http://lowendbox.com/blog/yes-you-can-run-18-static-sites-on-a-64mb-link-1-vps/

      Thanked by 2Jeffrey GM2015
    Sign In or Register to comment.