Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Setting up proxmox VPS with additional IP
New on LowEndTalk? Please Register and read our Community Rules.

Setting up proxmox VPS with additional IP

Hello,

I have never used proxmox before and I'm not being able to assign additional IPs to proxmox VPSs.
My server is in Delimiter and I have the following configuration:

Hostname: dedicated.multygroup.org

Server IP: 199.yyy.yyy.yyy

Netmask: 255.255.255.192

Server Gateway: 199.yyy.yyy.zzz

Additional IPs:

209.xxx.xxx.x6

209.xxx.xxx.x7

209.xxx.xxx.x8

209.xxx.xxx.x9

Please help me

I was once LowEndBoss

Comments

  • Also, I only have Windows VPS by now.

    Today I tried to create an OpenVZ CentOS VPS, and got this errors:


    Directory /proc/vz not found, assuming non-OpenVZ kernel

    Container init failed: Cgroup is not mounted

    TASK ERROR: command 'vzctl --skiplock create 101 --ostemplate /var/lib/vz/template/cache/centos-6-standard_6.3-1_i386.tar.gz --private /var/lib/vz/private/101' failed: exit code 5

    I was once LowEndBoss

  • You must run kernel with OpenVZ support if you want create OpenVZ VPS.

  • What does uname -a print? As tux says, make sure you're booted into the 2.6.32-pve kernel. For reference, mine is:

    Linux bugsy 2.6.32-26-pve #1 SMP Mon Oct 14 08:22:20 CEST 2013 x86_64 GNU/Linux

    Once you get that straight, using your additional IP addresses depends on how your host networking is setup and the virtualization used. I have a Delimiter dedicated also, and the additional IP's are /32's routed to your machine. To make use of them with openvz and a venet interface, just assign the guest an IP in the Proxmox UI and everything magically works.

    If the guest is Windows/KVM and you want to give it one of your external internet-facing additional IP's, one way you can achieve that is by creating a bridge on the host, assigning that bridge to the VM in Proxmox, and routing the additional IP's to the bridge. The additional interface would look something like this:

    auto vmbr1 iface vmbr1 inet static address 199.XXX.XXX.XXX netmask 255.255.255.XXX bridge_ports none bridge_stp off bridge_fd 0 up ip route add 209.XXX.XXX.XXX/32 dev vmbr1 down ip route del 209.XXX.XXX.XXX/32 dev vmbr1

    Where 199.XXX.XXX.XXX is your host IP and 209.XXX.XXX.XXX are your additional IP's. I'm using this setup with KVM guests and it seems to work fine.

    Thanked by 3xphones ct_tx Mark_R
  • @luissousa have pm'ed you

  • Hi, I have the same problem. can anyone give me some url or tutorial about it.
    I've create VM, install the debian manually via console and insert one of additional ip to /etc/network/interfaces.

    But i still can't access vps which I've created via ssh/putty.

    @dabtech
    How to creating a bridge on the host, assigning that bridge to the VM in Proxmox, and routing the additional IP's to the bridge.?

  • @xphones

    Creating the interface vmbr1 in /etc/network/interfaces creates the bridge on the host, and prefixing the name of the bridge with 'vm' should make it available to assign to the network interface of the guest in Proxmox. The route for the additional IP is also taken care of in that example interfaces file excerpt I posted.

    Is the bridged interface up and active on the host?

  • xphonesxphones Member
    edited January 2014

    http://prntscr.com/2gg77j

    That's when I tried the bridge. :)

  • I've never tried creating a bridge in the Proxmox UI. Edit the /etc/network/interfaces files as shown, and then 'ifup vmbr1' from the command prompt. Then you can assign the bridge to a guest in Proxmox.

  • xphonesxphones Member
    edited January 2014

    It's my edited interfaces

    http://pastebin.com/BrZmYyY1

    command 'ifup vmbr1' the result is Ignoring unknown interface vmbr1=vmbr1.

    I have rebooted node for several time too.

  • Sent you a PM.

  • pbalazs123pbalazs123 Member
    edited January 2014

    @xphones

    Just modify one line in your /etc/vz/vz.conf file to this:

    NEIGHBOUR_DEVS=ALL

    Reboot...

    And voila, your other IPs will work with the containers.

    No need to add another bridge device if you want to assign additional IPs to your containers. You only need that if you need to assign internal (192.168.x.x) or whatever address to your CTs.

    Delete all bridge devices except vmbr0, and assign the IPs directly to your containers instead.

    If you assign your additional IPs to your bridge interfaces then you will lose the IPs.

    Ramnode (referral link)

  • ct_txct_tx Member, Provider
    edited January 2014

    Thank you all for this very helpful post. Gathering from the various individual messages, this is the procedure I am using to setup Proxmox and VMs using the "Create VM" option in Proxmox:

    Step 1: Edit /etc/network/interfaces on the proxmox host to add the following:

    auto vmbr1

    iface vmbr1 inet static

    address 199.xxx.xxx.xxx

    netmask 255.255.255.255

    bridge_ports none

    bridge_stp off

    bridge_fd 0

    up ip route add 209.yyy.yyy.yyy/32 dev vmbr1

    down ip route del 209.yyy.yyy.yyy/32 dev vmbr1

    auto vmbr2

    iface vmbr2 inet static

    address 199.xxx.xxx.xxx

    netmask 255.255.255.255

    bridge_ports none

    bridge_stp off

    bridge_fd 0

    up ip route add 209.zzz.zzz.zzz/32 dev vmbr2

    down ip route del 209.zzz.zzz.zzz/32 dev vmbr2

    etc.

    Step 2. In the virtual machine itself, run the following

    ifconfig eth0 209.xxx.xxx.xxx netmask 255.255.255.255

    route add 199.xxx.xxx.xxx dev eth0

    route add default gw 199.xxx.xxx.xxx

    where

    199.xxx.xxx.xxx is the Proxmox host and 209.xxx.xxx.xxx, etc. are the allocated IP addresses.

    I would appreciate if anyone could comment on potential problems or errors with the procedure outlined above.

    Regards,

    ct_tx

  • same problem with me...
    i was follow procedure

    Edit /etc/network/interfaces

    auto vmbr1
    iface vmbr1 inet static
    address 199.xxx.xxx.xxx
    netmask 255.255.255.255
    bridge_ports none
    bridge_stp off
    bridge_fd 0
    up ip route add 209.yyy.yyy.yyy/32 dev vmbr1
    down ip route del 209.yyy.yyy.yyy/32 dev vmbr1

    then create VM, after that install centos.. give command my vps :
    ifconfig eth0 209.xxx.xxx.xxx netmask 255.255.255.255
    route add 199.xxx.xxx.xxx dev eth0
    route add default gw 199.xxx.xxx.xxx

    sucessfull when i ping my vps.. but every restart VM / Restart Network my VM always back disconnect from internet.

  • If you are not able to create vms at all:

    Check if you are booted into ovz kernel by running > uname -r

    check if selinux is enabled. if enabled, disable it > getenforce

    if you can start the vps but no networking

    in this condition you need to check first if the additional ip pool are on same subnet. if yes then it is easy just config your vm manager with provided gateway (usually your dedi ip).

    If not you need to create an alias on dedi using one of the pool ip and route eth1:0 through the alias in openvz instead of default network

  • zionvps said: if you can start the vps but no networking

    in this condition you need to check first if the additional ip pool are on same subnet. if yes then it is easy just config your vm manager with provided gateway (usually your dedi ip).

    i cant place subnetmask 255.255.255.255 from my provider..

    my vps work nice.. but every reboot my vps so i must reconfig again route network like this:
    ifconfig eth0 209.xxx.xxx.xxx netmask 255.255.255.255
    route add 199.xxx.xxx.xxx dev eth0
    route add default gw 199.xxx.xxx.xxx

  • that means you are forcing the vps to connect through your main eth0.
    it might work as temporary but it is the nature of openvz to reset network interface at every reboot to prevent ip stealing and other misconfiguration s done by client.
    what you need to do it is create an alias of et0 with any ip of the pool you got. then first ping the ip to make sure if it works.

    after that you need to edit the global config file at /etc/vz/vz.conf
    and uncomment this line "VE_ROUTE_SRC_DEV=eth0:your alias"

    then restart vz. after that in your default vz config script (solusvm or others) which create vps use the ip you used at alias as the default gateway

    @donext said:
    route add default gw 199.xxx.xxx.xxx

  • cfgguycfgguy Member, Provider

    proxmox is a pain use virtualizor instead.

    KGR

  • @zionvps thanks,, now its work...

    @cfgguy i was try virtualizor and sent ticket my problem to support virtualizor but they cant help,,
    also they lack tutorial,, you can see forum softaculous, most people ask for help problem but support always ask to submit ticket your problem,,

    i like WHT LEB and other forum i can see many problem and share how to solve any problem...

  • cfgguycfgguy Member, Provider

    I never used their support and running close to 40 vps on virtualizor. No issues at all

    KGR

  • @cfgguy you may luck have much knowledge,, im still learn about add IP route, networking..
    i have some problem like this with virtualizor, i was ask support and they cant help this.. also search find with google and cant find how to solve this problem..

Sign In or Register to comment.