Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
vultr BGP session with full table - not working...
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

vultr BGP session with full table - not working...

TaKeNTaKeN Member
edited August 2017 in Providers
    Hello guys,
    I learning BGP and from beginning got strange problem with BGP on Vultr.
    Anyone got maybe running and working VPS with BGP session with full table?
    I try but all the time got it:

    [email protected]:~# birdc6 show protocol all France
    BIRD 1.6.3 ready.
    name     proto    table    state  since       info
    France   BGP      master   up     14:31:49    Established
      Description:    France link local
      Preference:     100
      Input filter:   ACCEPT
      Output filter:  REJECT
      Routes:         39351 imported, 0 exported, 39351 preferred
      Route change stats:     received   rejected   filtered    ignored   accepted
        Import updates:          39433          0          0         27      39406
        Import withdraws:           26          0        ---         19          7
        Export updates:          39407      39406          1        ---          0
        Export withdraws:            7        ---        ---        ---          0
      BGP state:          Established
        Neighbor address: XXXXX
        Neighbor AS:      XXXXX
        Neighbor ID:      XXXXX
        Neighbor caps:    refresh enhanced-refresh restart-able AS4
        Session:          external multihop AS4
        Source address:   XXXXX
        Hold timer:       186/240
        Keepalive timer:  64/80

[email protected]:~# ip -6 r s
2001:19f0:6801:246::/64 dev ens3 proto kernel metric 256  expires 2591784sec pref medium
fe80::/64 dev ens3 proto kernel metric 256  pref medium
default via fe80::fc00:ff:fe7b:e144 dev ens3 proto ra metric 1024  expires 1584sec hoplimit 64 pref medium


    My config looks like this:
    [email protected]:~# cat /etc/bird/bird6.conf
    router id XXXXX;
    # debug protocols all;
    protocol device {
    scan time 10;
    }

    protocol static {
    route XXXXX/128 via "ens3";
    import all;
    }

    protocol kernel {
    device routes;
    import none;
    scan time 15;
    }

    protocol bgp France
    {
    description "France link local";
    local as XXXXX;
    source address XXXXX;
    graceful restart on;
    multihop 2;
    neighbor XXXXX as XXXXX;
    password "XXXXX";
    import all;
    export none;
    }

    All other VPS working good but this one not at all.
    Only diffrence between this and others is they use DHCP and autoconfiguration for IPv6:
    allow-hotplug ens3
    iface ens3 inet dhcp
    iface ens3 inet6 auto

    Maybe someone know how to setup VULTR VPS to work with BIRD and Full Table?
    I open a ticket in VULTR but still don`t answer :-(

    Thanks & Best Regards
    Marek

Comments

  • WilliamWilliam Member, Provider
    edited August 2017

    TaKeN said: Anyone got maybe running and working VPS with BGP session with full table?

    Vultr does not in all regions deliver you a full table. This is all they have in FR.

  • patrick7patrick7 Member, LIR

    @William WRONG!

      Routes:         39351 imported, 0 exported, 39351 preferred
    

    The problem is you're not importing the routes to the kernel (vultr config example)

    RIPE NCC member | IPv4 & IPv6 & ASN: https://www.ipv4.ch/ | 5x /24 available |

  • WilliamWilliam Member, Provider

    patrick7 said: WRONG!

    That might be also (did not even read the config, just FR+<40k), they however still do not have a full table there.

    Verified myself (plus, we do run all locations, multiple accounts in each, for customers and ourself - FR and certain US always had no entire table, and Tokyo at some point as well).

  • try this .. net.ipv6.conf.all.accept_ra = 2

    Thanked by 1Spencer
  • TaKeNTaKeN Member
    edited August 2017
        @William in France they give full table. But like You see i get 39k but nothing
     go to kernel because of rejected no idea why...
    
        @patrick7 i use config from example and they don`t import anything there. 
    In example they just export all and nothing import or we got other configs in examples.
        If You got working example of config in Vultr with full table in kernel please share me.
    
        @Twinker same effect.
    
        [email protected]:~# sysctl -a |grep net.ipv6.conf.all.accept_ra
        net.ipv6.conf.all.accept_ra = 2
    
        [email protected]:~# ip -6 r s |grep ens3
        2001:19f0:6801:246::/64 dev ens3 proto kernel metric 256  expires 2591713sec pref medium
        fe80::/64 dev ens3 proto kernel metric 256  pref medium
        default via fe80::fc00:ff:fe7b:e144 dev ens3 proto ra metric 1024  expires 1513sec hoplimit 64 pref medium
    
        Best Regards
        Marek
    
  • gbshousegbshouse Member, Provider

    In protocol kernel change import none to import all

  • TaKeNTaKeN Member
    edited August 2017
    @gbshouse Heh i change this many times :P not working :P i give everything to import all and nothing but looks i do exacly like You say now:
    Look:
    
    [email protected]:~# cat /etc/bird/bird6.conf
    router id XXXXX;
    # debug protocols all;
    protocol device {
    scan time 10;
    }
    
    protocol static {
    route XXXXX/128 via "ens3";
    import all;
    }
    
    protocol kernel {
    device routes;
    import all;
    scan time 15;
    }
    
    protocol bgp France
    {
    description "France link local";
    local as XXXXX;
    source address XXXXX;
    graceful restart on;
    multihop 2;
    neighbor XXXXX as XXXXX;
    password "XXXXX";
    import all;
    export none;
    }
    
    
    [email protected]:~# ip -6 r s dev ens3
    2001:19f0:6801:246::/64 proto kernel metric 256  expires 2591714sec pref medium
    fe80::/64 proto kernel metric 256  pref medium
    default via fe80::fc00:ff:fe7b:e144 proto ra metric 1024  expires 1514sec hoplimit 64 pref medium
    
  • When i enable debug i got it:

    Aug 19 20:07:39 fr-bgp bird6: France > added [best] 2a01:8840:87::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: kernel1 < filtered out 2a01:8840:87::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France < rejected by protocol 2a01:8840:87::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France > added [best] 2a01:8840:84::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: kernel1 < filtered out 2a01:8840:84::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France < rejected by protocol 2a01:8840:84::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France > added [best] 2001:500:c::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: kernel1 < filtered out 2001:500:c::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France < rejected by protocol 2001:500:c::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France > added [best] 2a01:8840:8b::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: kernel1 < filtered out 2a01:8840:8b::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France < rejected by protocol 2a01:8840:8b::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France > added [best] 2a01:8840:88::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: kernel1 < filtered out 2a01:8840:88::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France < rejected by protocol 2a01:8840:88::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France > added [best] 2a01:8840:8f::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: kernel1 < filtered out 2a01:8840:8f::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France < rejected by protocol 2a01:8840:8f::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France > added [best] 2001:500:b::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: kernel1 < filtered out 2001:500:b::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France < rejected by protocol 2001:500:b::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France > added [best] 2a01:8840:8c::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: kernel1 < filtered out 2a01:8840:8c::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France < rejected by protocol 2a01:8840:8c::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France > added [best] 2a01:8840:93::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: kernel1 < filtered out 2a01:8840:93::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France < rejected by protocol 2a01:8840:93::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: France > added [best] 2001:500:16::/48 via 2001:19f0:ffff::1 on ens3
    Aug 19 20:07:39 fr-bgp bird6: kernel1 < filtered out 2001:500:16::/48 via 2001:19f0:ffff::1 on ens3
    [CUT]
    
  • patrick7patrick7 Member, LIR
    edited August 2017

    If you consider switching, then for sure not to quagga but FRR.
    You should have "import all" and "export all" in the kernel section.

    RIPE NCC member | IPv4 & IPv6 & ASN: https://www.ipv4.ch/ | 5x /24 available |

  • @gbshouse i know i can switch to Quagga but i want learn verry good BIRD... This is for EDU/Research not for production :-)

    @patrick7 I try export/import everything and same effect...

    So i ask again: Anyone here got it or know how to run on VULTR BGP IPv6 session with full table on BIRD and properly import all 40k+ prefixes to kernel?

  • patrick7patrick7 Member, LIR
    edited August 2017

    I have a running BGP setup (not with vultr, but doesn't matter) with bird. Try adding the "learn":

    protocol kernel {
      scan time 20;
      device routes;
      learn;
      import all;
      export all;
    }
    

    RIPE NCC member | IPv4 & IPv6 & ASN: https://www.ipv4.ch/ | 5x /24 available |

  • TaKeNTaKeN Member
    edited August 2017

    @patrick7 Nope problem was with protocol static.

    Topic to close i find a way.

  • ClouviderClouvider Member, Provider

    It would be a good custom if you had shared it for others who might have a problem like that in the future. After all you asked for help here.

    Thanked by 4Zerpy Shade FHR malek

    Clouvider Limited - Leading Hosting Provider & Connectivity Partner || Dedicated Server Sale - Our Latest LET Offer

    Cloud Web Hosting | SSD & SAS HA OnApp VPS | UK, NL & DE Dedicated Servers | Network Services | Colocation | Managed Services

Sign In or Register to comment.