CentOS Web Panel VS Vestacp , your opinion?

CentOS Web Panel VS Vestacp , your opinion?

Hello,

I use WHM/Cpanel on my servers/VPS.

For personal projects, I use CentOS Web Panel.

Here are the advantages for me:

Easy to install.

Choice of PHP, php 4.4, 5.2, 5.3, 5.4,5,5,5,6,7,0, and 7.1

Choice of webserver, Apache Only, Apache & Nginx Reverse Proxy, Apache & Varnish Cache,

The pro version costs $ 10 a year

I was advised VestaCP because CentOS Web Panel has security problems?

What do you weigh?

Do you have another panel to advise me.

Thank you for your help

What is the best?
  1. What is the best panel with multiple PHP?39 votes
    1. CentOS Web Panel
      17.95%
    2. Vestacp
      69.23%
    3. Other (please specify in comment).
      12.82%

Comments

  • VestaCP on CentOS ain't any better if you opt to use VestaCP's provided CentOS Apache package which is 2.5yrs old and outdated https://community.centminmod.com/threads/vestacp-ouch-no-http-2-and-outdated-apache.10114/

    * Centmin Mod Project (HTTP/2 support + ngx_pagespeed + Nginx Lua + Vhost Stats)
    * Centmin Mod LEMP Stack Quick Install Guide
    Thanked by 1comeback
  • MikeAMikeA Member, Provider
    edited July 2017

    I prefer VestaCP's interface compared to CentOSWebPanel since it's not as bloated (at least last time I used it), but like @eva2000 said.. the apache on it is super old now. 2.4.6 is still latest.

    ExtraVM DDoS Protected VPS

    Thanked by 2comeback eva2000
  • eva2000eva2000 Member
    edited July 2017

    MikeA said: the apache on it is super old now. 2.4.6 is still latest.

    Indeed, if VestaCP is going to build their own Apache rpms, at least keep them up to date. Centmin Mod has Apache 2.4 + PHP-FPM integration support on it's to do list in future just not right now https://community.centminmod.com/threads/custom-apache-2-4-rpms-for-centmin-mod-lemp-stack.4471/. Centmin Mod dev dashboard https://github.com/centminmod/centminmod/projects/1

    * Centmin Mod Project (HTTP/2 support + ngx_pagespeed + Nginx Lua + Vhost Stats)
    * Centmin Mod LEMP Stack Quick Install Guide
  • comebackcomeback Member
    edited July 2017

    @eva2000 said: VestaCP on CentOS ain't any better if you opt to use VestaCP's provided CentOS Apache package which is 2.5yrs old and outdated https://community.centminmod.com/threads/vestacp-ouch-no-http-2-and-outdated-apache.10114/

    Thank you for your reply,

    CentOS Web Panel is very fast for security updates.

    I love centminmod, congratulations for your work.

    I use centminmod on projects in production, where there is only one site.

    Thanked by 1eva2000
  • comeback said: I love centminmod, congratulations for your work.

    I use centminmod on projects in production, where there is only one site.

    always great to hear from a happy Centmin Mod user ^_^

    * Centmin Mod Project (HTTP/2 support + ngx_pagespeed + Nginx Lua + Vhost Stats)
    * Centmin Mod LEMP Stack Quick Install Guide
  • eva2000eva2000 Member
    edited July 2017

    comeback said: Choice of PHP, php 4.4, 5.2, 5.3, 5.4,5,5,5,6,7,0, and 7.1

    oh yeah Centmin Mod progress on multiple PHP-FPM concurrent versions https://community.centminmod.com/threads/addons-php71-sh-multiple-php-fpm-versions-work-preview.11900/ :)

    and PHP 7.2 testing - beta1 coming next week https://community.centminmod.com/threads/php-7-2-0-alpha3.12211/

    * Centmin Mod Project (HTTP/2 support + ngx_pagespeed + Nginx Lua + Vhost Stats)
    * Centmin Mod LEMP Stack Quick Install Guide
  • Quick question. What security problem on cwp ?

  • @yokowasis said: Quick question. What security problem on cwp ?

    I do not know, that's why I'm asking

  • jarjar Provider

    I'll sound like a broken record because I've said this a lot, but this is a personal perception issue that I just can't shake. I feel like it's not a perception to be ignored, because it comes from a place of pattern recognition in my head.

    CentOS Web Panel has a button to install TeamSpeak. A web hosting control panel has a button to insteall TeamSpeak. To me this just screams "Made by young gamers" which also has no correlation with "Strong security minded individuals" in my head. I could be entirely wrong, it's just stereotypes, but stereotypes are sometimes the result of your brain recognizing common patterns and assessing risk.

    Thanked by 2comeback Hxxx
  • @jarland said: I'll sound like a broken record because I've said this a lot, but this is a personal perception issue that I just can't shake. I feel like it's not a perception to be ignored, because it comes from a place of pattern recognition in my head.

    CentOS Web Panel has a button to install TeamSpeak. A web hosting control panel has a button to insteall TeamSpeak. To me this just screams "Made by young gamers" which also has no correlation with "Strong security minded individuals" in my head. I could be entirely wrong, it's just stereotypes, but stereotypes are sometimes the result of your brain recognizing common patterns and assessing risk.

    I'm looking for a free panel that allows you to choose several versions of PHP.

    For the moment the best has been CentOS Web Panel.

    But do you know another?

    Thank you

  • jarjar Provider

    Nope, can't think of another free one that lets you do that.

  • They are very active on FaceBook:

    https://www.facebook.com/centoswebpanel/

    And there are often updates

  • jarjar Provider

    One of those updates include a minecraft server installer yet? :P

  • comebackcomeback Member
    edited July 2017

    @jarland said: One of those updates include a minecraft server installer yet? :P

    Now there are:

    WHMCS Billing

    Softaculous

    Team Speak3

    Shoutcast Manager

    Torrent SeedBox

  • jarjar Provider

    Seedbox installer .... yeah I feel justified in calling it a kid panel now lol. I'm sorry but that does not give me confidence.

    Thanked by 1Hxxx
  • @eva2000 said: VestaCP on CentOS ain't any better if you opt to use VestaCP's provided CentOS Apache package which is 2.5yrs old and outdated https://community.centminmod.com/threads/vestacp-ouch-no-http-2-and-outdated-apache.10114/

    Apache security issues are only related to CentOS. Ubuntu 16.04 not affected by old software, and uses latest stable and up to date software with all actual security fixes. What about http2 support... VestaCP already has PR at GitHub which will be implemented in a next version. The problem why http2 is not implemented yet, because of a huge amount of distros support. In many cases on old systems, http2 support broke many things and crash them. The PR already under testing and will be as I know implemented in the next version which will be released soon.

  • BTW, latest version of HTTPD is 2.4.27.

    ..:: Kloxo-MR - hosting and forum ::..

  • ISPConfig3 allows you to install and select multiple php versions.

    Thanked by 1Falzo
  • desperand said: Apache security issues are only related to CentOS. Ubuntu 16.04 not affected by old software, and uses latest stable and up to date software with all actual security fixes.

    yeah hence why, i mentioned centos only issue

    CentOS 7.4/ Redhat 7.4 will have Openssl 1.0.2 rebase default system version for ALPN protocol support so HTTP/2 will be native.

    Just need a newer version of Apache for VestaCP on CentOS. Shouldn't be that hard to do https://community.centminmod.com/threads/custom-apache-2-4-rpms-for-centmin-mod-lemp-stack.4471/#post-52077

    on my CentOS 7.3 virtualbox test server with my custom Apache 2.4.27 rpms.

    httpd -V
    Server version: Apache/2.4.27 (CentOS)
    Server built:   Jul 10 2017 09:38:04
    Server's Module Magic Number: 20120211:68
    Server loaded:  APR 1.5.2, APR-UTIL 1.5.4
    Compiled using: APR 1.5.2, APR-UTIL 1.5.4
    Architecture:   64-bit
    Server MPM:     event
      threaded:     no
        forked:     yes (variable process count)
    Server compiled with....
     -D APR_HAS_SENDFILE
     -D APR_HAS_MMAP
     -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
     -D APR_USE_SYSVSEM_SERIALIZE
     -D APR_USE_PTHREAD_SERIALIZE
     -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
     -D APR_HAS_OTHER_CHILD
     -D AP_HAVE_RELIABLE_PIPED_LOGS
     -D DYNAMIC_MODULE_LIMIT=256
     -D HTTPD_ROOT="/usr"
     -D SUEXEC_BIN="/usr/sbin/suexec"
     -D DEFAULT_PIDLOG="/var/run/httpd.pid"
     -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
     -D DEFAULT_ERRORLOG="logs/error_log"
     -D AP_TYPES_CONFIG_FILE="/etc/httpd/conf/mime.types"
     -D SERVER_CONFIG_FILE="/etc/httpd/conf/httpd.conf"
    
    * Centmin Mod Project (HTTP/2 support + ngx_pagespeed + Nginx Lua + Vhost Stats)
    * Centmin Mod LEMP Stack Quick Install Guide
  • jvnadrjvnadr Member
    edited July 2017

    jarland said: CentOS Web Panel has a button to install TeamSpeak. A web hosting control panel has a button to insteall TeamSpeak. To me this just screams "Made by young gamers" which also has no correlation with "Strong security minded individuals" in my head.

    They also having a button to install and manage via their interface a full shoutcast server. And this is also unique as (with the exception of the SMI project that is in deep sleep for over 2 years now) there is no any free decent control panel for a shoutcast server...
    So, they maybe wanted to add some features that many free (and paid) control panels don't have, to place themselves better against the competitors.
    And I have to say, even if I am not using CWP (just had some testing for it and it is installed to one of my servers just for the easiness of shoutcast control) that I haven't heard anything serious related to security against CWP...

    jarland said: Nope, can't think of another free one that lets you do that.

    VestaCP with this: https://forum.vestacp.com/viewtopic.php?t=10854 . I have used it and it is quite good, no issues till now

    • If a program actually fits in memory and has enough disk space, it is guaranteed to crash.
    • If such a program has not crashed yet, it is waiting for a critical moment before it crashes.

Sign In or Register to comment.