Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on
ehlo command not found
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

ehlo command not found

Hey everyone!

So Im trying to install my own mailserver :D Im following a guide from Google for Debian and when I ehlo localhost, the console says command not found. May I pls know what is missing that I should install? @AuroraZ @jar


I'm stuck


  • webdevwebdev Member

    lol, you need telnet to your SMTP port, then type ehlo localhost

  • hehe so telnet wasnt installed? I will try to install it and report back. Thank you

    I'm stuck

  • @webdev telnet is already installed but still

    -su: ehlo: command not found

    I'm stuck

  • webdevwebdev Member

    that means telnet can't connect to your smtp port, so it's quit, you need type that in telnet...

  • webdevwebdev Member

    for example, telnet 80, and you will know what's it looks like...

    Thanked by 1timelapse
  • sanvitsanvit Member
    edited January 1

    You should telnet to localhost:25 (telnet localhost 25) then EHLO

    Thanked by 1timelapse
  • tetechtetech Member

    He is trying to type ehlo in a shell as a shell command rather than as part of SMTP protocol.

    Thanked by 1timelapse
  • Ohhhhh thank you everyone so ehlo is command of telnet not of the console! I tried it and it worked!

    I'm stuck

  • timelapsetimelapse Member
    edited January 1

    telnet localhost 25
    Connected to localhost.
    Escape character is '^]'.
    220 myhostname ESMTP Postfix (Debian/GNU)
    ehlo locahost
    250-SIZE 10240000
    250 SMTPUTF8

    I'm stuck

Sign In or Register to comment.