Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Running Firefox on a 128MB Linux VPS
New on LowEndTalk? Please Register and read our Community Rules.

Running Firefox on a 128MB Linux VPS

nbphuocnbphuoc Member
edited September 2011 in General

any Idea how can I run firefox smoothly on a VPS with 128 MB of RAM?

Comments

  • My 256MB VPS (OpenVZ) can barely handle it, although it does load a flash-based game every single time it loads. It uses about 180MB of RAM. I don't think it's going to be possible to run Firefox on a 128, at least not without using some burst RAM.

    Is there a particular reason you have to use Firefox (or any graphical web browser, for that matter) on your VPS?

  • kristalkristal Banned
    edited September 2011

    dont install heavy desktop environments and windows managers also a light vnc if u r using it remotely and install dropbear instead of normal ssh, that will save u some memory. as to the firefox alone, no idea, i use iceweasel

    apt-get install jwm xvt tightvncserver dropbear

  • why would you do that? make a ssh tunnel to your vps and put that in your firefox

    # ssh [email protected] -D 12345
    

    and put localhost:12345 in your local firefox as socks5 server.

    but if you really want for some reason to run firefox directly on your server, you can use X11Forwarding in ssh server. ("man sshd_config" for more info)

  • Which is the lightest desktop environment that firefox can run on?

  • nbphuoc said: Which is the lightest desktop environment that firefox can run on?

    umm.. dwm

  • kristalkristal Banned
    edited September 2011

    dwm is lightest, agreed, but not fully functional (no terminal)
    best IMO is jwm, used in puppy etc

  • LongShotLongShot Member
    edited September 2011

    Sure. I'm running minimal Debian 6, tightvncserver, LXDE and Iceweasel 3.5 (Debian's FireFox equivalent) using less than 70mb of my 128mb Hostigation KVM server.

    Thanked by 1klikli
  • Firefox worked fine on my 256MB KVM box (before I downgraded it to 128MB) over NX without a desktop env running but with my normal php, mysql and nginx setup running too.

    FreeVPS.us - The oldest post to host VPS provider
  • LongShotLongShot Member
    edited September 2011

    Here's a page from my cookbook:

    Make sure Debian is the latest and greatest

    apt-get update
    apt-get upgrade
    apt-get dist-upgrade
    

    Install X, desktop, VNC programs

    apt-get install xorg lxde-core tightvncserver
    

    Stop VNC

    tightvncserver -kill :1  
    

    Edit startup file

    nano ~/.vnc/xstartup  
    

    Change to

    #!/bin/sh
    xrdb $HOME/.Xresources
    xsetroot -solid black
    lxterminal &
    /usr/bin/lxsession -s LXDE &
    

    Restart VNC

    tightvncserver :1  
    

    I use the "VNC Free Edition Viewer for Windows Stand-Alone Viewer" from the downloads page at: http://www.realvnc.com

    Configure the viewer to access your VPS at: xxx.xxx.xxx.xxx:5901

    Enjoy!

  • maxexcloomaxexcloo Member
    edited September 2011

    LongShot said: Here's a page from my cookbook

    Any chance you can post the rest of it? It seems like you have some useful information :)

  • Any chance you can post the rest of it? It seems like you have some useful information :)

    LongShot's Three Rules for Success in Life:

    1. Don't get hurt.
    2. Look good.
    3. Take careful notes.
  • kristalkristal Banned
    edited September 2011

    WOW Longshot what a horribly terrible set up u got there!!!!

    also 70mb is terrible, u can save like 40mb memory by switching to jwm & xvt. LOL what a waste

    as i said before:

    apt-get install dropbear tightvncserver xvt jwm

    thats all u need, and its automatic no need to edit xresources or any other crap

  • kristal said: not fully functional (no terminal)

    what? you could use xterm (or any other term) am i missing something here?

  • then its dmw+xterm which is heavier than jwm itself(with build in terminal)
    just proves that jwm is the lightest thats all

  • circuscircus Member
    edited September 2011

    kristal said: build in terminal

    then, what's the xvt for? it's an xterm alternative right? -> http://packages.debian.org/squeeze/xvt

    if it's then you could replace xterm with xvt (dwm+xvt) CMIIW

    to be honest this is the first time i heard a wm with builtin terminal (and you don't even need it for firefox...)

  • xvt is a desktop session x terminal emulator (required to run desktop) uses 4,4 mb memory - the lightest, just after wterm

    jwm is a windows manager (required to run multiple windows)

    they come together for a fully functional multi window desktop, without jwm your desktop will be dull

    for firefox you are right, dwm+xvt would work (saving 2-3 mb from jwm+xvt)

  • also 70mb is terrible, u can save like 40mb memory by switching to jwm & xvt. LOL what a waste

    Thank you for your thoughtful comments! The 70mb includes Iceweasel. Debian/LXDE/tightvncserver, etc., etc. are running in less than 40mb. I like LXDE because it is an "official" Debian desktop and is well-integrated with the OS. For example, menus automatically reconfigure when you install new programs, and Debian includes some important utilities with the core installation. Decisions, decisions....

  • kristalkristal Banned
    edited September 2011

    true lxde is great, but not for low-mem vpses :P

    just fyi my base debian runs @ 3,5mb ram.

    vnc + desktop = total @ 10mb / with iceweasel its less than 20mb

    thats featherlight ;]

  • @kristal: Could you make a dpkg --get-selections > apps.txt and post the txt here? It would help me setting up such a damn small debian.

  • mrm2005mrm2005 Member
    edited September 2011

    My Setup (128MB VPS) :
    Debian Lenny + dropbear + iceweasel + tightvncserver + Blackbox

    Ram usage when running iceweasel (no flash site- 1 or 2 tabs) : around 25~30MB

    sometimes i use openbox instead of blackbox (both are very similar).

  • kristalkristal Banned
    edited September 2011

    reinstall debian 5 os, make sure its 32bit, then:

    apt-get install dropbear tightvncserver xvt jwm

    pico /etc/default/dropbear
    /// change NO_START=0

    mv /etc/rc2.d/S16ssh /etc/rc2.d/K16ssh

    /etc/init.d/ssh stop

    /etc/init.d/dropbear start

    apt-get --purge remove syslog-ng avahi-daemon cups dbus cron anacron rsyslog

    reboot

    Here u go, all bare naked debian with working vnc desktop windows manager and terminal :P

  • edited July 2012

    err
    sorry to bump an old thread,but i have followed kristal instructions
    and i got this
    http://i.imgur.com/t2ZjL.png

    is it normal?
    cause i cant click anything
    i am using free realvnc viewer (if i use tightvnc viewer,it say connection refused)
    sorry for the noob question

  • netomxnetomx Member, Moderator
    edited July 2012

    does it works? on mine, it crashes constantly about low memory ,using iceweasel or arora

    It seems that it doesn't install the xserver, and if I install xfce4, it iwill load by default

  • earlearl Member
    edited July 2012

    Someone should make an image of windows 98.. If I recall it use to work with just 4mb of ram complete with desktop and all!! wonder if win98 still works or if anyone still uses it?

  • netomxnetomx Member, Moderator

    @earl said: 4mb of ram

    that was a wild bad guess.. try 32. Win95, yeah, 4mb should be fine.

    Thanked by 2earl klikli
  • yomeroyomero Member
    Thanked by 1earl
  • earlearl Member
    edited July 2012

    @MeMyselfandLinux

    Just tried this on a 32mb VPS from ipxcore.. jwm would not start so I got the same as you with just a mouse cursor and nothing else so instead of jwm I installed flwm.. installed midori and iceweasel worked ok but it crashes when trying to watch flash so if you want to use it for just browsing it's fine. Just uninstall JWM and install flwm instead

    apt-get purge jwm xvt
    apt-get install flwm midori aterm

    -update:
    I got jwm to work by adding the entry "jwm &" right after "#!/bin/sh" from the file /username/.vnc/xstartup

  • hmm i already switched to fluxbox,and it run nicely
    thank you anyway :D

Sign In or Register to comment.