Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
Arch OpenVZ/SolusVM issue
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

Arch OpenVZ/SolusVM issue

thekreekthekreek Member
edited August 2011 in General

I been trying to setup an Arch based server, with the 2010.5 OpenVZ template from SolusVM.

After upgrading everything with pacman, if I reboot the server when I try to login again, the root password its not accepted, if the password gets changed with SolusVM it still the same the root password its not accepted.

I used the console to check if root user is allow to login, and yes its allowed.

This hasnt happen before on Debian or Ubuntu. Not sure if its a problem with the image or something else.

Comments

  • KuJoeKuJoe Member, Provider
    edited August 2011

    pty or tty errors (known issue along with the glibc bug)? If so install MAKEDEV and add the following to /etc/rc.local:

    /sbin/MAKEDEV tty
    /sbin/MAKEDEV pty
    
    -Joe @ SecureDragon - LEB's Powered by Wyvern in FL, CO, CA, IL, NJ, GA, OR, TX, and AZ
    Need backup space? Check out BackupDragon
  • no pty or tty errors, alredy using the glibc-vps from arch.

    But I will add those settings to see if it helps.

  • KuJoeKuJoe Member, Provider

    If it's not the pty or tty errors then I'm at a loss, I've used both the OpenVZ.org Arch templates and our custom templates without seeing a problem with passwords.

    -Joe @ SecureDragon - LEB's Powered by Wyvern in FL, CO, CA, IL, NJ, GA, OR, TX, and AZ
    Need backup space? Check out BackupDragon
  • FranciscoFrancisco Top Provider

    Are you sure your VPS can ping out?

    It's quite possible you have an IP conflict and are logging into the wrong VPS.

    Francisco

    BuyVM - Free DirectAdmin, Softaculous, & Blesta! / Anycast Support! / Windows 2008, 2012, & 2016! / Unmetered Bandwidth!
    BuyShared - Shared & Reseller Hosting / cPanel + Softaculous + CloudLinux / Pure SSD! / Free Dedicated IP Address
  • thekreekthekreek Member
    edited August 2011

    Finally I was able to solve it, i had a bad openssh config file.

    All the settings were on /etc/ssh/ssh_config when I should be using /etc/ssh/sshd_config

    But then I came to a new error, and this time tty related, the fix the KuJoe mention didnt work. This make me reconsider using Arch on OpenVZ, so i went back to Debian and now its time to compile the stuff I need.

    @KuJoe and @Francisco thanks for the tips.

  • KuJoeKuJoe Member, Provider

    My fix only works if MAKEDEV is installed. By default it is not installed on Arch Linux 2010.05 and is not in the default repos so you'll need to grab it from AUR.

    -Joe @ SecureDragon - LEB's Powered by Wyvern in FL, CO, CA, IL, NJ, GA, OR, TX, and AZ
    Need backup space? Check out BackupDragon
Sign In or Register to comment.