Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Subscribe to our newsletter

Advertise on LowEndTalk.com

Latest LowEndBox Offers

    Help for Proxmox 4.0
    New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

    Help for Proxmox 4.0

    A friend of mines is having a problem with proxmox, I have never dealt with it so I am looking for some help to assist him.

    This is the information he has given me.

    Dual X5650 XEON (24 cores)
    48 GB RAM
    500GB SSD
    1Gbps port

    Proxmox Virtual Environment: Version: 4.0-48/0d8559d0
    OS: http://lubuntu.net/
    Browser: chromium-browser

    I create each VM with the RAW format
    I create each VM with 4.5 Gigs of Disk Space
    I turned off Simple Cache for HTTP inside of chrome://flags
    I turned off all Updates for the OS

    I run chromium-browser with the following settings:

    --incognito
    --disk-cache-dir=/tmp/cache
    --process-per-site
    --disable-extensions
    --disable-sync-preferences
    --disable-application-cache
    --disable-cache
    --disable-gpu-program-cache
    --disable-gpu-shader-disk-cache
    --disable-offline-load-stale-cache
    --disable-backing-store-limit
    --disable-zero-copy
    --disable-prerender-local-predictor
    --disable-local-storage
    --disable-logging
    --disable-login-animations
    --disable-low-res-tiling
    --disable-offline-pages
    --disable-pinch
    --disable-popup-blocking
    --disable-session-crashed-bubble
    --disable-seccomp-filter-sandbox
    --disable-setuid-sandbox
    --disable-shared-workers
    --disable-site-engagement-service
    --disable-smooth-scrolling
    --disable-sync
    --disable-sync-app-list
    --disable-sync-backup
    --disable-sync-rollback
    --disable-sync-types
    --disable-tab-eviction
    --disable-threaded-animation
    --disable-threaded-scrolling
    --disable-timezone-tracking-option
    --disable-translate
    --disable-async-dns
    --disable-cloud-import
    --disable-component-update
    --disable-zero-copy
    --fast
    --dns-prefetch-disable
    

    Bridge is configured correctly

    Name: vmr0
    Type: Linux Bridge
    Active: Yes
    Autostart: Yes
    Ports/Slaves: eth0
    IP Address: x.x.x.x (This has the correct IP)
    Subnet mask: x.x.x.x (This has the correct Subnet Mask)
    Gateway: x.x.x.x (This has the correct Gateway)
    

    So once again, this is when all my VMs are made, it has been running for hours, and the left over disk space, just slowly starts going down.

    After all that, my disk space still slowly goes down. Can not figure out why. Any advice would be much appreciated. It goes down a lot more slow now, because of what I have done, but still goes down none of the less.

    Thanks!

    Zac U. - 20TBSSD.Com

    512MB-4096MB OpenVZ - Canada - 100Mbit Unmetered Plans - Starting at $8.00 per year - 100Gbps DDoS Mitigation Free.

    Comments

    • Nic_20TBSSD said: Dual X5650 XEON (24 cores) 48 GB RAM 500GB SSD 1Gbps port

      12 Cores.. not 24

      Thanked by 1GM2015

      I AM BACK :)
      Working Windows Server 2012 R2 on 6GB! Beat that!

    • @TarZZ92 said:

      Its quoted exactly from what he sent me so excuse the errors I did not want to change anything or possibly miss replay his message.

      Zac U. - 20TBSSD.Com

      512MB-4096MB OpenVZ - Canada - 100Mbit Unmetered Plans - Starting at $8.00 per year - 100Gbps DDoS Mitigation Free.

    • back to the original question perhaps it's just the way you setup the SWAP or something?

      I AM BACK :)
      Working Windows Server 2012 R2 on 6GB! Beat that!

    • @TarZZ92 said:
      back to the original question perhaps it's just the way you setup the SWAP or something?

      Direct Quote

      Under the summary tab for the node it says:
      
      SWAP Usage
      Total: 27.87 GB
      Used: 0
      
      So I would say yes but none of it is being used?
      

      Zac U. - 20TBSSD.Com

      512MB-4096MB OpenVZ - Canada - 100Mbit Unmetered Plans - Starting at $8.00 per year - 100Gbps DDoS Mitigation Free.

    • looks okay node wise what about the vps themself?

      I AM BACK :)
      Working Windows Server 2012 R2 on 6GB! Beat that!

    • @TarZZ92 said:
      looks okay node wise what about the vps themself?

      They seem to be configured correctly, ill get more information from him.

      Zac U. - 20TBSSD.Com

      512MB-4096MB OpenVZ - Canada - 100Mbit Unmetered Plans - Starting at $8.00 per year - 100Gbps DDoS Mitigation Free.

    • Why not ask your friend to makean account and post it here. So we can discuss it together :)

      Thanked by 1Nic_20TBSSD
    • @sirmbhe said:
      Why not ask your friend to makean account and post it here. So we can discuss it together :)

      Yea that would be a better option I forwarded the thread to him hopefully he will make an account and get the problem solved a bit faster.

      Zac U. - 20TBSSD.Com

      512MB-4096MB OpenVZ - Canada - 100Mbit Unmetered Plans - Starting at $8.00 per year - 100Gbps DDoS Mitigation Free.

    • Hey, this is the friend :) What other information do you need me to provide?

    • so probably additional information could be: how much VMs did you create, and show some number about diskusage on the hostnode...

      and how are you checking on that diskspace usage?

      your RAW diskimages are probably simple sparse files, which only take space as they get filled, so depending on how you are looking on your available diskspace, it may look like filling up as long as the images have sparse room left.

      most recommended Provider: First-Root KVM Power-Edition /w SSD
      UltraVPS.eu KVM in US/UK/NL/DE: 15% off first 6 month | Netcup VPS/rootDS - 5€ off: 36nc15279180197 (ref)

    • @Falzo said:
      so probably additional information could be: how much VMs did you create, and show some number about diskusage on the hostnode...

      and how are you checking on that diskspace usage?

      your RAW diskimages are probably simple sparse files, which only take space as they get filled, so depending on how you are looking on your available diskspace, it may look like filling up as long as the images have sparse room left.

      Right now I am working with the first 250 SSD. After Proxmox and the Disk Swap, I have 121.76 GB to use to create VMs. I create 1 template that is 4.40GB RAW and then clone 32 VMs from that template.

      After I did all that, I start recording my Disk Space which is under local(IX-0270) > Summary tab.

      2.59 GB 1:32 AM (1/4/2016)
      2.57 GB 1:45 AM (1/4/2016)
      2.52 GB 2:00 AM (1/4/2016)
      2.51 GB 2:08 AM (1/4/2016)
      2.01 GB 10:52 AM (1/5/2016)

      Now I thought, if the Disk Type is RAW, that it can not use more disk space than what it is assigned? But if that is true, then how does the Available Disk Space under my local(IX-0270) > Summary tab keep going down?

      Thanks!

    • antfuentes87 said: Now I thought, if the Disk Type is RAW, that it can not use more disk space than what it is assigned?

      yes, that is right. but that files are created as sparse files, which means they do not use the assigned size on the disk initially, but only as much as they need.
      they may grow up to their assigned size while they are in use later.

      and that is in my assumption why you are seeing your remaining diskspace decreasing.

      if you have ~120GB left for creation of your VMs, then how would (1+32)*4.4=145GB fit in this? thus you overcommit diskspace by running on sparse and probably will be running into trouble, when your raw-images can't grow as needed...

      just look at the estimated size one of your raw-images is consuming by doing something like du -sh *.raw within one of the dirs holding that images /var/lib/vz/images/
      maybe that clears things out. ;-)

      most recommended Provider: First-Root KVM Power-Edition /w SSD
      UltraVPS.eu KVM in US/UK/NL/DE: 15% off first 6 month | Netcup VPS/rootDS - 5€ off: 36nc15279180197 (ref)

    • @Falzo said:

      Alright, so I will try getting more disk space and running that command on each .raw :) Thank you!

    • Try make one mother VM and cover to template. After this copy this template as linked copy.

    • antfuentes87antfuentes87 Member
      edited January 2016

      @stalmer said:
      Try make one mother VM and cover to template. After this copy this template as linked copy.

      I always create one master VM, then convert to template. But I been using Full, not linked. Will try linked, thank you. What does link do exactly?

    • Nothing special, but new Vm are using very lower disc space than full clone

    • @stalmer said:
      Nothing special, but new Vm are using very lower disc space than full clone

      Well using LINKED copy, allows me to make more VMs and everything last longer. But the Disk Space still is going down. It may stable out tho, so I will keep watching it and see what happens.

    • lol. if you want or need to overcommit on diskspace that hard use OVZ and not KVM. you'll be running into problems soon enough.
      BTW: why do you have only 121 GB after proxmox+swap? if you're coming from 250GB it doesn't make sense, the host system should not need anything near 120GB itself.

      most recommended Provider: First-Root KVM Power-Edition /w SSD
      UltraVPS.eu KVM in US/UK/NL/DE: 15% off first 6 month | Netcup VPS/rootDS - 5€ off: 36nc15279180197 (ref)

    Sign In or Register to comment.