Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
Debian and dhcpcd
New on LowEndTalk? Please Register and read our Community Rules.

Debian and dhcpcd

drmikedrmike Member
edited November 2011 in General

greets:

i just have a minute. installed debian on eeepc and wireless is shot. following manual instructions on arch's beginning guide. step i'm stuck on is dhcpcd as command not found in debian install. quick google no help. what package is dhcpcd in or is there a different command in debian.

excuse short. very busy day. thanks for help
-drmike

«1

Comments

  • tuxtux Member
    edited November 2011

    It is dhclient in debian and it is included in isc-dhcp-client package.

    Thanked by 1drmike
  • i'll check tonight. thanks. rather silly that wireless in installed as default but not dhcp support.

  • No dice as it's not in the netinst iso image. any other ideas?

  • Connect it over ethernet, set a static IP, download dhclient, disconnect ethernet, use dhclient to fix wifi

  • (Re)check pool/main/i/isc-dhcp/ on netinst cd for client deb.

    Alternatively you could try copying busybox over from install cd to run udhcpc with it.

  • dhcpd is for a dhcp server, be careful, lol

  • This site looks really bad in Lynx. :) No real access to ethernet as I don't have a home connection and all the churches and libraries I deal with are wireless setups. I found a mention that dhclient may work and I just tried it, after trying it a couple of installs ago, and it works now. Go figure. I got on another tty during the last install and got dozens of missing package errors on the screen so I'm going to try reinstalling now. Debian apt-get tells me that xorg is not found. Shouldn't that be on the debian servers? Ditto on lynx. Actually ssh'ed into a vps and fired up lynx from there. This is really annoying. it is xorg to instrall x, right? thanks -drmike

  • apt-get install xserver-xorg

  • Let me go try that after yet another reinstall, this time connected to the net. thanks

  • Got things up and running and with Firefox v8 no less.

    If anyone comes across a guide to get apt-get to deal with Firefox and Debian would love a link. All that I can find and for other OSes and Google things every linux distro is the same.

    Still have to manually connect wireless though. Have to work on that.

    Thanks.

  • Download the firefox version from their website, is better n_n

  • @drmike said: If anyone comes across a guide to get apt-get to deal with Firefox and Debian

    I'm guessing you mean the iceweasel business? You can adjust your repos if you want the actual Mozilla family, but other than that @yomero has it right, install from the source.

  • LOL, well, not source, but download it from their site and create a pretty shortcut in your desktop :D

  • @drmike: Maybe this does help you a bit: http://www.howtoforge.com/the-perfect-desktop-debian-lenny It's for Lenny but it it should be reusable with newer editions of Debian.

  • Debian unstable FTW. Almost experimental sometimes :D

  • @yomero said: Debian unstable FTW. Almost experimental sometimes :D

    I run aptosid on my netbook (Advent 4211)

  • Not sure about the iceweasal stuff. I'm seeing a lot of mentioning about it but nothing specific. I just downloaded the binary and am running that.

    Interesting that filezilla got installed to bin and not opt.

  • drmikedrmike Member
    edited November 2011

    If anyone can clue me in on getting java working here in Firefox 8, I'd love a link. Most of what I'm finding references a page on the mozilla site that now 404's. Java runtime is installed but I guess firefox can't use it. I head over to java.com, do the "Do I have java installed?" link, it tries to download a plugin, fails, and heads me back to the "Do I have java installed?" link in a circle.

    Thanks

    edit: I think I tried the plugin install as root. Have to check on that.

  • yomeroyomero Member
    edited November 2011

    apt-get install sun-java6-plugin

    Not sure, let me see

    Edit: Yep, it worked for me n_n

  • @drmike: Did you try the Synaptic Package Manager and the packages listed: http://www.howtoforge.com/the-perfect-desktop-debian-lenny-p2

  • Synaptic is for gays

    [Troll mode]

  • drmikedrmike Member
    edited November 2011

    @yomero it's telling me to install iceweasel. I still haven't figured this out but is that actually a replacement for firefox or does it run alongside it?

    I'm going to have to ditch Firefox, aren't I? That may be an issue....

    edit: And I would rather do everything from a prompt so I can see it. Anything in windows is getting cut off because the screen is so small.

  • Mon5t3rMon5t3r Member
    edited November 2011

    iceweasel is firefox for debian, as the same as icedove for debian project mail client (thunderbird). but last time i check (in my toshiba laptop) it's still using firefox engine 3.6.

    edit: but i install iceweasel and firefox in my laptop and running side by side.

    Yes! I'm with Carstensz Pyramid Server Now stop asking me please :D
  • @drmike

    WTF!?!?
    The sun-java6-plugin? It isn't prompting me for iceweasel! o_O!

    Ok, let me see...

    Depends: libasound2, libx11-6, libxext6, libxi6, libxtst6, sun-java6-bin (>= 6.26-0squeeze1), firefox | firefox-2 | iceweasel | mozilla-firefox | iceape-browser | mozilla-browser | epiphany-gecko | epiphany-webkit | epiphany-browser | galeon | midbrowser | moblin-web-browser | xulrunner | xulrunner-1.9 | konqueror | chromium-browser | midori | google-chrome
    

    Hmm, so, you need to install a browser from the list. I recommend you chrome lol, but, I got it, it didn't asked me because gnome 3 has epiphany. So, sorry, install another one. Also is good to have lots of browsers n_n

  • Going back to 3.6 is going to be an issue. Looks like I'm going to have t go with Chrome.

    This is my apt-get output:

    [email protected]:/home/drmike# apt-get install sun-java6-plugin
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following extra packages will be installed:
      iceweasel libmozjs2d xulrunner-1.9.1
    Suggested packages:
      ttf-lyx latex-xft-fonts xfonts-mathml ttf-mathematica4.1 xprint mozplugger libgnome2-0
      libgnomevfs2-0 libgnomeui-0
    The following NEW packages will be installed:
      iceweasel libmozjs2d sun-java6-plugin xulrunner-1.9.1
    0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
    Need to get 8,858 kB of archives.
    After this operation, 24.7 MB of additional disk space will be used.
    Do you want to continue [Y/n]? n
    Abort.
    [email protected]:/home/drmike# 
    
  • LOL, well, install what you want n_n

    Midori is fun too :D

    Btw, instead of Google chrome, try "apt-get install chromium-browser". The normal chrome isn't in the debian repos.

  • Is any normal browser in the repos?

    This is actually an issue. I log bug reports off of this laptop and reporting the browser and version is a requirement. Anything that's not firefox or IE or another main stream browser is just going to get closed as Can Not Recreate. I'm going through that with a couple of tickets and Lynx right now. ("What Lynx? You have to use a web browser to access out site." sigh)

  • Epiphany is a normal browser lol
    Konqueror too but is so heavy xD

    But... why you complicate so much? Just install it for... installing the java plugin and then use firefox, lol.

    Yes, this is the apt world.

  • I can go back afterwards? Didn't know that. Let me try that later on....

    I have to support my clients off of this laptop. Gotta admit though three weeks I'm planning on a new laptop. 2nd paycheck....

  • No, I mean, you are using Firefox with the .tar.gz from their page. So, just install any browser to get the java plugin, then continue using your firefox.

  • Bit late but Google provides .debs for Chrome from their own repo.

  • I'd rather not use Chrome. Most of my hosting clients use Firefox because I do. If I was to change, they're going to want to change and that'll just start the support flood on doing so.

  • Yes, Chrome have their own repos n_n

    But we need any browser form the dependencies list, just to install the freaking java plugin.

  • kylixkylix Member
    edited November 2011

    @drmike: Iceweasel is Firefox. You just need to install it using Synaptic Package Manager. It will handle most dependencies. Then install the Java and Flash packages as cited on the webpage and you have a running Iceweasel/Firefox. Firefox had just to be renamed to Iceweasel on Debian because of licensing issues.

    See: http://lists.debian.org/debian-devel/2006/10/msg00665.html

    See: http://en.wikipedia.org/wiki/Mozilla_Corporation_software_rebranded_by_the_Debian_project

    See: http://www.geticeweasel.org/useragent/

    See: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=399633#102

  • drmikedrmike Member
    edited November 2011

    Let me ask this. Would a different OS work better? This is for the asus eee pc netbook so there has to be drivers for it.

    To be honest, I just installed Debian because I'm vaguely familiar with it from using it on the VPS(es) but now that I've done the "download the iso/dd it to a thumb drive" a half dozen times, I think I can handle something different.

  • @drmike I did have a look - some time ago - at wiki.debian.org/DebianEeePC/
    and I remember finding many interesting things....

  • @TigersWay Yes I'm familiar with that link.

  • Yeah MacOS runs cool in these little things.

  • Would be nice to get some mac experience. I have those xserve's but they're just file servers. Last real mac I had was a borrowed apple 2e. :)

  • You should install OpenSUSE! It's better than some of the alternatives imo.

  • Suse is bloatware :(
    At least the default install.

  • @yomero said: Suse is bloatware :(

    At least the default install.

    Hm, how so? It comes with LibreOffice, Firefox, and then the basic KDE apps.

  • Bloated for me

  • KDE is not recommended for the eee pc. Seems like all of the tutorials are for lxke which seems to work sort of fine. Lots of messed up links though in the menu.

    Granted though I'm still looking for a Sudoku game for it....

  • Not recommended, or have you given it a try? KDE4 runs without issue on my netbook, and I don't see the EEEs being of significantly lower spec.

  • I went straight to lxke as what I read suggested doing so. When it was using the out of the box OS, just opening firefox maxed out both processor and memory. 2 terminals and firefox running is using 376k of 500k memory used and a load of about .20ish. That never happened previously.

  • That's... weird. True, I disable the fancy visual effects for KDE4 on my netbook, but with those off it runs like a champ. KDE3 also hauls really well. -shrug-

    I actually haven't tried lxke.. if I get bored this weekend I may try that out. I'm still kinda burned from the Honeycomb letdown, eager to play with something new.

  • @Aldryic said: That's... weird. True, I disable the fancy visual effects for KDE4 on my netbook, but with those off it runs like a champ. KDE3 also hauls really well. -shrug-

    I actually haven't tried lxke.. if I get bored this weekend I may try that out. I'm still kinda burned from the Honeycomb letdown, eager to play with something new.

    The ICS source is available now, and I think they just released the x86 branch as well if that's what you're interested in.

Sign In or Register to comment.