Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Issues installing eBot
New on LowEndTalk? Please Register and read our Community Rules.

Issues installing eBot

Hello Guys,

i want to install the eBot (http://www.esport-tools.net/ebot/install press EN top right section).
Everything works fine but when i run

php boostrap.php

It checks for PHP Compatibility only the "pthreads" extension is missing.

Can somebody help me to get it working?

Do I really have to compile it?
Can somebody explain me how to do it with my digital ocean vps? (or can i use an more powerful local vm?)

My issue on github.
(the first advice does not help me)

Thanks for any useful tip.

Comments

  • Magic installation...

    pecl install pthreads

  • Die_QuelleDie_Quelle Member
    edited November 2015

    @ToggledNS said:
    Magic installation...

    pecl install pthreads

    Thanks but I tried it a bit earlier getting this:

    pecl/pthreads requires PHP (version >= 7.0.0RC2), installed version is 5.5.9-1ubuntu4.14
    No valid packages found
    install failed
    
  • so.... update php.........

  • But PHP 7 is not really stable or is it?

    Is there no way to use the pecl installation with the 2.0.10 version:

  • pecl install pthreads-2.0.10 works.

    But I have to enable PHP ZTS

    checking checking for ZTS... configure: error: pthreads requires ZTS, please re-compile PHP with ZTS enabled
    ERROR: `/tmp/pear/temp/pthreads/configure' failed

  • what does it says when you:

    apt-cache search pthreads | grep php

    ?

  • @netomx said:
    what does it says when you:

    apt-cache search pthreads | grep php

    ?

    no output.

    I think i need to recompile php with ZTS "enabled" but i have never done this before....

  • Don't they provide a Debian install package that does all the setup for you?
    Just use that and your good to go :)

    There is some configuration that needs to be done when it's installed but it's nothing major IIRC. It's been a while since I installed it.

  • A simple google could of helped you..

    "I haven't found any proper instructions on how to install pthreads in linux, so I'll leave the steps I followed:

    Required libraries

    sudo apt-get install gcc make libzzip-dev libreadline-dev libxml2-dev \
    libssl-dev libmcrypt-dev libcurl4-openssl-dev lib32bz2-dev

    Download PHP

    cd /usr/local/src

    wget http://www.php.net/distributions/php-.tar.gz
    ( e.g. wget http://www.php.net/distributions/php-5.5.8.tar.gz )

    Extract

    tar zxvf php-.tar.gz
    (e.g. tar zxvf php-5.5.8.tar.gz )

    Configure

    cd /usr/local/src/php-
    ( e.g. cd /usr/local/src/php-5.5.8 )

    ./configure --prefix=/usr --with-config-file-path=/etc --enable-maintainer-zts

    Compile

    make && make install
    ( make -j3 && make -j3 install) -> Faster building

    Copy configuration

    cp php.ini-development /etc/php.ini

    Install pthreads

    pecl install pthreads
    echo "extension=pthreads.so" >> /etc/php.ini

    Check installation

    php -m | grep pthreads"

  • Can i do this on a different server with much more power? Afterwards i get an .deb right?

  • @Die_Quelle said:
    Can i do this on a different server with much more power? Afterwards i get an .deb right?

    No, you will have to do this on the target server. You will not get a .deb afterwards, just a working local installation.

    For those who care:
    You can now find me at https://talk.lowendspirit.com or https://www.hostballs.com

  • Take a look at this.
    https://github.com/deStrO/eBot-CSGO/blob/threads/install.txt
    I used instructions from this link to set up my ebot installation on a VM.
    If you followed the instructions from the website to set up ebot-csgo you will have issues with nodejs packages (The instruction on webpage are outdated.)

    If you want to I can share my VM with everything set up, though there are issues with socket.io stability which are most likely related to ebot itself and not the installation.

Sign In or Register to comment.