Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Subscribe to our newsletter

Advertise on LowEndTalk.com

Latest LowEndBox Offers

    Need help with IPv6 on Kimsufi
    New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

    Need help with IPv6 on Kimsufi

    Here is the problem:

    [email protected]:~# ping6 ipv6.google.com
    PING ipv6.google.com(vl-in-x71.1e100.net) 56 data bytes
    From fe80::6e9c:edff:feba:ec40 icmp_seq=1 Destination unreachable: Beyond scope of source address
    From fe80::6e9c:edff:feba:ec40 icmp_seq=2 Destination unreachable: Beyond scope of source address
    From fe80::6e9c:edff:feba:ec40 icmp_seq=3 Destination unreachable: Beyond scope of source address
    From fe80::6e9c:edff:feba:ec40 icmp_seq=4 Destination unreachable: Beyond scope of source address
    From fe80::6e9c:edff:feba:ec40 icmp_seq=5 Destination unreachable: Beyond scope of source address
    ^C
    --- ipv6.google.com ping statistics ---
    5 packets transmitted, 0 received, +5 errors, 100% packet loss, time 4005ms
    

    Here is some information:

    [email protected]:~# cat /etc/resolv.conf 
    search ovh.net
    search kimsufi.com
    nameserver 127.0.0.1
    nameserver 213.186.33.99
    
    
    [email protected]:~# cat /etc/network/interfaces
    iface lo inet loopback
    auto lo
    iface eth0 inet dhcp
    iface eth0 inet dhcp 
    iface eth0 inet6 static 
    address 2607:5300:60:1a59::1 
    netmask 64 
    
    post-up /sbin/ip -f inet6 route add 2607:5300:60:1aff:ff:ff:ff:ff dev eth0 
    post-up /sbin/ip -f inet6 route add default gw 2607:5300:60:1aff:ff:ff:ff:ff 
    pre-down /sbin/ip -f inet6 route del 2607:5300:60:1aff:ff:ff:ff:ff dev eth0 
    pre-down /sbin/ip -f inet6 route del default gw 2607:5300:60:1aff:ff:ff:ff:ff
    
    
    
    [email protected]:~# ping6 2607:5300:60:1a59::1
    PING 2607:5300:60:1a59::1(2607:5300:60:1a59::1) 56 data bytes
    From fe80::4e72:b9ff:fe26:7160 icmp_seq=1 Destination unreachable: Address unreachable
    From fe80::4e72:b9ff:fe26:7160 icmp_seq=2 Destination unreachable: Address unreachable
    From fe80::4e72:b9ff:fe26:7160 icmp_seq=3 Destination unreachable: Address unreachable
    ^C
    --- 2607:5300:60:1a59::1 ping statistics ---
    6 packets transmitted, 0 received, +3 errors, 100% packet loss, time 5032ms
    
    
    [email protected]:~# ping6 2607:5300:60:1aff:ff:ff:ff:ff 
    PING 2607:5300:60:1aff:ff:ff:ff:ff(2607:5300:60:1aff:ff:ff:ff:ff) 56 data bytes
    64 bytes from 2607:5300:60:1aff:ff:ff:ff:ff: icmp_seq=1 ttl=64 time=0.827 ms
    64 bytes from 2607:5300:60:1aff:ff:ff:ff:ff: icmp_seq=2 ttl=64 time=0.633 ms
    64 bytes from 2607:5300:60:1aff:ff:ff:ff:ff: icmp_seq=3 ttl=64 time=0.673 ms
    ^C
    --- 2607:5300:60:1aff:ff:ff:ff:ff ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 1999ms
    rtt min/avg/max/mdev = 0.633/0.711/0.827/0.083 ms
    
    [email protected]:~# cat /etc/sysctl.conf 
    net.ipv6.conf.all.autoconf = 0
    net.ipv6.conf.default.autoconf = 0
    net.ipv6.conf.all.accept_ra = 0
    net.ipv6.conf.default.accept_ra = 0
    net.ipv6.conf.eth0.autoconf=0
    net.ipv6.conf.eth0.accept_ra=0
    

    So ... how do I fix the problem (inability to ping6 ipv6.google.com) ?

    Comments

    • worked out the box for me, can't obviously see anything wrong with the above - what have you changed?

    • All I did was follow the instructions at http://docs.ovh.ca/en/guides-network-ipv6.html
      Haven't changed anything else since last hard reboot.

    • rm_rm_ Member

      GodsGiftToLET said: /sbin/ip -f inet6 route add default gw 2607:5300:60:1aff:ff:ff:ff:ff

      For the ip command it must be not default gw but default via.

      Few other comments, you have the iface eth0 inet dhcp twice, and also remove the blank line before the first "post-up".

    • GodsGiftToLETGodsGiftToLET Member
      edited October 2015

      Thanks rm_. I have made those three changes that you suggested, then ran
      service networking restart

      I am still getting:

          [email protected]:~# ping6 ipv6.google.com
          connect: Network is unreachable
      

      I am using the word "still" because, even though that was not the original error message I posted, after my initial post, the error message change for mysterious reasons to the one I just posted, without me modifying anything to the system.

    • Here is something weird. After I typed, at the Linux prompt:

      ip -6 r a default via 2607:5300:60:1aff:ff:ff:ff:ff

      pinging ipv6.google.com worked.

      However, I have two "equivalent" lines in my /etc/network/interfaces file:

      post-up /sbin/ip -f inet6 route add default via 2607:5300:60:1aff:ff:ff:ff:ff
      pre-down /sbin/ip -f inet6 route del default via 2607:5300:60:1aff:ff:ff:ff:ff
      

      and those didn't seem to be good enough despite having typed:

      service networking restart

      before the ping command.

      When I run the "service networking restart" command, I get the following warning:

      [email protected]:~# service networking restart
      [warn] Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfaces ... (warning).
      [ ok ] Reconfiguring network interfaces...done.

      What's an alternative and better way to restart the networking ?

    • GodsGiftToLET said: What's an alternative and better way to restart the networking ?

      systemctl restart network (CentOS7)

      time wasters please dont comment as we are a serious buyer
      Programmer trying to do Logo Designs

    • tehdantehdan Member
      edited October 2015

      @sdglhm said:
      systemctl restart network (CentOS7)

      To be fair, just uninstalling Debian/Ubuntu and installing centos will also restart networking (more than once...) :)

    • tehdan said: o be fair, just uninstalling Debian/Ubuntu and installing centos will also restart networking (more than once...) :)

      Ha.. Ha.. True enough. ;)

      time wasters please dont comment as we are a serious buyer
      Programmer trying to do Logo Designs

    • Thank you all for your help. I am going to soft reboot out of the rescue mode into the normal mode (as soon as I can login to the right OVH website), and report back if there is a problem after the (non CentOS7) reboot.

    • Am back. I soft rebooted out of the rescue mode and back into ESXi 6.0, hoping that the changes I had made to /etc/network/interfaces were still going to be there. After a soft reboot, I was no longer able to ping6 the Kimsufi server from my home computer (I was able to do so before the soft reboot).

      I couldn't ssh into THAT Kimsufi server because I had, on Saturday, disabled its ability to respond to IPv4. But I did ssh into another Kimsufi server with the same ESXi 6.0 installation, and noticed that the whole /etc/network directory is missing. Yesterday, I emailed the following question to technical support:

      Is there a way to have ESXi installed on a Kimsufi without the /etc/network directory disappearing into CyberSpace ?

      So far, I haven't received an answer to that question. Any Kimsufi/ESXi users on this forum who have an answer to the above question ?

    • Thought it isnt possible to install ESXI on a kimsufi?

    • It is. I did it twice. If you have a Kimsufi server, you can click on Reinstall and, among the options, you will see VMWare ESXi 5.0 option listed.

    Sign In or Register to comment.