Cacti and SNMP error
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

Cacti and SNMP error

GM2015GM2015 Member
edited October 2015 in Help

I've more than 10 servers(yeah yeah, I'm not here to compare dick sizes or buying habits) now, so I though having a self-hosted monitoring domain would be fine on my one of LES boxes. Based on this thread http://www.lowendtalk.com/discussion/54477/self-hosted-monitoring#latest, I've tried librenms, but due to my lack of understanding ditched it today and today I've tried cacti instead.

Cacti is throwing out snmp errors when adding a new device. I've used this tutorial on ubuntu 14.04 to setup the snmp agent http://www.unixmen.com/cacti-monitor-linux-servers-using-snmp/, then used http://download.dartware.com/docs/DevGuide/Content/02-CustomProbes/Debugging_with_SNMPWalk.htm for snmpwalk debugging and the following snmpwalk returns a bunch of values is which is expected from what I've read earlier. Code I'm using:

snmpwalk -v 2c -c communitystring1234random server.randomdomain.com

And it spits out a bunch of OID values as expected. I've tried both from the snmp manager(where cacti is hosted) and the snmp agent server and both receive the same response. Last line from response:

iso.3.6.1.2.1.25.1.7.0 = No more variables left in this MIB View (It is past the end of the MIB tree)

I believe I've read this meaning that the snmp agent sent over all information it has access to.

Cacti was installed from 0.8.8.f(latest tar.gz from cacti.net http://www.cacti.net/downloads/cacti-0.8.8f.tar.gz).

I've activated the following plugins:

Autom8  0.35        Automate Cacti Tasks    General     Active  Reinhard Scheck
    Slowlog 1.3         Cacti MySQL Slow Log Viewer     General     Active  The Cacti Group
    Aggregate   0.75        Create Aggregate Graphs     General     Active  Reinhard Scheck
    Monitor 1.3         Device Monitoring   General     Active  Jimmy Conner
    Settings    0.71        Global Plugin Settings  System  Active  Jimmy Conner
    Nectar  0.35a       Send Graphs via EMail   General     Active  Reinhard Scheck
    Syslog  1.22        Syslog Monitoring   General     Active  Jimmy Conner

The cacti host is running: nginx 1.9.5, php5.6-fpm dotdeb wheezy, mariadb 10.1, debian wheezy.

On new device addition fields I've got my snmp agent server as the following:

Hostname  server.randomdomain.com
Host Template Local Linunx Machine

Number of Collection Threads 1
Monitor Host Ticked

Downed Device Detection Ping and SNMP Uptime
Ping Method ICMP Ping
Ping Timeout Value 1000
Ping Retry Count 3

SNMP Version Version 2
SNMP Community communitystring1234random
SNMP Port 161
SNMP Timeout 1000
Maximum OID's Per Get Request 10

The agent server's /etc/snmp/snmpd.conf file(only pasted the non-commented lines in here:

#  AGENT BEHAVIOUR

agentAddress udp:161,udp6:[::1]:161

#  ACCESS CONTROL


view   systemonly  included   .1.3.6.1.2.1.1
view   systemonly  included   .1.3.6.1.2.1.25.1
view   all         included   .1                80
rocommunity communitystring1234random  default    -V systemonly
rouser   randomauthOnlyUser

#  SYSTEM INFORMATION

sysLocation    Provider, Provider Location
sysContact     [email protected]
sysServices    72

#  Process Monitoring

proc  mountd
proc  ntalkd    4
proc  sendmail 10 1

#  Disk Monitoring

disk       /     10000
disk       /var  5%
includeAllDisks  10%

#  System Load

load   12 10 5

#  ACTIVE MONITORING

trapsink     localhost public

#  Event MIB - automatically generate alerts

iquerySecName   internalUser
rouser          internalUser
defaultMonitors          yes
linkUpDownNotifications  yes

#  Arbitrary extension commands

extend    test1   /bin/echo  Hello, world!
extend-sh test2   echo Hello, world! ; echo Hi there ; exit 35

#  AgentX Sub-agents
master          agentx

I don't understand what cacti's problem is. I've installed and double-checked all php extension needed by their documentation.

Ping between agent and manager is 8ms(London and Netherlands).

On devices tab, cacti has info on the local server, but detects my agent server to be down, which isn't true.

Go give Vultr(referral) a try. | GNU/Linux http://debian.org

Comments

Sign In or Register to comment.