Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Subscribe to our newsletter

Advertise on LowEndTalk.com

Latest LowEndBox Offers

    Virtualbox Network
    New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

    Virtualbox Network

    Hi, i use hetzner dedicated server now install centos 6.7 and virtualbox 4.1 , i want use windows 2008 r2 . How can i do?

    Comments

    • Use Proxmox instead.

      How to clean up a questionable reputation: throw the kids some BF/CM offers.

    • @doughmanes said:
      Use Proxmox instead.

      i was install proxmox but same problem i cant access with rpd and proxmox windows performance bad(software raid 0)

    • shorter and more understandable pls?

    • WilliamWilliam Member, Provider
      edited September 2015

      did you even install it? You need to install the Windows via VNC, just mounting the ISO does not magically install it and open RDP....

      YOur Proxmox also sucked because you had no VirtIO enabled, either in Proxmox or no driver inside the KVM.

    • install x2go or xrdp(no terminal cryptic bs then)/ installl virtualbox like you usually do, the machine you create for windoze will need to have the checkboxes under display settings for rdp and make sure the firewall doesnt give you burnt toast and dah you go.

    • @William said:
      did you even install it? You need to install the Windows via VNC, just mounting the ISO does not magically install it and open RDP....

      YOur Proxmox also sucked because you had no VirtIO enabled, either in Proxmox or no driver inside the KVM.

      i have 2x3tb hdd debian install only 1 tb but centos all space usable and i install proxmox 4 and select virtuo drivers

      @raptorpeanutbuttr said:
      install x2go or xrdp(no terminal cryptic bs then)/ installl virtualbox like you usually do, the machine you create for windoze will need to have the checkboxes under display settings for rdp and make sure the firewall doesnt give you burnt toast and dah you go.

      i install vnc and virtualbox 4.1 windows firewall off, centos iptables off but still i cant connect with rdp

    • @Uruloki said:
      i install vnc and virtualbox 4.1 windows firewall off, centos iptables off but still i cant connect with rdp

      You have to do port forwarding you're using NAT. If you're using an "extra ip" set the network tipe to bridge.

    • @MuZo said:
      You have to do port forwarding you're using NAT. If you're using an "extra ip" set the network tipe to bridge.

      No, i dont use extra ip, how can i do port forward

    • Uruloki said: shorter and more understandable pls?

      Uruloki said: No, i dont use extra ip, how can i do port forward

      RTFM

      Let's bet which dot-name will collapse first ;)

    • MuZoMuZo Member
      edited September 2015

      @Uruloki said:

      Lots of guide out there, search for iptables port forward. You could also use redir to forward the rdp port

      redir --lport=3389 --caddr=yourvpsip --cport=3389

    • @tommy said:
      RTFM

      Fucking manual too long and i dont know need use which mode . Now i use nat mode windows connect internet but i cant connect with rdp

    • @MuZo said:

      Now iptables close when i active iptables i cant connect vnc with centos

    • @Uruloki said:

      post the result of iptables -L

    • @MuZo said:

      `[[email protected] ~]# iptables -L
      Chain INPUT (policy ACCEPT)
      target prot opt source destination

      Chain FORWARD (policy ACCEPT)
      target prot opt source destination

      Chain OUTPUT (policy ACCEPT)
      target prot opt source destination
      `

    • Not sure why you can't access vnc when you enable iptables, seems it's empty with accept policy.

      Thanked by 1netomx
    • @MuZo said:
      Not sure why you can't access vnc when you enable iptables, seems it's empty with accept policy.

      Server now empty i can give root access if you want.

    • @Uruloki said:
      Server now empty i can give root access if you want.

      Don't give root access to a random user on a forum lol. I'm on mobile now but later I can help you if you still haven't solved

    • @MuZo said:
      Don't give root access to a random user on a forum lol. I'm on mobile now but later I can help you if you still haven't solved

      Still same, when you're your free time send me pm

    • An easier way to configure a server for port forwarding etc. in cases as using proxmox or virtualbox, is installing webmin. With a GUI you can configure firewall/port forwarding and do some other useful configuration, too.
      If you don't know how to properly configure, follow those simple steps:

      • Open thru centos gui the virtualbox. From there, open windows instance.
      • COnfigure network adapter on Windows vm, with a static internal ip (etc. 192.168.1.50), mask 255.255.255.0 and your gateway ip. You can use as dns servers google's ones: 8.8.8.8 and 8.8.4.4
      • Now, go to webmin to the original server and configure firewall. You can find int on the tab NETWORK > LINUX FIREWALL
      • In the "showing iptable" tab, chose "network address translation".
      • Create a new rule, chose as action "destination NAT", type at "IPs and ports for DNAT" your nat ip of the windows vm (192.168.1.50) and as port your rdp port (3389)
      • The Incoming interface should be eth0 or whatver your interface is.
      • In "Network protocol" chose equals and TCP
      • In "Destination TCP or UDP port" chose equals and chose a port that you will use by your external ip on the main node (e.g. 15000)
      • Save the rule and apply it

      Following same instructions, you can port other ports to the same or other vms.
      Hope I hepled

      • If a program actually fits in memory and has enough disk space, it is guaranteed to crash.
      • If such a program has not crashed yet, it is waiting for a critical moment before it crashes.

    • @jvnadr said:

      Thanks for instructions but my linux command level of knowledge bad i will try

    • @Uruloki said:
      Thanks for instructions but my linux command level of knowledge bad i will try

      Maybe try my guide:

      http://www.lowendtalk.com/discussion/21980/a-quick-guide-for-setting-up-windows-on-the-new-kimsufi-range

    • @jvnadr said:
      An easier way to configure a server for port forwarding etc. in cases as using proxmox or virtualbox, is installing webmin. With a GUI you can configure firewall/port forwarding and do some other useful configuration, too.
      If you don't know how to properly configure, follow those simple steps:

      • Open thru centos gui the virtualbox. From there, open windows instance.
      • COnfigure network adapter on Windows vm, with a static internal ip (etc. 192.168.1.50), mask 255.255.255.0 and your gateway ip. You can use as dns servers google's ones: 8.8.8.8 and 8.8.4.4
      • Now, go to webmin to the original server and configure firewall. You can find int on the tab NETWORK > LINUX FIREWALL
      • In the "showing iptable" tab, chose "network address translation".
      • Create a new rule, chose as action "destination NAT", type at "IPs and ports for DNAT" your nat ip of the windows vm (192.168.1.50) and as port your rdp port (3389)
      • The Incoming interface should be eth0 or whatver your interface is.
      • In "Network protocol" chose equals and TCP
      • In "Destination TCP or UDP port" chose equals and chose a port that you will use by your external ip on the main node (e.g. 15000)
      • Save the rule and apply it

      Following same instructions, you can port other ports to the same or other vms.
      Hope I hepled

      cheers for this, one more entry in the lazy ways to do things

    • @MuZo fix problems just did virtualbox gui port forward

    • MuZoMuZo Member
      edited September 2015

      I contacted @Uruloki on chat and now it should be solved. He wanted to access his Windows VM via RDP and so do the port forwarding.

      From what I saw Virtualbox acts pretty weird: on the host there is a vboxnet0 interface using the192.168.56.0/24 network, but the virtual machine gets a 10.0.2.X IP from the Virtualbox DHCP. The problem is that it seems that the host can't connect to the 10.0.2.X IP: ping can't reach (yes firewall was disabled in the vm) and redir fails to connect too.

      I found that Virtualbox has a simple way to do port forwarding integrated in the GUI under the network settings, so I just used that and it's working fine. I'm not sure how they make it work network wise. See those example images:





      Source: http://www.howtogeek.com/122641/how-to-forward-ports-to-a-virtual-machine-and-use-it-as-a-server/



      Obviously for RDP that would be port 3389 TCP.

      Thanked by 1Uruloki
    Sign In or Register to comment.