Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


FreeBSD amd64 KVM Troubleshooting
New on LowEndTalk? Please Register and read our Community Rules.

FreeBSD amd64 KVM Troubleshooting

Nick_ANick_A Top Provider
edited October 2012 in Help

There seems to be something wrong with my configuration where I can't get any amd64 FreeBSD bootonly ISOs to boot. This is across two KVM nodes that I've verified this. I've used FreeBSD 8.3, 9.0, and 9.1 Beta with no success. 32-bit works fine. What am I overlooking here?

RamNode: High Performance Cloud VPS
NYC - LA - ATL - SEA - NL - DDoS Protection

Comments

  • marcmmarcm Member
    edited October 2012

    @Nick_A I've sent you a PM :)

  • Thread resurrection: GO GO GO !!

    What was the fix for this issue? I've now run into the problem where no 64-bit FreeBSDs will boot, but the 32-bit ones will.

  • CrabCrab Member
    edited February 2013

    Last time I heard from @Nick_A the problem still persists. Hopefully they get it working though.

  • Nick_ANick_A Top Provider

    No fix found to date.

    RamNode: High Performance Cloud VPS
    NYC - LA - ATL - SEA - NL - DDoS Protection
  • edited February 2013

    I'm experiencing the same issue on my E3 KVM nodes, but it looks like it's related to either the Supermicro board we're using, or the E3 CPU.

    FreeBSD AMD64 ISOs boot fine on my E5 KVM node.

    Fusioned | KVM SSD VPS | LSI RAID10 | Netherlands 1Gbps | Acronis Cloud Backups | IPv4 & IPv6 | SolusVM
  • We have ran into this also.

  • flricharflrichar Member
    edited February 2013

    Do you have the console output for when the boot fails?

    I just successfully booted a test kvm guest with the bootonly amd64 iso for 9.1. Sitting at a shell prompt now... Is this still an issue?

  • jaakkajaakka Member
    edited February 2013

    My testVM on ipxcore results to :

    kernel trap 9 with interrupts disabled

    i asked to try to run KVM enviroment without -cpu host switch on qemu-system-x86_64

    This is cpu switch bound and some bugs rely on a usb subsystem.

  • What version of kvm? What were the command line options?

  • @Damian can chime in, i dont have access to the host node.

  • [[email protected] ~]# virsh version
    Compiled against library: libvir 0.9.10
    Using library: libvir 0.9.10
    Using API: QEMU 0.9.10
    Running hypervisor: QEMU 0.12.1

    /usr/libexec/qemu-kvm -S -M rhel6.3.0 -enable-kvm -m 512 -smp 1,sockets=1,cores=1,threads=1 -name kvm135 -uuid 9222afad-46eb-4ec1-cp32-368706284aad -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/kvm135.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/dev/vg_colo0649ipx8/kvm135_img,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -drive file=/home/solusvm/kvm/iso/FreeBSD-9.1-RELEASE-i386-bootonly.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=22,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=x:x:x:x:x,bus=pci.0,addr=0x3 -device usb-tablet,id=input0 -vnc 0.0.0.0,password -k en-us -vga cirrus -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x4
    
  • flricharflrichar Member
    edited February 2013

    I'm running 1.2.0 on Archlinux. My command options were extremely simple:

    kvm -m 512 -cpu kvm64 -boot d -cdrom /misc/iso/FreeBSD-9.1-RELEASE-amd64-bootonly.iso -curses -enable-kvm

    I have a guest freebsd machine here at home but it's 32bit and not 64... oh and in that output above too you're pointing to the i386 bootonly iso.

  • @flrichar said: oh and in that output above too you're pointing to the i386 bootonly iso.

    I know, I took it as it currently exists, because i386 will boot without issue.

  • archlinux kvm points to qemu-system-x86_64.

    What if damian invokes qemu-system-x86_64 directly.

    e.g qemu-system-x86_64 -hda [BASE IMAGE FILE NAME] -m [MEMORY] -boot d -cdrom [GUEST OS LOCATION]

  • flricharflrichar Member
    edited February 2013

    It shouldn't matter... and now as of Qemu 1.3.0, they've combined qemu-kvm and qemu (ie, no more modified qemu to use kvm features of the kernel/hardware). I'm wondering what option(s) or configurations are making it fail. I've actually compiled 1.3.0 for Arch but had to back out... because my FreeBSD guest wouldn't boot, and that one is 32bit. I was also considering joining your KVM beta test. :) It's a cool project, I've been following it for quite some time. I'm not a big fan of virsh or libvirt, though.

Sign In or Register to comment.