Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with OpenID
Advertise on

In this Discussion

instlling php and mysql

instlling php and mysql

sureshsuresh Member
edited November 2011 in Help

I had got a free vps from another site and when i tried to follow this installation guide i am getting errors can some body tell me whats the problem. My VPS memory was 64MB so some one suggested the above link to use for installation.



  • InfinityInfinity Member, Provider
    edited November 2011

    What errors are you getting?

    And yep, I'm Infinity from the place you got your vps from :P

  • You need to tell us what the errors are. Think about your question.

    Thanked by 1Infinity
  • Stupid question, but are you running Debian or Ubuntu on that VPS?

  • You had better be running something like Debian 5 32 bit or getting it all to fit is going to be a challenge. The newer distributions use more RAM as do the 64 bit versions.

  • @suresh insert yet another request for the specific error that you are receiving as well as walking us through with specifics as to what you are doing.

    Please remember specifics helps.

  • drmike said: Please remember specifics helps.

    So does man pages, and Google :P

  • drmikedrmike Member
    edited November 2011

    @suresh Oh by the way, you owe me a steak dinner.

    @aldryic but real men give error reports. :)

    I don't even point my clients to google as they may screw up something worse. But they're very good at giving error reports.

  • drmike said: But they're very good at giving error reports.

    I envy you for that. "Sir why so lag" or "plz my vps" is all too often the entirety of a support ticket for us.

  • drmikedrmike Member
    edited November 2011

    Like I said, they're well trained. :)

    Actually it's a running joke that came out of the dinner running joke. When you didn't leave the error in the forums, you had to put $5 into the charity kitty that got donated once a month to a charity that got voted on by the client at large. We don't enforce it of course and some clients screw up on purpose to chip in but it gets the point across. Ticks a few off but once it gets explained to them and what good comes out of it, I've only had one client leave over it. (And I wasn't sorry to see her leave.)

    The support ticket form has a field for the error received. Also the main area of the ticket form has a checklist that's prefilled in and that's in bold. We thought about making it a required field so that the ticket wouldn't submit without something in there but feedback said that was confusing for those who weren't getting an error.

    edit: November is an inner city reading organization that donates books to a US cities Girls and Boys clubs as well as other private clubs. Last month was a months supply of feed for a horse rescue organization a few states over. It doesn't really take in a whole lot but um a certain client makes sure that it does if you catch my meaning and I throw in some from the budget if I can get away with it.

  • sureshsuresh Member
    edited November 2011

    here some errors as i run this commands again

  • Damn, can you use pastebin?

  • Lol


  • I edited the post with pastebin.

  • @suresh try using debian 6 "squeeze" 32bit instead. It works and install fine on that. Seems like debian 5 "lenny" have some issue installing some of those files.


  • The next release of Debian is codenamed "wheezy" — no release date has been set Debian 6.0 ("squeeze") — current stable release Debian GNU/Linux 5.0 ("lenny") — obsolete stable release Debian GNU/Linux 4.0 ("etch") — obsolete stable release Debian GNU/Linux 3.1 ("sarge") — obsolete stable release


  • Current stable version is Debian Squeeze (6.0).

  • drmikedrmike Member
    edited November 2011

    6.0.3 actually I believe. At least that's what was the iso over at Pyramid.

    edit: Yup:

  • Well just switch to squeeze. It should work like a charp. Just tried on my test vps with debian 6 32bit and 64bit minimal template


  • I had asked to install debian 6 and he did when i entered the codes it is still gvng problems. after this I am unable to log as getting error network ion refusederror connect

    Can we able to install drupal or required more RAM ?

  • yomeroyomero Member
    edited November 2011

    If you still want to stick with debian 5 because your provider or something, I recommend you do this at FIRST after reinstalling your VPS, do this:

    Go to and grab your repositories, click on the first 5 checkboxes (main repos and security repos) and copy the results, then do this

    Mine is like that, for repos in USA. Or edit the sources.list file manually if you want

    Your installation is screwed.

    I recommend you do the same for squeeze anyway.


    and show us /etc/apt/sources.list

    I'd also ln -s /bin/bash /bin/sh

    Signatures are to identify who I am. I'm me. Who the hell are you?

  • I requested to reinstall the OS Can somebody tell me how to find the What OS is installed

  • I'm using

    cat /etc/debian_version
  • cleonardcleonard Member
    edited November 2011

    Your install isn't screwed, it's just old.

    The problem is expired gpg keys of the Debian 5 install. I ran into the same issue when I was comparing Debian 5 and 6 in a 128mb box. I don't have the solution at hand, but it's an easy fix. You need to get the new keys and then use apt-key to install.

  • @suresh said: I requested to reinstall the OS Can somebody tell me how to find the What OS is installed

    cat /etc/issue 

    or just use what @vedran posted for debian specific

  • @suresh google "no_pubkey GPG error"

    That should help you resolve the issue pretty quickly.

  • These

    E: There are problems and -y was used without --force-yes
    inetutils-syslogd installed for /usr/sbin/syslogd /usr/sbin/invoke-rc.d: /bin/sh: bad interpreter: No such file or directory /usr/sbin/invoke-rc.d: /bin/sh: bad interpreter: No such file or directory

    Are not GPG errors.

    But about gpg...

    apt-get install debian-archive-keyring

    Probably can help you

  • The debian-archive-keyring didn't fit it for me. I had to do it manually. I also had those invoke-rc.d errors which went away when I installed the new keys and tried the process again.

  • After changing the plan I finally managed to install wordpress and the tutorial was correct. How to connect to the server using FTP? or any control panel? I mean to edit files and adding database to wordpress.

  • SpeedBusSpeedBus Member, Provider

    Install a FTP-server,

    such as, vsftpd,

    apt-get install vsftpd

    Then add a new user and password for that user and then start vsftpd and you can FTP into your VPS :)

    CrownCloud | Los Angeles, California | Frankfurt, Germany | Wormer, The Netherlands

  • @SpeedBus said: Install a FTP-server,


    No, don't use an FTP server, use SSH, upload the files via SCP and create the database with the console client, or install phpmyadmin to do it via web.

    A decent SCP client is Filezilla.

    Thanked by 1Infinity
  • InfinityInfinity Member, Provider


    SFTP is secure, no additional software and it's easier :)

  • you could also try WinSCP..

  • I am unable to log into VPS and still not yet understanding whats the problems. It looks like something problem on my side since trying with putty also fails

  • SpeedBusSpeedBus Member, Provider
    edited December 2011

    Is the VPS booted ? (ON?) --> reboot the VPS from the panel (SolusVM) and try again ?

    CrownCloud | Los Angeles, California | Frankfurt, Germany | Wormer, The Netherlands

  • SpeedBusSpeedBus Member, Provider

    after reading through the error log you posted above, it seems to be you need to apply : --force-yes when you install the scripts..

    CrownCloud | Los Angeles, California | Frankfurt, Germany | Wormer, The Netherlands

  • Speedbus That is on old VPS i am new one and the IP is Do i need to reboot? let me know please.

  • I am able to log into VPS Can somebody tell me how to add database and where can i see phpmyadmin or databases in my VPS?

  • If I were you, first I solve the "unable to login" problem than trying to configure databases and so.

    Also, if you need information on how to use mysql, I guess google is your friend.

  • exussumexussum Member
    edited December 2011

    I can confirm its that problem

    for me

    gpg --keyserver --recv-key AED4B06F473041FA gpg -a --export AED4B06F473041FA | sudo apt-key add -

    Just before solves it.

  • I wanted to know my database host and how i should make databases. I know Google is not my friend thats why i am here.

  • AldryicAldryic Member
    edited December 2011

    @suresh phpmyadmin is a web-based tool, you'll need an httpd, php, and mysql installed before you can use phpmyadmin. On a debian-based system, you can just do apt-get install phpmyadmin, which will cover all of the dependencies for you.

    If you'd rather interact with mySQL directly (my personal preference, but takes a little getting used to), all you need to install is the mysql-client package, and google up a guide on mySQL commands.

    EDIT: (just noticed your 'Google is not my friend' line :P) - here's a pretty nifty guide for the mysql-client side of things.

Sign In or Register to comment.