Broken CentOS 7 x86_64 Image?
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

Broken CentOS 7 x86_64 Image?

berryboyberryboy Member
edited April 2015 in Help

Hey guys,
I just recently purchased what seems to be a good deal on a VPS from alpharacks.com and I reinstalled CentOS 7 x86_64 onto the machine. I logged in and ran yum update and continued working. After I rebooted the server after working on it for 20 minutes, things didn't come back online. I checked logs using the Solus console and couldn't find anything. After reinstalling the OS again, I discovered that using yum update was the source of the problem. I don't know if there's a broken package or something.

I submitted a ticket letting them know and they provided me with the instructions of reinstalling the OS and running yum update again, clearly not understanding my problem. Unfortunately, I don't know what else to look into and am wondering what I should do next.
Any ideas?

Thanks!
Kevin

Comments

  • MelitaMelita Member, Provider

    https://bugzilla.redhat.com/show_bug.cgi?id=1207975

    TL:DR: latest initscripts didn't properly up your venet0 on openvz.

    You need to edit /etc/sysconfig/network-scripts/ifup-aliases temporarily until one of them fixing it.

    Currently work with IndoVirtue, selling US/Asia/Singapore KVM/OpenVZ SSD VPS and Dedicated Server.

  • @Melita said:
    https://bugzilla.redhat.com/show_bug.cgi?id=1207975

    TL:DR: latest initscripts didn't properly up your venet0 on openvz.

    You need to edit /etc/sysconfig/network-scripts/ifup-aliases temporarily until one of them fixing it.

    Thanks for providing me with at least a route to look into. Unfortunately, I tried replacing certain lines in ifup-aliases, rebooted and then ran yum update. The system still hangs :(

  • earlearl Member

    Maybe you're being blocked by the firewall? you may need to add a rule for your SSH port.

    Thanked by 1berryboy
  • @earl said:
    Maybe you're being blocked by the firewall? you may need to add a rule for your SSH port.

    Yeah I tried this first and still no dice :( tried the same thing with apache and no connections allowed and it seems everything is super messed up.

  • MaouniqueMaounique Member
    edited April 2015

    There are also issues with centos 7 on certain xen pv installations. Some random kernels fail to boot, also centos 6 has this issue. The problem fixes itself next kernel or the one after just to pop-up again later..

    Extremist conservative user, I wish to preserve human and civil rights, free speech, freedom of the press and worship, rule of law, democracy, peace and prosperity, social mobility, etc. Now you can draw your guns.

  • earlearl Member
    edited April 2015

    try disabling the firewall momentarily. You should be able to access your vps from the control panel (solusvm/virtualizor)

  • @earl said:
    try disabling the firewall momentarily. You should be able to access your vps from the control panel (solusvm/virtualizor)

    This is what I tried actually. For some reason firewalld isn't installed (I thought iptables got replaced with firewalld). Anyways, I disabled iptables and nothing's changed.

  • earlearl Member

    Hmm.. I don't have a VPS with alpharack, but let try the centos image on one of my VPS.

  • ndelaespadandelaespada Member, Provider

    @berryboy

    To get the network back up, run the following via console:

    ip addr add x.x.x.x dev venet0

    Where x.x.x.x is the public IP of your container

    Then the "permanent" fix is here:

    https://bugzilla.redhat.com/show_bug.cgi?id=1207975

    It's telling you to edit /etc/sysconfig/network-scripts/ifup-aliases

    removing the following line:

    if ! /sbin/arping -q -c 2 -w ${ARPING_WAIT:-3} -D -I ${parent_device} ${IPADDR} ; then

    and adding the following lines in that same position:

    /sbin/arping -q -c 2 -w ${ARPING_WAIT:-3} -D -I ${parent_device} ${IPADDR}

    if [ $? = 1 ]; then

    As shown here:

    https://git.fedorahosted.org/cgit/initscripts.git/commit/?id=55a50ebc591ebd0f4cfbb8ecc204fa20ee6a7368

    Good luck!

    Thanked by 1earl

    owned-networks | kvm & openvz | Dallas - Los Angeles - Seattle - Lenoir - New York City - Miami


    english, french & spanish support

  • I asked alpharack what image specifically they're using (not sure if v1/v2 gen1/gen2, etc) but all I know is it's CentOS 7.0.1406 x86_64

  • earlearl Member

    Just tried same problem as you.. must be the image then nothing to do with alpharack..

    I would try @ndelaespada solution.. I just realize can't even console into the vps wth virtualizor cause java does not work.

    Thanked by 1berryboy
  • berryboyberryboy Member
    edited April 2015

    @ndelaespada said:
    berryboy

    To get the network back up, run the following via console:

    ip addr add x.x.x.x dev venet0

    Your solution worked great, thank you so much! Passing this on!

  • nullnullnullnull Member
    edited April 2015

    Got the same issue too recently and switched back to 6 due to this.

  • MelitaMelita Member, Provider
    edited April 2015

    @berryboy said:
    Thanks for providing me with at least a route to look into. Unfortunately, I tried replacing certain lines in ifup-aliases, rebooted and then ran yum update. The system still hangs :(

    yum update replaces back your edited ifup-aliases. It's a wrong sequence.

    Do yum update first, then replace the ifup-aliases. Next reboot will execute the ifup-aliases. Detailed steps is just like ndelaespada said, as stated in the mentioned bugzilla link.

    Anyway, ip addr add x.x.x.x dev venet0 also can do and it's simpler (you can put it in your init scripts) :)

    Currently work with IndoVirtue, selling US/Asia/Singapore KVM/OpenVZ SSD VPS and Dedicated Server.

Sign In or Register to comment.