Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
Firewall on Kimsufi - Proxmox
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

Firewall on Kimsufi - Proxmox

iGryphyiGryphy Member
edited April 2015 in Help

So I followed this guide here: http://lowendtalk.com/discussion/21980/a-quick-guide-for-setting-up-windows-on-the-new-kimsufi-range

In which I created my VM with Server 2012 R2 Datacenter.

But my main issue is that I need to open ports, in which I can open them within the VM, via Windows Firewall. But I have been using SSH into my Host, and tried to add the ports to the IP Table, ie.

iptables -t nat -A PREROUTING -i vmbr0 -p tcp --dport 8080 -j DNAT --to 192.168.0.1:8080

But the Firewall is still not opening the port. Just wondering if there is any advice on what to do, as I have been trying to get this issue fixed for 3 days now, and Googling it isnt helping in any case.

Thanks.

Comments

  • earlearl Member
    edited April 2015

    what are you trying to do rdp into your windows?

    Anyways if you are.. in the RDP client you have to use port 8080 so eg. 216.58.211.14:8080

  • iGryphyiGryphy Member
    edited April 2015

    @earl said:
    what are you trying to do rdp into your windows?

    Anyways if you are.. in the RDP client you have to use port 8080 so eg. 216.58.211.14:8080

    My RDP works on the usual port. What I am trying to do is open up ports for a Webserver as its website hosting. Which is port 8080.

    And I just relized a type at the top there. Its meant to be 192.168.0.1:8080 at the end. But that still doesnt work.

    Proxmox VE 3.3 is installed on the Main Server, as the Host machine, and Windows Server 2012 R2 is the guest machine in the VM. What I am trying to do is open the ports on the Host Machine, to send the port information to the Guest Machine.

    IE.

    Host Port ----> Guest Port

    80 --------> 80 = Working |
    8080 -------> 8080 = Not Working |
    3389 (RDP) -------> 3389 (RDP) Working

    Its so I can open the ports required for the website on the server to work. And any other ports for things like TS3.

  • BlazeMuisBlazeMuis Member
    edited April 2015

    You should really check out the link in my signature hint

  • RizRiz Member

    Did you enable your webserver to listen on port 8080?

  • @joodle said:
    You should really check out the link in my signature hint

    I did follow your link before, and had an issue in which I couldnt enable ports on my Server, using Windows Firewall, In which I ended up reinstalling Server 2012 several times.

    @Riz said:
    Did you enable your webserver to listen on port 8080?

    My Webserver is enabled to listen on port 80 and 8080. The main issue now, is trying to open the UDP 9987 and other ports required for TeamSpeak etc.

  • earlearl Member
    edited April 2015

    In your host proxmox node check if there is conflicting rules..

    iptables -t nat -n -L

    To delete a rule replace -A with -D and make sure the entry is removed from your interfaces file, and best to reboot the host server and check again.

    iptables -t nat -D PREROUTING -i vmbr0 -p tcp --dport 8080 -j DNAT --to 192.168.0.1:8080

    It's all I can suggest..

  • @earl said:
    In your host proxmox node check if there is conflicting rules..

    iptables -t nat -n -L

    To delete a rule replace -A with -D and make sure the entry is removed from your interfaces file, and best to reboot the host server and check again.

    iptables -t nat -D PREROUTING -i vmbr0 -p tcp --dport 8080 -j DNAT --to 192.168.0.1:8080

    It's all I can suggest..

    Check it, and ports 80 and 8080 and 3389 are all working fine, but its the other ports required that arent, such as 9987, 10011, and 30033. Which are needed for TeamSpeak.

  • sc754sc754 Member

    @iGryphy said:
    So I followed this guide here: http://lowendtalk.com/discussion/21980/a-quick-guide-for-setting-up-windows-on-the-new-kimsufi-range

    In which I created my VM with Server 2012 R2 Datacenter.

    But my main issue is that I need to open ports, in which I can open them within the VM, via Windows Firewall. But I have been using SSH into my Host, and tried to add the ports to the IP Table, ie.

    iptables -t nat -A PREROUTING -i vmbr0 -p tcp --dport 8080 -j DNAT --to 192.168.0.1:8080

    But the Firewall is still not opening the port. Just wondering if there is any advice on what to do, as I have been trying to get this issue fixed for 3 days now, and Googling it isnt helping in any case.

    Thanks.

    You probably don't need windows firewall enabled if you're just forwarding specific ports from the host to the windows vm

  • sc754 said: You probably don't need windows firewall enabled if you're just forwarding specific ports from the host to the windows vm

    Id prefer to keep windows firewall on just so if I decide to move it to another server, where its the servers OS, then I dont need to try and remember all the ports to open.

    joodle said: You should really check out the link in my signature hint

    Just to add in. It was the same issue as Im having just now, when I was using your Templates to install Server 2012 onto the Server, but ofcourse, without the element of Proxmox Firewall, or Linux Firewall.

  • earlearl Member

    I dont think I have ever installed team speak.. so not much help.

  • iGryphy said: Just to add in. It was the same issue as Im having just now, when I was using your Templates to install Server 2012 onto the Server, but ofcourse, without the element of Proxmox Firewall, or Linux Firewall.

    That's just weird, because the Firewall has been disabled on my templates... Send me a PM with your Skype, i can take a look if you'd like if you reinstall it with Windows from my template again.

  • joodle said: That's just weird, because the Firewall has been disabled on my templates... Send me a PM with your Skype, i can take a look if you'd like if you reinstall it with Windows from my template again.

    Messaged you with my Skype.

  • Still having the issue with Proxmox. Nothing in iptables is able to fix the issue.

    @joodle I added you on Skype, would you be able to help me out with this issue with your Template too, thanks?

  • sc754sc754 Member
    edited April 2015

    @iGryphy said:
    Still having the issue with Proxmox. Nothing in iptables is able to fix the issue.

    joodle I added you on Skype, would you be able to help me out with this issue with your Template too, thanks?

    Maybe test on the host node to see if you can access the local IP and port. Then you'll know if its iptables or windows firewall that's the problem

  • @sc754 said:
    Maybe test on the host node to see if you can access the local IP and port. Then you'll know if its iptables or windows firewall that's the problem

    I can access the Host node without any issue, tested the port there and it was fine pinging the guest environment, but the then I cant ping the outside environment on any other ports other than 3389 and 22.

  • ClancomsClancoms Member
    edited April 2015

    with windows you must allow for ping
    turn on

    File and Printer Sharing (Echo Request - ICMPv4-In)

    File and Printer Sharing (Echo Request - ICMPv4-Out)

    http://puu.sh/h91XQ/8d73505388.png



    and if your running a windows vps on proxmox you should be able to install and start teamspeak and connect with no problem. the teamspeak install opens the required ports for you.

    also run this in putty on the main box if it will let you. it has been 3 years since i installed proxmox on my server i don't remember if this iptables command will work






    iptables -I INPUT -p tcp --dport 10011 -j ACCEPT

    iptables -I INPUT -p tcp --dport 30033 -j ACCEPT

    iptables -I INPUT -p udp --dport 9987 -j ACCEPT

    iptables -I INPUT -p tcp --dport 41144 -j ACCEPT

    iptables -I INPUT -p tcp --dport 2008 -j ACCEPT

    iptables -I INPUT -p udp --dport 2008 -j ACCEPT


    /etc/init.d/iptables save

    /etc/init.d/iptables restart




    as these are the required ports for teamspeak3

    https://clancoms.com "Las Vegas cheap colo | Windows VPS | KVM | OpenVZ | Dedicated | Teamspeak3"

  • @Clancoms said:
    with windows you must allow for ping
    turn on

    File and Printer Sharing (Echo Request - ICMPv4-In)

    File and Printer Sharing (Echo Request - ICMPv4-Out)

    http://puu.sh/h91XQ/8d73505388.png



    and if your running a windows vps on proxmox you should be able to install and start teamspeak and connect with no problem. the teamspeak install opens the required ports for you.

    also run this in putty on the main box if it will let you. it has been 3 years since i installed proxmox on my server i don't remember if this iptables command will work






    iptables -I INPUT -p tcp --dport 10011 -j ACCEPT

    iptables -I INPUT -p tcp --dport 30033 -j ACCEPT

    iptables -I INPUT -p udp --dport 9987 -j ACCEPT

    iptables -I INPUT -p tcp --dport 41144 -j ACCEPT

    iptables -I INPUT -p tcp --dport 2008 -j ACCEPT

    iptables -I INPUT -p udp --dport 2008 -j ACCEPT


    /etc/init.d/iptables save

    /etc/init.d/iptables restart




    as these are the required ports for teamspeak3

    Will give this a try and let you know

Sign In or Register to comment.