Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
Configuring IPv6 for Proxmox KVM on Dedibox / Online.net
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

Configuring IPv6 for Proxmox KVM on Dedibox / Online.net

earlearl Member
edited April 2015 in Tutorials

So I finally managed to get IPv6 only VM working in Proxmox on my dedibox server.. No Failover IP, Virtual MAC, or Router is required. Essentially it's the same network configuration used on the OVH / Kimsufi servers.

I probably don't need to mention that changing your network config can do really bad things to your server.. so asses for yourself if you want to take the risk.. as I don't want to be held responsible if you Bork your server!!

This was done on a fresh install of the Proxmox image from the online console. and only works for KVM not OVZ.

1) Enable IPv6

/etc/modprobe.d/local.conf

options ipv6 disable=0

2) Get IPv6 to start on boot add the line ipv6 below loop

/etc/module

ipv6

3) Reboot server to enable IPv6

4) Enable Forwarding and Proxy

/etc/sysctl.conf

net.ipv6.conf.all.forwarding = 1
net.ipv6.conf.all.proxy_ndp = 1
net.ipv6.bindv6only = 1

5) in putty issue command

sysctl -p

6) From the online console go to the IPv6 tab and create a /64 subnet from your /48 IP block.

7) Create a new file named dhclient6.conf in

/etc/dhcp/

Replace DUID with the DUID number of the /64 from the online console.

interface "vmbr0" {
send dhcp6.client-id DUID;
request;
}

8) Network Configuration, add the following lines to your interfaces file

/etc/network/interfaces

iface vmbr0 inet6 static
    address YourIPv6::1
    netmask 64
    accept_ra 2
    pre-up dhclient -cf /etc/dhcp/dhclient6.conf -pf /run/dhclient6.eth0.pid -v -nw -6 -P vmbr0
    pre-down dhclient -x -pf /run/dhclient6.eth0.pid
    
# vmbr2: IPv6
auto vmbr2
iface vmbr2 inet6 static
    address YourIPv6::2
    netmask 64
    bridge_ports none
    bridge_stp off
    bridge_fd 0 
    post-up echo 1 > /proc/sys/net/ipv6/conf/all/proxy_ndp
    post-up echo 1 > /proc/sys/net/ipv6/conf/all/forwarding
    post-up echo 1 > /proc/sys/net/ipv6/conf/default/forwarding
    post-up /sbin/ip -f inet6 neigh add proxy YourIPv6::2 dev vmbr2
    post-up /sbin/ip -f inet6 neigh add proxy YourIPv6::3 dev vmbr0
    post-up /sbin/ip -f inet6 route add YourIPv6::3 dev vmbr2`

9) Start DHCP issue the command in putty

dhclient -cf /etc/dhcp/dhclient6.conf -6 -P -v vmbr0

10) Restart Network issue the command in putty

service networking restart

to add more IPv6 just add

post-up /sbin/ip -f inet6 neigh add proxy YourIPv6::4 dev vmbr0
post-up /sbin/ip -f inet6 route add YourIPv6::4 dev vmbr2`

Very Important That you Do not use vmbr0 when creating a VM or your servers network port will be disabled and you will not be able to connect to your dedi!! until support resets your port.

In Proxmox you must use vmbr2 as your Network Device when creating a VM and use YourIPv6::2 as your gateway and I used google's DNS which is 2001:4860:4860::8888

Also note that if you add more IPv6 to the interfaces file and restart the network you need to also restart each VM cause they loose connectivity until a reboot.

I'm not very good at writing tutorials so if this was confusing or did not work out for you, I apologize but I am not able to help further than what I have already posted as my networking knowledge is somewhat limited.
Just posting what I found works in my case by following tutorials I found from the net.. Hopefully it helps somebody out.

Reference:

http://documentation.online.net/en/serveur-dedie/reseau/ipv6-prefix

http://forum.online.net/index.php?/topic/4729-howto-ipv6-using-dhclient-for-ubuntu/

http://tech.poirsouille.org/2014/09/proxmox-configuration-ipv6-avec-dhclient/

http://forum.ovh.co.uk/showthread.php?5844-IPv6-with-Proxy-ARP

http://forum.online.net/index.php?/topic/4059-solved-proxmox-and-ipv6/

Possibly a few more but I can only recall the one's listed..

Comments

Sign In or Register to comment.