Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Additional IP Config in Hetzner : Messed UP
New on LowEndTalk? Please Register and read our Community Rules.

Additional IP Config in Hetzner : Messed UP

Mahfuz_SS_EHLMahfuz_SS_EHL Member, Provider

Hi,

I tried to do virtualization with A lot of software. Everything failed. Virtualizor seemed to be one way ahead. It could do everything. Just, when I tried to ssh via the IP I allocated to the VM, instead of logging into the VM, it logged in the Main Node.

In their IP Configuration Wiki, there are three tutorials. I can't understand which one I have to follow.

Anyone to help ??

Thanks.

Thanked by 1mpkossen

AlphaSSL Revocation Issue is being investigated.

«1

Comments

  • Ow man I have lost 5 days trying it and on the end I have canceled my server. They have 0 support! I hope you will get it fixed.

    Buy Site Ads - Advertising Platform

  • edited February 2015

    http://wiki.hetzner.de/index.php/Netzkonfiguration_CentOS/en#Routed_.28brouter.29

    This is the one you have to run a routed bridge configuration.

    VPS's out of Asheville, NC, Amsterdam, LA (Quadranet): https://my.aggressivenetworks.com

  • ndelaespadandelaespada Member, Provider

    owned-networks | ssd ddos protected kvm & openvz 7 | DAL - LA - SEA - NYC - MIA - AMS - LON
    english, french & spanish support

  • I have used hour on hour on this issue the last weeks. But I'm using Windows Server 2012 R2 as main server OS, and then Hyper-V to create VMs.
    It's two main difference with the IPs you get from Hetzner.
    1. The three extra IPs; Here you have via Robot click on the symbol badk the IP to get the MAC, then you have to have the option to change MAC on the VM nic in whatvever software you are using. Then you have to change MAC on the VM wleol Then your online.

    If you have a subnet, things gets more complicated, but I*m got i to work this week.
    What kind of OS or you running?

    Kenneth Myhre
    WindowsTemplate.com - free Windows templates for OVH/Hetzner/Kimsufi/Online.net

    Powered by Hetzner.com, backed up by OVH, Kimsufi and VULTR.com

  • Jazzy8999Jazzy8999 Member
    edited February 2015

    If Virtualizor :

    Create config like this, create bridge

    /etc/sysconfig/network-scripts/ifcfg-viifbr0

    DEVICE=viifbr0

    BOOTPROTO=none

    ONBOOT=yes

    HWADDR=08:60:6E:46:FB:46

    IPADDR=144.76.56.xx ---> main ip addres

    NETMASK=255.255.255.224

    SCOPE="peer 144.76.56.xx" ---> main gateway

    /etc/sysconfig/network-scripts/ifcfg-eth0

    DEVICE=eth0

    BOOTPROTO=none

    ONBOOT=yes

    HWADDR=08:60:6E:46:FB:xx ---> main mac addres

    BRIDGE=viifbr0

    now we use the first usable ip as gateway for VMs

    /etc/sysconfig/network-scripts/ifcfg-viifbr0:1

    DEVICE=viifbr0:1

    TYPE=Bridge

    BOOTPROTO=static

    IPADDR=136.243.212.xx ---> main usable additional ip

    NETMASK=255.255.255.224

    ONBOOT=yes

    DELAY=0

    STP=off

    /etc/sysconfig/network-scripts/route-viifbr0

    ADDRESS0=0.0.0.0

    NETMASK0=0.0.0.0

    GATEWAY0=144.76.56.xx ---> main ip gateway

    and don't forget to add :

    /etc/sysctl.d/10-no-icmp-redirects.conf

    net.ipv4.conf.all.send_redirects=0

    net.ipv4.conf.default.send_redirects=0

    net.ipv4.conf.br0.send_redirects=0

    net.ipv4.conf.virbr0.send_redirects=0

    Restart the network service

  • Jazzy8999Jazzy8999 Member
    edited February 2015

    SolusVM :

    Create config like this, create bridge

    /etc/sysconfig/network-scripts/ifcfg-br0

    DEVICE=br0

    TYPE=Bridge

    BOOTPROTO=none

    IPADDR=213.133.111.xx ---> main ip

    NETMASK=255.255.255.255

    SCOPE="peer 213.133.111.x" ---> main ip gateway

    ONBOOT=yes

    /etc/sysconfig/network-scripts/ifcfg-br0:1

    DEVICE=br0:1

    TYPE=Bridge

    BOOTPROTO=static

    IPADDR=46.4.207.xx ---> first usable additional ip addres

    NETMASK=255.255.255.248

    ONBOOT=yes

    DELAY=0

    STP=off

    /etc/sysconfig/network-scripts/ifcfg-eth0

    DEVICE=eth0

    BOOTPROTO=none

    ONBOOT=yes

    HWADDR=6C:62:6D:B2:AE:xx --> main ip mac address

    BRIDGE=br0

    /etc/sysconfig/network-scripts/route-br0

    ADDRESS0=0.0.0.0

    NETMASK0=0.0.0.0

    GATEWAY0=213.133.111.xx ---> main gateway ip

    /etc/sysctl.d/10-no-icmp-redirects.conf

    net.ipv4.conf.all.send_redirects=0

    net.ipv4.conf.default.send_redirects=0

    net.ipv4.conf.br0.send_redirects=0

    net.ipv4.conf.virbr0.send_redirects=0

    Restart network service

  • Jazzy8999Jazzy8999 Member
    edited February 2015

    Means if you get ips , different subnet, in other way you have to use 1 additional ip as a gateway. I'm using CentOS, and good luck !

  • @Jazzy8999 said:
    Means if you get ips , different subnet, in other way you have to use 1 additional ip as a gateway. I'm using CentOS, and good luck !

    This is only true if you get a /29 /28 or /27 subnet. You also have the option to get three extra IPs from Hetzner (not failover IPs). If you are using the correct MAC from the IP (that you can find in Robot) you can use DHCP and you will still get the correct IP on the VM. Trust me, I have really used lots of time on this the last weeks.

    If you have a subnet, you have to follow one of Hetzners guides for your OS, and then maybe your setup work.

    Kenneth Myhre
    WindowsTemplate.com - free Windows templates for OVH/Hetzner/Kimsufi/Online.net

    Powered by Hetzner.com, backed up by OVH, Kimsufi and VULTR.com

  • Jazzy8999Jazzy8999 Member
    edited February 2015

    That was for additional subnet.
    If you go with 3 additional ips, you have to request separate mac address, and add those ips to ip pool with the correct mac.

    I have 2 servers with them which running virtualizor and solusvm. Both using 3 ips and /28 subnet

  • But then my point from my early post in this thread stands, if he just have extra IPs, MAC is the solution. If he has a subnet, your solution is the correct one with his setup.
    If he had used Windows, it's even more simpler.

    Kenneth Myhre
    WindowsTemplate.com - free Windows templates for OVH/Hetzner/Kimsufi/Online.net

    Powered by Hetzner.com, backed up by OVH, Kimsufi and VULTR.com

  • Mahfuz_SS_EHLMahfuz_SS_EHL Member, Provider

    I have only the 3 Additional IPs, don't have the flexipack. So, which will I follow ?? @Jazzy8999 @myhken

    AlphaSSL Revocation Issue is being investigated.

  • The info I gave you first time, it's for the three extra IPs without flexipack. But I don't know the software you use, so you have to find out where you can change the MAC for the networkcard on the VM, then change the MAC inside the VM, then set things to DHCP, then reboot, and you should be online.

    Thanked by 1NeoXiD

    Kenneth Myhre
    WindowsTemplate.com - free Windows templates for OVH/Hetzner/Kimsufi/Online.net

    Powered by Hetzner.com, backed up by OVH, Kimsufi and VULTR.com

  • If you want easy and working configuration(KVM, bridged), install Proxmox with "installimage".
    Then, order MAC for IP with robot. Create VM on Proxmox and add MAC for VM network configuration. Then, your VM will get IP automagically with DHCP.
    Proxmox works just like myhken said. :)

    Thanked by 1Falzo
  • Mahfuz_SS_EHLMahfuz_SS_EHL Member, Provider

    This is the result after everything done:

    [email protected] network-scripts]# service network restart  
    Shutting down interface eth0:                        [  OK  ]
    Shutting down interface viifbr0:  Device viifbr0 has MAC address FE:FF:FF:FF:FF:FF, instead of configured address 54:04:A6:EF:B5:14. Ignoring.
                                                         [FAILED]
    Shutting down loopback interface:                    [  OK  ]
    Bringing up loopback interface:                      [  OK  ]
    Bringing up interface eth0:                          [  OK  ]
    Bringing up interface viifbr0:  Determining if ip address 173.9.176.1xx is already in use for device viifbr0...
    RTNETLINK answers: File exists
                                                         [  OK  ]
    

    @Jazzy8999

    AlphaSSL Revocation Issue is being investigated.

  • Jazzy8999Jazzy8999 Member
    edited February 2015

    Remove the mac address from viifbr0, but you told me that you used 3 additional ips rather than additional subnet. If you using 3 additional ips, just request separate mac address from robot and add those ips into the ip pool or add the ip when creating vm if it a single ip

    Edit : arghhh sorry for my poor english, lol

  • Mahfuz_SS_EHLMahfuz_SS_EHL Member, Provider

    How o remove that MAC ?? @Jazzy8999

    AlphaSSL Revocation Issue is being investigated.

  • Mahfuz_SS_EHLMahfuz_SS_EHL Member, Provider

    I'm confused about Subnet. Can you let Me know how can I know that of it's different subnet of Same ??

    AlphaSSL Revocation Issue is being investigated.

  • winnervpswinnervps Member, Provider

    Hetzner can't afford Xen Vitualization as far as I experienced. The bridging things can't work ;( I havent' tried KVM yet, but OVZ works great.
    The only possible way is creating one VM (one IP) as a bridge for all VMs and this is rather (very) difficult things to do. I don't know if Chris (smartservermanagement is here, he might lend a hand on this)

    WINNERvps | Jakarta Tier3 DataCenter and Network Services

  • Mahfuz_SS_EHLMahfuz_SS_EHL Member, Provider

    @Jazzy8999 said:
    That was for additional subnet.
    If you go with 3 additional ips, you have to request separate mac address, and add those ips to ip pool with the correct mac.

    I have 2 servers with them which running virtualizor and solusvm. Both using 3 ips and /28 subnet

    I think @myhken you can help Me. I have got My Separate MAC. But, how to do the rest?? Can you give Me the Complete commands?? I mean IP Pool.......

    AlphaSSL Revocation Issue is being investigated.

  • @Mahfuz_SS_EHL said:
    I'm confused about Subnet. Can you let Me know how can I know that of it's different subnet of Same ??

    http://en.wikipedia.org/wiki/Subnetwork

  • Mahfuz_SS_EHLMahfuz_SS_EHL Member, Provider

    @myhken I'm using CentOS 6.6 32 Bit, has no FlexiPack ! Got My MAC !

    AlphaSSL Revocation Issue is being investigated.

  • Mahfuz_SS_EHLMahfuz_SS_EHL Member, Provider

    Did everything, still the IP doesn't Ping. I selected Routed Network fron the IP Pool and also set the Separate MAC I got from the Robot.

    /etc/sysconfig/network-scripts/ifcfg-eth0
    DEVICE=eth0
    BOOTPROTO=none
    ONBOOT=yes
    HWADDR=08:60:6E:46:FB:xx ---> main mac addres
    BRIDGE=viifbr0
    

    Can you let Me know what's the Main MAC Address here ?? Not the Main IP ?? If it's for the Main IP, then wouldn't it be The HWADDR ?? I'm little bit confused ! @Jazzy8999

    AlphaSSL Revocation Issue is being investigated.

  • Mahfuz_SS_EHLMahfuz_SS_EHL Member, Provider

    It's little bit difficult to understand. Can't it be detected from the IP Address ??

    AlphaSSL Revocation Issue is being investigated.

  • Mahfuz_SS_EHLMahfuz_SS_EHL Member, Provider

    The Additional IP only was online when I created the file named "ifcfg-eth0:0" after that with no configuration it was pinging !

    AlphaSSL Revocation Issue is being investigated.

  • Mahfuz_SS_EHLMahfuz_SS_EHL Member, Provider

    Okay, You have an additional Subnet which I don't have. So, will there be any changes in the comfig you provided??

    AlphaSSL Revocation Issue is being investigated.

  • Can't help you anymore since you are using different software then I do. In Hyper-V I just set the MAC on the network card to the VM, then install the VM, then it's online.
    If I want to change IP, I just change MAC on the network card to the VM in Hyper-V, then see if the VM changes MAC by it self, if not, just changing MAC inside the VM, reboot, and then I'm online.

    Never used the software you are using (Proxmox)

    Kenneth Myhre
    WindowsTemplate.com - free Windows templates for OVH/Hetzner/Kimsufi/Online.net

    Powered by Hetzner.com, backed up by OVH, Kimsufi and VULTR.com

  • @Mahfuz_SS_EHL said:
    Okay, You have an additional Subnet which I don't have. So, will there be any changes in the comfig you provided??

    No i used the additional ips

  • Mahfuz_SS_EHLMahfuz_SS_EHL Member, Provider
    edited February 2015

    The Fact is that you have shown Me it's pinging from the VM itself. But, My Problem is Virtualizor showing the VPS being online, but from My Connection I can't connect to it, can't ssh, and If I try to ping it from CMD, then it shows Connection Timeout, So My Problem is that the connectivity between My Connection and that IP. @Jazzy8999

    AlphaSSL Revocation Issue is being investigated.

Sign In or Register to comment.