Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
Vanilla and htacces + cloudflare = 404 error
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

Vanilla and htacces + cloudflare = 404 error

ZweiTigerZweiTiger Member, Provider
edited January 2015 in Help

Hi guys,

I enabled cloudflare with ssl for one of my personal site.

Here is the default vanilla htacces:

> # Original
> # If you modify this file then change the above line to: # Modified
> <IfModule mod_rewrite.c>
>    RewriteEngine On
>    # Certain hosts may require the following line.
>    # If vanilla is in a subfolder then you need to specify it after the /. 
>    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
>    # RewriteBase /
>    RewriteCond %{REQUEST_FILENAME} !-d
>    RewriteCond %{REQUEST_FILENAME} !-f
>    RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
> </IfModule>

My main problem is many links are broken. 404 error. So how to fix it?

Forum is in the main directory

Comments

  • HyperSpeedHyperSpeed Member
    edited January 2015

    Does this happen when Cloudflare is on Dev mode?
    How do you know it's down to Cf because I don't think I've ever had Cf effect Htaccess rewrite, mine works fine? - Sounds more like a SSL issue

    Ex-Sys Admin

  • jarjar Provider

    Tail your access log to see what is actually being requested. The redirects shown will not be dependent on port 80 or 443 specifically.

    Thanked by 1HyperSpeed
  • ZweiTigerZweiTiger Member, Provider

    @HyperSpeed said:
    Does this happen when Cloudflare is on Dev mode?
    How do you know it's down to Cf because I don't think I've ever had Cf effect Htaccess rewrite, mine works fine? - Sounds more like a SSL issue

    Actually this is a flexible SSL at this time.

Sign In or Register to comment.