Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with OpenID
Advertise on

In this Discussion

rndc reload failed bad zone
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

rndc reload failed bad zone

ShamliShamli Member
edited August 2012 in General

I have a multiple zone,the others are working fine when reloading the zone, except for one. Does anyone know what caused this. Or how to solve this.

Get Free USD10 in DigitalOcean credit


  • I guess you need to post the zone. Obviously this two lines aren't the best way to get help.

  • ShamliShamli Member
    edited August 2012

    haha.sure...just thought maybe there is someone may help without looking at the zone...

    here it is..

    $TTL        86400
    @       IN      SOA (
                            2012080218       ; serial, todays date + todays serial #
                            28800              ; refresh, seconds
                            7200              ; retry, seconds
                            604800              ; expire, seconds
                            86400 )            ; minimum, seconds
    *.image 86400 A
    billing 86400 A        184.xx.206.125
    docs 86400      CNAME
    extplorer 86400 A
    eyeos9 86400 A        184.xx.236.231 86400 A 86400      MX    20   ALT1.ASPMX.L.GOOGLE.COM. 86400      MX    20   ALT2.ASPMX.L.GOOGLE.COM. 86400      MX    10   ASPMX.L.GOOGLE.COM. 86400      MX    30   ASPMX2.GOOGLEMAIL.COM. 86400      MX    30   ASPMX3.GOOGLEMAIL.COM. 86400      MX    30   ASPMX4.GOOGLEMAIL.COM. 86400      MX    30   ASPMX5.GOOGLEMAIL.COM. 86400      MX    10 86400      NS 86400      NS 86400      NS
    image 86400 A
    mail 86400      CNAME
    moon 86400 A
    stats 86400 A
    status 86400 A
    statuss 86400 A
    vks01 86400 A
    vp1 86400 A
    vp10 86400 A
    vp11 86400 A
    vp2 86400 A
    vp7 86400 A
    vp8 86400 A
    vp9 86400 A
    webmail 86400 A
    webmails 86400 A

    I'm just disguising the domain and the IP for it to be posted here...

    Get Free USD10 in DigitalOcean credit
  • I think error log make much sense for troubleshooting

  • where do I find the error log.? seems like I cant find it.

    below is my named.conf.options

    options {
        directory "/var/cache/bind";
        // If there is a firewall between you and nameservers you want
        // to talk to, you may need to fix the firewall to allow multiple
        // ports to talk.  See
        // If your ISP provided one or more IP addresses for stable 
        // nameservers, you probably want to use them as forwarders.  
        // Uncomment the following block, and insert the addresses replacing 
        // the all-0's placeholder.
        // forwarders {
        // };
        auth-nxdomain no;    # conform to RFC1035
        listen-on-v6 { any; };
            channel query_logging {
                    file "/var/log/bind/bindquery.log" versions 10 size 30m;
                    severity debug 3;
                    print-time yes;
                    print-severity yes;
                    print-category yes;
            #   syslog syslog;
            category queries {
    Get Free USD10 in DigitalOcean credit
  • yomeroyomero Member
    edited August 2012

    Your zone file seems fine for me. I haven't worked too much with DNS stuff, but maybe some dumb points due to my lack of knowdlege to try.

    The semicolon without comment is valid? The *.image entry is valid?

    And well, you always can try to remove stuff from the zone to see what entry is causing the error.

    Btw, the error log, well you can find some messages at /var/log/syslog (at least in Debian based distros)

  • ExpertVMExpertVM Member, Provider

    Can you run this command to check the zone data?

    /usr/sbin/named-checkzone /path/to/your/zone/file/ - Singapore Based Low End Provider.
    Thanked by 1NanoG6
  • ShamliShamli Member
    edited August 2012

    found it...though it never happened before.. so,I have updated the record,and it's solved....

    thanks guys...=)

    # /usr/sbin/named-checkzone /etc/bind/
    zone NS '' has no address records (A or AAAA)
    zone NS '' has no address records (A or AAAA)
    zone NS '' has no address records (A or AAAA)
    zone not loaded due to errors.

    @Yomero those are valid before...perhaps after I dist-upgrade recently that caused this....

    Get Free USD10 in DigitalOcean credit
  • Oh, I forggot that command +1 to ExpertVM

Sign In or Register to comment.