Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
PeakServers ignoring my tickets
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

PeakServers ignoring my tickets

Hi,

I would like the community's opinion on this.

In june I ordered a VPS with PeakServers and paid for a year. Earlier this month it was suspended without any reason.
I then submitted a ticket, asking why It was suspended and got no answer. Followed up on my ticket, still no answer. Created a new ticket, still no answer. Then they just closed my tickets with no answer.

I'm kinda lost here, I was hoping this could be resolved in a mature way. But I guess thats not the way PeakServers do business.
It's not about the money, as it was only $12, it's the whole "lets ignore him, and he might go away" attitude.

What would you guys do ? Just let it go ?

Comments

  • @ihatetonyy your browser is infected by Merry Christmas malware

  • @Maller Paypal dispute, and submit fraud record in this case.

  • NekkiNekki Moderator

    If they're completely ignoring you, you may as well raise the dispute; if they ignore the dispute too, you'll get your money back.

    Thanked by 1ErawanArifNugroho

    Here lies Nekki. He loved massive amounts of storage, K-Pop and calling people cunts.

  • Two days ago I asked to setup rdns and they answered today, not so fast but they did it.

  • MallerMaller Member
    edited December 2014

    @ScienceOnline said:
    Two days ago I asked to setup rdns and they answered today, not so fast but they did it.

    With the holidays and all two days are acceptable for me. But I submitted my first ticket 21/12 and they just closed it. So it's not a matter of being slow, but ignoring me.

  • Got same experience like you. I bought the $12/yr. plan and they suspend my VPS without reason or notification. I just run lighttpd and OpenVPN in it. I'm sure I didn't violate the TOS because I read it twice before ordering. Explained the details in ticket but to no avail.

Sign In or Register to comment.