Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
ipv6 routing / 6to4 tunnel server
New on LowEndTalk? Please Register and read our Community Rules.

ipv6 routing / 6to4 tunnel server

flyfly Member
edited July 2012 in Help

so i've got an archlinux box with a /56 (ipv6) routed to it.

I'm looking at http://superuser.com/questions/304786/ipv6-tunnel-via-own-linux-ipv6-connected-server
to try to get a /64 out of that /56 and set up a 6to4 server so I can tunnel from my windows laptop at home.

But for whatever reason, it's not working. The guide isn't very helpful... it's just straight up copypasta so I have no idea how I would diagnose where I'm doing it wrong.
Any help?

Comments

  • rm_rm_ Member
    edited July 2012

    6to4 is a completely different thing, not what you're trying to do.
    You mean a 6in4 tunnel.

    I dunno, post more specifics, what exactly do you run on both sides and what result do you get.

    Does your laptop have a public IPv4 address? If it's your router that has one, you need to set up DMZ to the laptop's LAN IP or set up forwarding of protocol 41 (not port 41) to it.

    Also, instead of setting up your own tunnel server, you could consider using the http://tunnelbroker.net/ service.

  • WilliamWilliam Member, Provider

    @rm_ said: Also, instead of setting up your own tunnel server, you could consider using the http://tunnelbroker.net/ service.

    Very slow sadly...

  • @William said: Very slow sadly...

    Is there a faster way when setting up an own server as the IPv6 gateway/tunnel server?

  • rm_rm_ Member
    edited July 2012

    @William said: Very slow sadly...

    I did not find tunnelbroker.net to be slow at all. Just ensure you choose a tunnel server closest to you, but if that doesn't help (maybe it's overloaded) try the next closest one.

  • KeithKeith Member

    If your Archlinux box is OpenVZ it probably won't work with the kernel you're using. KVM & Xen should work ok.

    This is how I've used 6to4 with Debian

    create /root/6to4.sh

    #!/bin/sh

    set -e
    ip4=$1
    echo "$ip4" | grep -q '^[0-9].[0-9].[0-9].[0-9]$' || \
    { echo 'Syntax: $0 a.b.c.d'; exit 1; }
    prefix=$(printf '%02x%02x:%02x%02x\n' $(echo $ip4 | sed 's/./ /g'))
    ip tunnel add 6to4 mode sit remote any local $ip4
    ip link set dev 6to4 up
    ip addr add 2002:$prefix::bad:babe/16 dev 6to4
    ip -6 route add ::/0 via ::192.88.99.1 dev 6to4 metric 1026

    chmod +x /root/6to4.sh

    Then in /etc/rc.local add this line
    /root/6to4.sh nn.nn.nn.nn
    where nn.nn.nn.nn is your external ipv4 address.

    run /root/6to4.sh nn.nn.nn.nn to setup without rebooting.

    For your own 6to4 relay router on a dual stack vps repeat this with the ip -6 route line omitted.

    To use the 6to 4 relay router from another vps/home change ::192.88.99.1 to ::xx.xx.xx.xx where xx.xx.xx.xx is the external ipv4 address of your relay router.

    Protocol 41 forwarding may have to be enabled on your router and allowed through the firewall.

  • flyfly Member

    yeah i'm guessing the problem i'm running into is the port being blocked. i'll have to get access to the router and take a peek.

Sign In or Register to comment.