Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Problems with CentOS PHP 5.3 with Curl
New on LowEndTalk? Please Register and read our Community Rules.

Problems with CentOS PHP 5.3 with Curl

BlazeMuisBlazeMuis Member
edited July 2012 in General

I tried installing Php-Curl on CentOS, but i just keep getting this error:

yum install php-curl
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mi.mirror.garr.it
 * extras: mi.mirror.garr.it
 * updates: mi.mirror.garr.it
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php53-common.i386 0:5.3.3-13.el5_8 set to be updated
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-13.el5_8.i386 from updates has depsolving problems
  --> php53-common conflicts with php-common
Error: php53-common conflicts with php-common
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

I did the:

package-cleanup --problems

and

package-cleanup --dupes

But still aint working

Can someone help me with this?

Comments

  • tried yum install php53-curl

    The Original Daniel.

  • I get:

    No package php53-curl available.
  • edited July 2012

    Is that the only depsolv issue? If you get depsolvs on everything it could be an error in the template

  • @ShardHost said: Is that the only depsolv issue? If you get depsolvs on everything it is likely an error in the template

    Many of the OpenVZ CentOS templates are broken to the core.

    Thanked by 1Jack

    The Original Daniel.

  • yum search curl and the get one that has php in front of it.

    Catalyst Host - Pie Approved!
  • @HalfEatenPie said: yum search curl and the get one that has php in front of it.

    Don't got any wich has php in front..
    Only python lol

  • @joodle You're screwed man. Put Debian on it.

    Catalyst Host - Pie Approved!
  • @HalfEatenPie Ye, gonna do that

  • PADPAD Member
    edited July 2012

    Its because a lot of CentOS templates are broken and/or can be broken. Almost always related to python and very annoying to trace it to the real cause and fix it.

  • If you have the ability to, try replacing the template. Its possible it was an incomplete copy/sync

  • Move from Centos :')

    Thanked by 2klikli yomero

    Security Consultant

  • Reinstalled it with Debian 6 32 bit

    Thanked by 3eastonch djvdorp tux
  • vdnetvdnet Member

    PS, it seems to be it was attempting to install php 5.3. Did you have PHP 5.2 installed?

  • @vdnet i had 5.3 installed

  • vdnetvdnet Member

    Strange, usually php53-common would already be installed then.

  • vdnetvdnet Member
    edited July 2012

    Well a workaround could have been probably uninstall php-common, install php53-common then try again but looks like you have already switched to Deb

    • P.S. Personally I like to compile from source and just save the configure options you use. That way you can quickly get PHP updated for security updates and not have to wait for the OS to put out new packages.
  • Are you sure it wasn't already there? Using PHP 5.3 (from IUS repo, though, not mainline) on Cent/SL and I have curl showing up in phpinfo even though there is no curl package installed.

    "We are in a prison drama. This is like The Shawshank Redemption, only with more tunneling through shit and no fucking redemption."
Sign In or Register to comment.