Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with OpenID
Advertise on

In this Discussion



jarlandjarland Provider
edited June 2012 in Help

Can anyone tell me why I cannot VNC into a KVM guest? I can, of course, connect to the external VNC provided by the providers that I have used, but I am always rejected when trying to connect directly to the guest. This remains true when using any VNC server that attempts to share the existing display (the one I am viewing via the provided external VNC). I am using desktop distributions, currently Ubuntu.

My errors range from just unable to connect to rejected, etc. The clients aren't very specific, but I've used multiple clients on two different operating systems. It would seem as though I am completely missing something about how KVM virtualization effects what I'm trying to do. Providers used have been Hostigation, BuyVM, and SonicVPS. The external VNC messes with my keyboard input and some of my preferred VNC client features, so it is not an option to simply use it.

Hoping someone here can shed some light on it.


  • BluBoyBluBoy Member
    • What windows manager are you running (and why on a LEB??)
    • What VNC Server are you running?
    • How is it configured, what port is it running on?

    Checkout my blog. I review VPS providers and mess around with Debian and FreeBSD!

  • jarlandjarland Provider

    Currently Vino although I've tried x11vnc and can't figure out for the life of me how to attach tightvnc to an existing desktop rather than launching a second instance, doubling my memory usage. Vino runs on 5900 and everything I find about changing its port is outdated, x11vnc I've tried on 5901-5903 as well. I would be inclined to think firewall issue on the node but 3 common providers blocking a standard VNC port would seem odd.

    As for the LEB, I guess they're a step above what we call an LEB here, but they're hosted by common LEB providers.

  • BluBoyBluBoy Member

    OK, the silly questions are out of the way now :)

    Have you tried VNCing into them from the LEB itself? (Just to ensure the server is taking connections). You could probably do a netstat -an and make sure it's listening on the right ports too I guess.

    I very much doubt it, but could the provider be port blocking?

    Checkout my blog. I review VPS providers and mess around with Debian and FreeBSD!

  • jarlandjarland Provider

    You have an interesting observation there. Now, on the BuyVM and Hostigation ones I double checked with netstat that it was listening, and it was. Here I'm getting a complete failure to start. I think I'm going to roll it back to 11.10 anyway...all the fun of 12.04 and half the screwy package upgrades. I'll keep you posted. We all may learn something today, one possible lesson is just how stupid I really am ;)

  • jarlandjarland Provider
    edited June 2012

    Well it looks like that is what it was here. It appears as though I jumped to conclusions that this was the same problem I had experienced twice before, rather than being thorough. There also may be some issues with Vino and x11vnc in general, if not specifically related to KVM (don't even want to speculate on how it could effect them). With x11vnc just now, 1 out of 3 clients I tried would connect and display the desktop. One would hang at connecting, one would connect and display an image similar to an unsupported resolution on an old CRT. Vino is refusing to start on 11.10 and 12.04 for me, and tightvnc is working flawlessly.

    So there's a slight issue for me trying to connect tightvnc to an existing desktop, but I'm getting around that by installing the server distro and then installing the desktop files. If I cared enough I'd sit down and read up on how Ubuntu is starting the desktop and prevent that so that I could launch it with tightvnc from the beginning, but seeing as how little impact that has on any professional application, I'll stick with this way ;)

    I love how it sometimes seems as though I am the only person trying to use a VPS as a desktop computer haha. Idiot or pioneer? I suppose that's relative.

  • KairusKairus Member

    @jarland said: I love how it sometimes seems as though I am the only person trying to use a VPS as a desktop computer haha.

    I recall a lot of OVZ providers having pre-made VNC ready templates, but nothing for KVM.

  • jarlandjarland Provider
    edited June 2012

    Yeah, I wonder how popular those are. In search of exactly the performance, price, and allotment that I want for my personal desktop VPS, I've been able to sample a lot of providers thus far. For this use, so far it's been KVM > Xen > OVZ for me. I guess you could call it a hobby. Absolute best of the 3 points so far has been's Xen package. I'm quite fond of the performance so far on SonicVPS.

    I should start a blog about it, only my experience so far as that I'm quite alone ;)

  • Thanks for the kind words jarland.

    Definitely hope to see more of you around. :)

    Thanked by 1jarland
  • I put lxde on my vpses with tightvnc when I need a desktop on my ubuntu (server version) environment for running java gui apps etc. Works great. Its on my blog,

    Check my blog for more cool *nix tips & tricks!

  • jarlandjarland Provider

    I love unity. I know a lot of people hate it, but since my iPad is nearly the only VNC client I use, it really goes well with a touch screen.

  • pcanpcan Member
    edited June 2012

    @jarland said: I love how it sometimes seems as though I am the only person trying to use a VPS as a desktop computer haha.

    I also sometimes use a VPS as remote desktop. They are useful for testing. I don't use VNC anymore because I have way better response using x2go. You can try this over the base ubuntu 12.04 server install:

    sudo su apt-get update apt-get upgrade aptitude install ubuntu-desktop apt-add-repository ppa:x2go/stable apt-get update apt-get install x2goserver

    nano /etc/ssh/sshd_config edit: enable ChallengeResponseAuthentication to YES

    apt-get install x2goserver-xsession

    Download, install and start the free x2go client. On the x2go client configuration, use this custom command: /usr/bin/gnome-session –session=ubuntu-2d

    Thanked by 1djvdorp
  • Why not just use X11 over SSH.

    apt-get install xfce4

    ssh -X -C [email protected]eb


    The Original Daniel.

  • jarlandjarland Provider

    @pcan x2go is definitely faster in my experience. My primary client is my iPad, I haven't found an app that supports x2go yet (idea for devs?).

    @MrLadoodle I've been thinking about that, my ssh app actually runs a built in x server. I'm just confused about making it recognize it, documentation is terrible for iSSH.

Sign In or Register to comment.