Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
Apache 403 error
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

Apache 403 error

JoeBissJoeBiss Member

Hello all,

I have a problem with my VPS. I restarted it and now I have 403 errors in all directories expect:

/downloads/root

I checked the permissions and it has 777 so it's not a problem. I guess it's related to .htaccess but I'm not sure!!

The main direcotry I want people to access the files is /krteam/etc..but I'm getting this error.

Forbidden

You don't have permission to access /krteam/*****/***/2003/****.avi on this server.

Apache/2.2.22 (Debian) Server at ****** Port 80

my httpd.conf file is as follow:


#Options FollowSymLinks
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order deny,allow
Allow from all


Options FollowSymLinks
AllowOverride All
Order Allow,Deny
Allow from all


Options FollowSymLinks
AllowOverride All
Order Allow,Deny
Allow from all


Options Indexes FollowSymLinks
AllowOverride All
Order Allow,Deny
Allow from all


Options FollowSymLinks
AllowOverride All
Order Deny,Allow
Deny from all

I hope this community helps me. Thank you!

Comments

  • JoeBissJoeBiss Member

    My httpd.conf here (it's removed from the first post) and apache2.conf

    https://dl.dropboxusercontent.com/u/22163509/Projects/httpd.conf

    https://dl.dropboxusercontent.com/u/22163509/Projects/apache2.conf

    Thanks a lot.

  • SpencerSpencer Member

    chown -R www-data:www-data /downloads/root

  • @joebiss What are the permissions on the folders? Ownership like @Spencer noted would be a spot to look, but too permissions would be something to look at - too check the error_log/access_log and see if that says any reasons for the 404, if it's a .htaccess or otherwise it may give some insight.

  • JoeBissJoeBiss Member

    @Spencer said:
    chown -R www-data:www-data /downloads/root

    Thank you @Spencer but downloads/root is working fine for me. Which is good.

    My problem is with /krteam/***

  • chown -R www-data:www-data /krteam then?

    Favourite host in general: Ramnode (affiliate link)
    Favourite host for hourly billing/custom ISOs: Vultr ($50 free credit for new accounts, affiliate link)

  • Do you have an vhosts enabled in /etc/apache2/sites-enabled/ that could include directives that override the ones you posted? Another place to check is the snippet files in /etc/apache2/conf.d/

    Be seeing you.

  • DewlanceVPSDewlanceVPS Member
    edited May 2014
    1. Remove .htaccess file from /krteam/public_html/ and /krteam/*****/***/2003/.htaccess?

    2. Check permission of each folder, eg: /krteam, public folder, xyz., file.

    3. chown krteam:krteam yourfile.avi

    4. Search in google.


    Dewlance
Sign In or Register to comment.