Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Can't install MySQL Server
New on LowEndTalk? Please Register and read our Community Rules.

Can't install MySQL Server

hostnoobhostnoob Member
edited May 2014 in Help

Okay I just got a new VPS from EDIS in Sweden, already got one there running nginx, PHP and MySQL

As soon as I rebuilt it and reset the password, updated APT repositories, etc.. I installed everything with

apt-get install nginx php5-fpm mysql-server php5-mysql

It installed everything except mysql-server-5.5 which fails with this

140506 16:39:21 InnoDB: Using Linux native AIO
140506 16:39:21 InnoDB: Warning: io_setup() failed with EAGAIN. Will make 5 attempts before giving up.
InnoDB: Warning: io_setup() attempt 1 failed.
InnoDB: Warning: io_setup() attempt 2 failed.
InnoDB: Warning: io_setup() attempt 3 failed.
InnoDB: Warning: io_setup() attempt 4 failed.
InnoDB: Warning: io_setup() attempt 5 failed.
140506 16:39:24 InnoDB: Error: io_setup() failed with EAGAIN after 5 attempts.
InnoDB: You can disable Linux Native AIO by setting innodb_use_native_aio = 0 in my.cnf
140506 16:39:24 InnoDB: Fatal error: cannot initialize AIO sub-system
140506 16:39:24 [ERROR] Plugin 'InnoDB' init function returned error.
140506 16:39:24 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
140506 16:39:24 [ERROR] Unknown/unsupported storage engine: InnoDB
140506 16:39:24 [ERROR] Aborting

I tried adding innodb_use_native_aio = 0 to my.cnf but it fails when starting it. Also tried using my-small.cnf from the doc examples folder with/without innodb_use_native_aio = 0 but that fails too

There's nothing in /var/log/mysql.(err/log)

It works fine on my other VPS, but when I ran upgrade it says there's upgrades to mysql-server-5.5 so I haven't upgraded that.

Is it probable there's just something wrong with the package? Can I install an older version from APT?

Favourite host in general: Ramnode (affiliate link)
Favourite host for hourly billing/custom ISOs: Vultr ($50 free credit for new accounts, affiliate link)

Comments

  • SpeedBusSpeedBus Member, Provider
    edited May 2014

    Disable InnoDB and then try.

    EDIT : Add skip-innodb under [mysqld] in my.cnf and then restart the MySQL server

    Thanked by 1hostnoob

    CrownCloud - Internet Services | Los Angeles, California | Frankfurt, Germany | Amsterdam, The Netherlands

  • @SpeedBus said:
    Disable InnoDB and then try.

    EDIT : Add skip-innodb under [mysqld] in my.cnf and then restart the MySQL server

    Tried that, it still fails on startup :(

    Favourite host in general: Ramnode (affiliate link)
    Favourite host for hourly billing/custom ISOs: Vultr ($50 free credit for new accounts, affiliate link)

  • SpeedBusSpeedBus Member, Provider
    Thanked by 1hostnoob

    CrownCloud - Internet Services | Los Angeles, California | Frankfurt, Germany | Amsterdam, The Netherlands

  • hostnoobhostnoob Member
    edited May 2014

    Yeah I found that, step 1 doesn't work

    Trying #2 now

    Edit: Edited the value for #2 in /etc/sysctl.conf and rebooted but it didn't work, tried modifying the file manually but it says access denied :(

    Favourite host in general: Ramnode (affiliate link)
    Favourite host for hourly billing/custom ISOs: Vultr ($50 free credit for new accounts, affiliate link)

  • SpeedBusSpeedBus Member, Provider

    hostnoob said: Yeah I found that, step 1 doesn't work

    Trying #2 now

    Edit: Edited the value for #2 in /etc/sysctl.conf and rebooted but it didn't work, tried modifying the file manually but it says access denied :(

    Probably might need to ask your host to increase the value at /proc/sys/fs/aio-max-nr to something larger

    On my CentOS5 based Virtuozzo node, the default value of aio-max-nr is 65536. A default MySQL 5.5 install will use 2661 of these, leading to the maximum of 24 started MySQL instances with the setting enabled. You should tune the value to be greater than max_instances * 2661 to ensure that you don't run into this issue.

    Thanked by 1hostnoob

    CrownCloud - Internet Services | Los Angeles, California | Frankfurt, Germany | Amsterdam, The Netherlands

  • @SpeedBus said:

    On my CentOS5 based Virtuozzo node, the default value of aio-max-nr is 65536. A default MySQL 5.5 install will use 2661 of these, leading to the maximum of 24 started MySQL instances with the setting enabled. You should tune the value to be greater than max_instances * 2661 to ensure that you don't run into this issue.

    Is there a my.cnf option to change the number of max instances?

    Favourite host in general: Ramnode (affiliate link)
    Favourite host for hourly billing/custom ISOs: Vultr ($50 free credit for new accounts, affiliate link)

  • SpeedBusSpeedBus Member, Provider

    hostnoob said: Is there a my.cnf option to change the number of max instances?

    I don't think so, contact the host with the link to that openvz forum post and they should be able to fix it up.

    Thanked by 1hostnoob

    CrownCloud - Internet Services | Los Angeles, California | Frankfurt, Germany | Amsterdam, The Netherlands

  • @SpeedBus said:
    I don't think so, contact the host with the link to that openvz forum post and they should be able to fix it up.

    Thanks for your help. I tried the same thing on my OVH box and it installed fine, even with the same aio-max-nr

    In the end I've just gone ahead and installed MariaDB instead which works fine :)

    Problem kinda solved

    Thanks again

    Favourite host in general: Ramnode (affiliate link)
    Favourite host for hourly billing/custom ISOs: Vultr ($50 free credit for new accounts, affiliate link)

Sign In or Register to comment.