Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
Why postfix is always in queue instead of sending mails?
New on LowEndTalk? Please Register and read our Community Rules.

Why postfix is always in queue instead of sending mails?

jrdaijrdai Member
edited March 2014 in Help

I was trying to configure the postfix to send mail only.

Mar 21 06:36:50 localhost postfix/postfix-script[8747]: starting the Postfix mail system
Mar 21 06:36:50 localhost postfix/master[8748]: daemon started -- version 2.6.6, configuration /etc/postfix
Mar 21 07:14:21 localhost postfix/pickup[8750]: 7443121B13: uid=0 from=
Mar 21 07:14:21 localhost postfix/cleanup[8852]: 7443121B13: message-id=<[email protected]>
Mar 21 07:14:21 localhost postfix/qmgr[8751]: 7443121B13: from=, size=513, nrcpt=1 (queue active)

# mailq
-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
7443121B13*     513 Fri Mar 21 07:14:21  [email protected]
(connect to mta7.am0.yahoodns.net[98.138.112.38]:25: Connection timed out)
                                            [email protected]


# postconf -d mydestination
mydestination = $myhostname, localhost.$mydomain, localhost
# postconf -d inet_interfaces
inet_interfaces = all

Anyone has a clue?

Comments

  • khavkhav Member

    It will be a bit offtopic but if you want the server to send emails online , use
    msmtp its much easier to setup than postfix

    http://jesin.tk/how-to-use-msmtp-with-gmail-yahoo-and-php-mail/

    Thanked by 1Profforg

    Checkout my proxy site if you want to bypass geo-restriction for free.

  • rmlhhdrmlhhd Member, Provider

    Looks like connection timed out, maybe the mail server at yahoo its trying to connect to is having some issues.

  • jrdaijrdai Member

    @khav said:
    It will be a bit offtopic but if you want the server to send emails online , use
    msmtp its much easier to setup than postfix

    http://jesin.tk/how-to-use-msmtp-with-gmail-yahoo-and-php-mail/


    Thanks for the option.

    @rmlhhd said:
    Looks like connection timed out, maybe the mail server at yahoo its trying to connect to is having some issues.


    No, I tried hotmail with the same error.

  • @jrdai, first you need to check your connectivity. Is your iptables permit outgoing smtp-connections?

    Also you may try to connect remote smtp server using telnet. Just try to execute following command from shell:

    telnet 98.138.112.38 smtp

    If you will see proper response from remote server - it's postfix issue. If no connection - check firewall or contact your hosting provider.

  • jrdaijrdai Member

    It turns out that the DC is blocking the port 25. I need to use their FREE relay server which has a 100 mails per day restriction, great!

  • @jrdai said:
    It turns out that the DC is blocking the port 25. I need to use their FREE relay server which has a 100 mails per day restriction, great!

    Redstation or something?

    This signature wasted 121 bytes of your data allocation.

    https://nixstats.com/report/56b53d6465689e44598b4567

  • @jrdai You can use ssmtp with mailgun.org on port 587. Fast, low resource sending only mail server.

    Thanked by 1jrdai

    Ramnode (referral link)

  • mikhomikho Member, Provider

    @jrdai said:
    It turns out that the DC is blocking the port 25. I need to use their FREE relay server which has a 100 mails per day restriction, great!

    More and more DC's are doing this as a way to fight spam. Which is pretty good. Unless you are a paranoid person and don't want to relay your emails via the provider.

    I can now be found at https://talk.lowendspirit.com
    or on twitter
    Come say HI! :)
  • jrdaijrdai Member

    @0xdragon said:
    Redstation or something?



    You are damn right.

    pbalazs123 said: You can use ssmtp with mailgun.org on port 587. Fast, low resource sending only mail server.

    Thanks buddy, but I am afraid that port 587 may not work, because when I tried to change the default port 25 to 587 on postfix, it failed. I'll try anyway, thanks.

Sign In or Register to comment.