Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
ChicagoVPS PPTP VPN Issues
New on LowEndTalk? Please Register and read our Community Rules.

ChicagoVPS PPTP VPN Issues

Canadian4evrCanadian4evr Member
edited March 2014 in Help

Hi,

Trying to get a PPTP VPN server working on Ubuntu 12.04. Tried to manually setup and with scripts but keep getting same issue:

Mar 19 04:58:19 VPS pptpd[1280]: CTRL: Client ##.##.##.## control connection started

Mar 19 04:58:19 VPS pptpd[1280]: CTRL: Starting call (launching pppd, opening GRE)

Mar 19 04:58:19 VPS pppd[1281]: Plugin /usr/lib/pptpd/pptpd-logwtmp.so loaded.

Mar 19 04:58:19 VPS pppd[1281]: Couldn't open the /dev/ppp device: No such file or directory

Mar 19 04:58:27 VPS pptpd[1280]: CTRL: EOF or bad error reading ctrl packet length.

Mar 19 04:58:27 VPS pptpd[1280]: CTRL: couldn't read packet header (exit)

Mar 19 04:58:27 VPS pptpd[1280]: CTRL: CTRL read failed

Mar 19 04:58:27 VPS pptpd[1280]: CTRL: Reaping child PPP[1281]

TUN/TAP is enabled, everything looks good, but can't seem to get any clients to start authenticating.

I've contacted ChicagoVPS support but they keep saying they don't support VPN's unless I can tell them what is disabled on their end.

Any ideas?

Comments

  • souensouen Member
    edited March 2014

    Looks like ppp is not enabled (different from tap/tun). If host uses SolusVM or similar, can enable it from there.

    Edit: sorry, to clarify, if you do cat /dev/ppp and it says something about "no such device or address" then should be enabled okay. If ppp is already on and it still errors, check also this tutorial (bottom of the OP): http://forum.interserver.net/forum/threads/pptp-vpn-server-on-ubuntu-12-open-vz.948/

  • RamiRami Member

    PPTP need PPP module to be enabled (not TUN/TAP module)

    You should be able to enable it from the control panel or ask your provider to enable it if not

  • Hey,

    Thanks for the replies. I checked that ppp is enabled, ran that command and got:

    cat: /dev/ppp: No such file or directory

    So looks like that is running. Any other ideas?

  • Issue the command:

    cat /proc/devices

    and make sure the ppp module is loaded. If not then you can tell ChicagoVPS you need it loaded on the node (if this is an OpenVZ VPS).

    If this is a KVM, make sure you have loaded the ppp module:

    modprobe ppp_generic

    See ya...

    d.c.

  • Canadian4evrCanadian4evr Member
    edited March 2014

    That command gave me:

    Character devices:

    1 mem

    2 pty

    3 ttyp

    4 /dev/vc/0

    4 tty

    5 /dev/tty

    5 /dev/console

    5 /dev/ptmx

    10 misc

    128 ptm

    136 pts

    Block devices:

    I believe ppp isn't loaded, am I right?

  • Ok ppp module is loaded now. Still can't connect though.

    Mar 19 19:24:41 pptpd[653]: CTRL: Client 72.38.198.66 control connection started

    Mar 19 19:24:41 pptpd[653]: CTRL: Starting call (launching pppd, opening GRE)

    Mar 19 19:24:41 pppd[654]: Plugin /usr/lib/pptpd/pptpd-logwtmp.so loaded.

    Mar 19 19:24:41 pppd[654]: pppd 2.4.5 started by root, uid 0

    Mar 19 19:24:41 pppd[654]: Using interface ppp0

    Mar 19 19:24:41 pppd[654]: Connect: ppp0 <--> /dev/pts/2

    Mar 19 19:24:41 pptpd[653]: GRE: Bad checksum from pppd.

    Mar 19 19:25:11 pppd[654]: LCP: timeout sending Config-Requests

    Mar 19 19:25:11 pppd[654]: Connection terminated.

    Mar 19 19:25:11 pppd[654]: Modem hangup

    Mar 19 19:25:11 pppd[654]: Exit.

    Mar 19 19:25:11 pptpd[653]: GRE: read(fd=6,buffer=80504c0,len=8196) from PTY failed: status = -1 = Input/output error, usually caused by unexpected termination of pppd, check option syntax and pppd logs

    Mar 19 19:25:11 pptpd[653]: CTRL: PTY read or GRE write failed (pty,gre)=(6,7)

    Mar 19 19:25:11 pptpd[653]: CTRL: Reaping child PPP[654]

    Mar 19 19:25:11 pptpd[653]: CTRL: Client 72.38.198.66 control connection finished

  • Have you rebooted your VPS to make sure no deadlocked processes are still stuck on /dev/ppp?

    Have you checked your iptables to make sure you are not blocking GRE protocol?

  • Rebooted VPS and ran these commands:

    sudo iptables --append INPUT --protocol 47 --jump ACCEPT

    sudo iptables --append INPUT --protocol tcp --match tcp --destination-port 1723 --jump ACCEPT

    Nothing else listed in my IPtables.

  • souensouen Member

    It uses ipv4 address, yeah? Try enable ipv4 forwarding for current session and adding iptable entry:

    Edit /etc/sysctl.conf and change net.ipv4.ip_forward: net.ipv4.ip_forward=1
    Add to iptables: iptables -t nat -A POSTROUTING -j SNAT --to youripaddresshere
    service pptpd restart

    On your client, try enabling MPPE also.

  • Got it working, support had to reboot the node which seemed to fix it.

Sign In or Register to comment.