Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
Force Exim (cPanel) to send mail-out using IPv6
New on LowEndTalk? Please Register and read our Community Rules.

Force Exim (cPanel) to send mail-out using IPv6

jmginerjmginer Member, Provider

Hello,

we have 2 cpanel servers with IPv4+IPv6,
if I do a: telnet mx.server1.com smtp

the response is via IPv6

but when I send a email, in the headers I see the mail has sent using IPv4.

There are any way to send emails in exim and force to use IPv6?

Thanks!!

Voxility DDoS protected BGP starting from 250 EUR/month. Contact us.
VPS in Spain ☛ 5.99€/month ★ We accept Bitcoins! ★ DMCA ignore ★

Comments

  • Awmusic12635Awmusic12635 Member, Provider

    Since not all mail servers support IPv6 I don't think that would be a good idea

    Subnet Labs, LLC Contact Us Deploy to: Seattle, Dallas or NYC
    Impact VPS | Cloud Servers | Storage Servers | Impact Shared | Shared Hosting

  • NyrNyr Member
    edited January 2014

    Yeah, don't force but set preference for IPv6 over IPv4 when both are available. No idea about exim config, sorry.

    Also, make sure you are using a dedicated /64 for sending email. Anything less could cause problems if the range is shared with clients.

    Edit: obvious, but PTR is 100% needed with IPv6 too. Gmail directly rejects mail from IPv6 without valid rDNS.

  • nunimnunim Member
    edited January 2014

    I believe cPanel Exim should favor IPv6 by default.

    Go to Exim Configuration > Advanced and see if disable_ipv6 is set to true.

    As Nyr said, make sure you have a valid PTR record for your IPv6.

    Thanked by 1Kevin_K

    SonicBoxes.com - VPS Tips, Tricks & Tutorials
    6UA.net Various tools, screenshots, password gen, looking glass, etc..

  • Exim tries to deliver email via ipv6 by default , but if you dont have rDNS , google will reject your email. I hate to force exim to send it via ipv4 until i set rDNS for ipv6. Then it started accepting it

  • cybermonkcybermonk Member
    edited June 2014

    Guys,
    a little late for a reply but I thought I'd post it anyway in case it helps.

    Cpanel changed the default behaviour of exim a while back and patched it to favour IPV4.

    See changelog 2nd line down.:-

    11.40.0.16
    2013-10-29

    Fixed case 80225: Ensure that new accounts are setup with correct ip.

    Fixed case 80257: Update exim to prefer IPv4 over IPv6.

    Fixed case 80409: Grant roles to database users on account restore.

    Fixed case 80441: Horde: Use INBOX namespace for new folders by default.

    Fixed case 80445: Enforce apache build options for ipv6.

    Fixed case 80625: Postgres and MySQL now report errors in the UI.

    .......

    This can be undone but it's tricky and best open a cpanel ticket for help unless you know what your doing.

    IMHO (FWIW) this was wrong of them to do that. It seems they did it to solve problems many were having with improperly configured IPV6 MX's but really it is the improperly configured ones that should have been fixed rather than nobbling exim.

  • petrispetris Member

    @Nyr said:
    Edit: obvious, but PTR is 100% needed with IPv6 too. Gmail directly rejects mail from IPv6 without valid rDNS.

    In my experience, Gmail will accept mail with a valid SPF entry and a valid DKIM header and no reverse DNS entry.

  • NyrNyr Member

    @petris said:
    In my experience, Gmail will accept mail with a valid SPF entry and a valid DKIM header and no reverse DNS entry.

    Not for IPv6.

  • petrispetris Member

    @Nyr said:
    Not for IPv6.

    Yes with ipv6.

  • NyrNyr Member

    @petris said:
    Yes with ipv6.

    They were enforcing this policy less than a year ago, I experienced this.

  • petrispetris Member

    @Nyr said:
    They were enforcing this policy less than a year ago, I experienced this.

    On Sunday (two days ago) Gmail accepted email from me over ipv6 with no rdns but with SPF and DKIM. Maybe they just like me.

  • AmitzAmitz Member

    @petris said:
    Maybe they just like me.

    Who doesn't? ;)

    For those who care:
    You can now find me at https://talk.lowendspirit.com or https://www.hostballs.com

Sign In or Register to comment.