Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
Can't install SSH2
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

Can't install SSH2

Hello,

I need to install SSH2, but I can't. I'm running into these errors:

Resolving Dependencies --> Running transaction check ---> Package php-devel.i686 0:5.3.3-23.el6_4 will be installed --> Processing Dependency: php(x86-32) = 5.3.3-23.el6_4 for package: php-devel-5.3.3-23.el6_4.i686 --> Processing Dependency: automake for package: php-devel-5.3.3-23.el6_4.i686 --> Processing Dependency: autoconf for package: php-devel-5.3.3-23.el6_4.i686 --> Running transaction check ---> Package autoconf.noarch 0:2.63-5.1.el6 will be installed ---> Package automake.noarch 0:1.11.1-4.el6 will be installed ---> Package php-devel.i686 0:5.3.3-23.el6_4 will be installed --> Processing Dependency: php(x86-32) = 5.3.3-23.el6_4 for package: php-devel-5.3.3-23.el6_4.i686 --> Finished Dependency Resolution Error: Package: php-devel-5.3.3-23.el6_4.i686 (updates) Requires: php(x86-32) = 5.3.3-23.el6_4 Installed: php-5.4.22-1.el6.remi.i686 (@remi) php(x86-32) = 5.4.22-1.el6.remi Available: php-5.3.3-22.el6.i686 (base) php(x86-32) = 5.3.3-22.el6 Available: php-5.3.3-23.el6_4.i686 (updates) php(x86-32) = 5.3.3-23.el6_4 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

What to do?

Comments

  • ihatetonyyihatetonyy Member
    edited November 2013

    try

    yum install php-devel --disablerepo=updates
    - remi has a version of php-devel that yum should be installing to match your remi PHP.
    "We are in a prison drama. This is like The Shawshank Redemption, only with more tunneling through shit and no fucking redemption."
  • Or you could just add this command line argument "--skip-broken"

    Alex L
    BuyCPanel.com - Instant CPanel and VPS License Activations!
    Lowest-Priced External CPanel Licenses
    http://www.BuyCPanel.com

  • Where did you get that php 5.4 package from? Go back there and download the php-devel package and any other php package you need.

    CentOS 6 only comes with PHP 5.3 so that package had to have come from a third party.

Sign In or Register to comment.