Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Linux XRDP blank screen after connecting
New on LowEndTalk? Please Register and read our Community Rules.

Linux XRDP blank screen after connecting

I have setup XFCE and XRDP on Debian 9 (on a VPS) which is working fine as I can connect to it from Windows 10 PC. I can connect to it BUT while I am connected and then leave the PC for like 15, 30 minutes and then come back to the XRDP then it will show blank screen.

Similarly if I disconnect XRDP and then come back later to connect let's say after 1 hour or so, then it will show blank screen. Blank screen is shown after I enter my user and password. After blank screen is shown no matter which key I press or click mouse button it doesn't show desktop and I have to reboot VPS.

After rebooting the XRDP works fine until next time i.e. if I connect again after a couple of hours then blank screen and I have to restart.

So every time I have to use XRDP then I have to reboot VPS. I have tried this at Vultr, DigitalOcean and Linode and same problem.

How to fix this issue?

Comments

  • Do you possibly have some kind of screensaver running that helpfully takes over the screen?

  • aliletalilet Member
    edited September 13

    Don't know where screensaver setting is but I found this power setting. I unchecked "Handle display power management" and changed of "Blank after" to 58 minutes. Then I tried connecting to it after 20 minutes and it worked.

    I believe this setting will allow me to connect again after 58 minutes without problem. Not sure how to increase or completely disable it.

  • @alilet said: I believe this setting will allow me to connect again after 58 minutes without problem. Not sure how to increase or completely disable it.

    Remove upower and xfce4-power-manager?

  • I just recently tried to set up XRDP on Ubuntu 20.04. XRDP+XFCE+GDM3 did not work but wiping the vps and using XRDP+LXDE+Lightdm worked. Try to reinstall your vps and use "apt-get install lxde xrdp" and when prompted opt for Lightdm instead of gdm3. This worked for me. Using xrdp+xfce+gdm3 resulted in remote desktop failure when connecting.

  • @stevewatson301 said:

    @alilet said: I believe this setting will allow me to connect again after 58 minutes without problem. Not sure how to increase or completely disable it.

    Remove upower and xfce4-power-manager?

    Removed both but problem persists.

  • @Ympker said:
    I just recently tried to set up XRDP on Ubuntu 20.04. XRDP+XFCE+GDM3 did not work but wiping the vps and using XRDP+LXDE+Lightdm worked. Try to reinstall your vps and use "apt-get install lxde xrdp" and when prompted opt for Lightdm instead of gdm3. This worked for me. Using xrdp+xfce+gdm3 resulted in remote desktop failure when connecting.

    Is this something lightweight that will work on 1GB RAM?

  • @alilet said:

    @Ympker said:
    I just recently tried to set up XRDP on Ubuntu 20.04. XRDP+XFCE+GDM3 did not work but wiping the vps and using XRDP+LXDE+Lightdm worked. Try to reinstall your vps and use "apt-get install lxde xrdp" and when prompted opt for Lightdm instead of gdm3. This worked for me. Using xrdp+xfce+gdm3 resulted in remote desktop failure when connecting.

    Is this something lightweight that will work on 1GB RAM?

    It worked when I tried it on a 1GB RAM LXC Ubuntu. Not perfect performance but it worked. Lightdm appears to be designed especially to be a more light-weigth alternative to gnome desktop manager.

  • One thing I found that if I logout session instead of just disconnecting RDP then I can login next time without problem. No blank screen.

  • Try wriggling your mouse

    See in my aff garden for VPS and hosting from different providers all in one place.

  • I have faced the same and in my notepad I have written:

    xrdp black screen fix:
    
    /etc/X11/Xwrapper.config
    
    and exchange the line:
    
    allowed_users=console
    
    by
    
    allowed_users=anybody
    

    Hope that helps!

    RC5 cracker since 1998!

Sign In or Register to comment.