Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
SSHFS Problem when mounting
New on LowEndTalk? Please Register and read our Community Rules.

SSHFS Problem when mounting

sgno1sgno1 Member
edited December 2020 in Help

I want to enable my Windows Server to be able to access my Ubuntu Server's Drive. I've done the following below on my Ubuntu Server:

[email protected]:/mnt# sudo sshfs -o allow_other,default_permissions [email protected]:/mnt/storage /mnt/storage [email protected]'s password:

However, I just get stuck on the password part even though I have pressed enter, it's just stuck there. Any ideas? I did it once before and now it no longer works for some odd reason.

Comments

  • This command is wrong I guess. Try only the following one:

    sudo sshfs -o allow_other,default_permissions [email protected]:/mnt/storage /mnt/storage

  • Try keys instead of passwords?

  • edited December 2020

    Why bother using sudo if you are root user.

    A simple uptime dashboard using UptimeRobot API https://upy.duo.ovh
    Currently using VPS from BuyVM, Gullo's, Hetzner, HostHatch, HostSailor, HostSolutions, InceptionHosting, LetBox, MaxKVM, MrVM, VirMach.

  • @kend said:
    This command is wrong I guess. Try only the following one:

    sudo sshfs -o allow_other,default_permissions [email protected]:/mnt/storage /mnt/storage

    It's the same command?

  • @sgno1 said:

    @kend said:
    This command is wrong I guess. Try only the following one:

    sudo sshfs -o allow_other,default_permissions [email protected]:/mnt/storage /mnt/storage

    It's the same command?

    The last part of your command, which was wrong, has been removed.

  • On the Linux VPS
    Change password. Also username if desired.
    Copy paste code after changing password:

    # linux server
    if [ -x "$(command -v apt)" ]; then
      sudo apt -y install sshfs
    fi
    
    if [ -x "$(command -v yum)" ]; then
      #sudo yum --enablerepo=PowerTools -y install fuse-sshfs
      sudo yum -y install fuse-sshfs
    fi
    username=sshfs
    password='insertpwhere'
    useradd -m $username
    echo -e "$password\n$password" | passwd $username
    

    On Windows
    Download and install the 2 programs
    Change the username and password to the account you setup above
    Possibly change drive letter from X to whatever
    Execute net use command from power shell or i think you can type it in explorer location bar.

    # windows client
    # download and install
    # WinFsp and SSHFS-Win
    # from https://github.com/billziss-gh/sshfs-win
    net use X: \\sshfs\[email protected]
    # to delete
    # net use X: /delete
    

    In another thread rclone was mentioned as a better option, it seems to support more protocols. https://www.lowendtalk.com/discussion/comment/3184271

  • trycatchthistrycatchthis Member
    edited December 2020

    @sgno1 said:
    I want to enable my Windows Server to be able to access my Ubuntu Server's Drive. I've done the following below on my Ubuntu Server:

    [email protected]:/mnt# sudo sshfs -o allow_other,default_permissions [email protected]:/mnt/storage /mnt/storage [email protected]'s password:

    However, I just get stuck on the password part even though I have pressed enter, it's just stuck there. Any ideas? I did it once before and now it no longer works for some odd reason.

    I cant remember having to execute this command. All I remember is installing it and it was able to mount. I could be wrong would have to check.

    Unless youre trying to mount the entire disk, while I was just trying to mount the user home directory which is a bit different.

Sign In or Register to comment.