Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
cPanel + LiteSpeed (No suEXEC) How to solve the issues ?
New on LowEndTalk? Please Register and read our Community Rules.

cPanel + LiteSpeed (No suEXEC) How to solve the issues ?

Mahfuz_SS_EHLMahfuz_SS_EHL Member, Provider

Hello,

One of my website was hosted in a cPanel Server alongside LiteSpeed & everything was so smooth. When the amount of visitor increased, I noticed that in LiteSpeed WebAdmin, they are being limited by External App (in this case php 7.4 with suEXEC). So, I maxed the connection from 20 to 2000. Now, everyone was getting response but the server load went high & MySQL wasn't responding.

After that, I found if I disable suEXEC, with the same amount of visitors, the server load remains stable. But, all the plugins & other core functions can't write to directory, make directory etc. At a whole, it can't create any file/directory in public_html area. I went through all the documentation provided by LiteSpeed about concurrent connection & suEXEC but no luck. suEXEC when enabled runs everything in user:user & when disabled runs everything as nobody:nobody. After disabling suEXEC, all the plugins require FTP Login to work & none of them create any directory/file. This is the issue. Anybody has any solution of this problem ??

Regards,
Nagib.

AlphaSSL Revocation Issue is being investigated.

Comments

  • It's expected. Try to change the permissions - Folder 755 and File 644

  • Suexec consume resources because more power need to check proper user and execute with that user. Either turn off it and receive security penalty or just increase server power.

    hostwp.net -- Wordpress Hosting for Developers.

  • Mahfuz_SS_EHLMahfuz_SS_EHL Member, Provider

    @jetchirag said:
    It's expected. Try to change the permissions - Folder 755 and File 644

    That doesn't work. When suexec is turned off, it runs the php as nobody:nobody (user:group) so it should be 775 for directories & 664 for files. This doesn't work either.

    AlphaSSL Revocation Issue is being investigated.

  • Mahfuz_SS_EHLMahfuz_SS_EHL Member, Provider

    @LTniger said:
    Suexec consume resources because more power need to check proper user and execute with that user. Either turn off it and receive security penalty or just increase server power.

    Lastly, I turned it off & turned the php process to run as that specific username:username (user:group) & now it's solved. But, this is just a temporary solution. I'm still trying to find out how to run php in a form so that it can access all the files & directories.

    AlphaSSL Revocation Issue is being investigated.

  • RadiRadi Member, Provider

    Have you tried chmodding all required directories to run as the respective users? For example if your wordpress is running as user/group mahfuz:mahfuz and needs to write to /var/tmp/wordpress, chown wordpress to mahfuz:mahfuz.

    4 GB RAM/90 GB SSD/4 TB Traffic/KVM/1 IPv4 for $7/mo only here with coupon code "LET-It-GO".

  • Mahfuz_SS_EHLMahfuz_SS_EHL Member, Provider

    @Radi said:
    Have you tried chmodding all required directories to run as the respective users? For example if your wordpress is running as user/group mahfuz:mahfuz and needs to write to /var/tmp/wordpress, chown wordpress to mahfuz:mahfuz.

    Yes, tried that. That makes a 403 Forbidden error.

    AlphaSSL Revocation Issue is being investigated.

  • RadiRadi Member, Provider

    In webadmin, somewhere below on general settings, you need to set vhost to run as mahfuz user and group too.

    4 GB RAM/90 GB SSD/4 TB Traffic/KVM/1 IPv4 for $7/mo only here with coupon code "LET-It-GO".

Sign In or Register to comment.