Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
My HostHatch Review
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

My HostHatch Review

Just want to say that my VPS @ HostHatch has been great. I have been using their service for 859 days now and the network has been stellar so far (275 days uptime so far since my last reboot) and had no problems with speed. The support is decent, not great. My problem with them was uploading a custom ISO on my account (that was in 2017), reply times were unimpressive and my ISO issue never got resolved. There was a ticket I submitted on 6/27 and they replied 7/27, stating "We are sorry for the delayed response. Are you still witnessing the issue?" LOL, at least they responded.

No synthetic benchmarks on this review, just my experience on its real-world performance. Overall, great value since the quality of the VPS makes up for the subpar (in my opinion) support (though I understand I have an unmanaged service). These are the specs of the VPS I have with them:

Virtualization: KVM
Storage: 5 GB NVMe
RAM: 1 GB
Bandwidth: 537 GB per month
Location: Amsterdam
2 IP Addresses (1 DDoS Protected with Layer 7)
1 /64 IPv6 Subnet

Annual Price: $16

Comments

  • dustincdustinc Member, Provider
    edited April 3

    Hi edoarudo5,
    Very detailed review and not a bad deal either. Curious if you've recently tested their support? They may have improved since, companies evolve so the community should know that too.

    Either way thanks for sharing the review.

    RackNerd LLC - Introducing Infrastructure Stability
    Dedicated Servers, Private Cloud, DRaaS, Colocation, VPS, DDoS Mitigation, Shared & Reseller Hosting

  • @dustinc said:
    Hi edoarudo5,
    Very detailed review and not a bad deal either. Curious if you've recently tested their support? They may have improved since, companies evolve so the community should know that too.

    Either way thanks for sharing the review.

    Hello dustic,

    Never contacted their support since that last unresolved ticket (ISO issue) since I didn't have any other problem with regards to the VPS. That was in July 2018.

  • dufudufu Member

    My experience with HostHatch for the past year has been very similar. I have a small NVMe VPS and storage VPS. The hardware/network are great, support is below average. Fortunately I didn't have to contact support often since everything is just running very smoothly. Can definitely recommend!

    Thanked by 1edoarudo5
  • Deepak_lebDeepak_leb Member
    edited April 3

    I was one of their customer.
    Servers are solid & prem. No issues so far.

    Using it around 3years. No downtime (expect maintenance time). Good network & hardware ❤️. Overall an satisfied customer.

    Kudos to @Abdullah & their team

    Support ?. Never contacted for vps related queries since I haven't faced any issues.

    Thanked by 1edoarudo5

    quam bene vivas refert non quam diu

  • ofitofit Member
    edited April 4

    @Deepak_leb said:
    I was one of their customer.
    Servers are solid & prem. No issues so far.

    Using it around 3years. No downtime (expect maintenance time). Good network & hardware ❤️. Overall an satisfied customer.

    Kudos to @Abdullah & their team

    Support ?. Never contacted for vps related queries since I haven't faced any issues.

    Agreed.

    The same, used it around 3 years. Good network & hardware. Have 2 times problems with network but in couple days it was solved. Support not that good but everything else on high level. Satifated with them with that price because not use support.

    Thanked by 1edoarudo5
  • thedpthedp Member

    Sounds more of an uptime/infrastructure review :)

    IT/Hosting-related & Miscellaneous Domain Names For Sale!
    Interested in acquiring any of the domain names above? Please send me a PM here, or on Discord (DP#3914).

  • I am a happy HostHatch customer as well, however, I do have one small complaint -- in their Sweden location is seems they oversell a little too much and often throughput to the server can be quite low (only a few MB/sec from Gigabit sources). Granted it is a storage server so I am a little bit forgiving about that, however, it seems to be the case more and more often recently.

    Again, since it was a storage server and used for back-ups and really haven't had a need to restore things super fast, it hasn't been a huge issue, but it has bugged me the few times I have gone to do a restore and found it doing so at super slow speeds.

    I also have servers in NL, NY and Chicago locations and they all work quite well and are very performant, the only issue I have had is the throughput issues I see in Sweden.

    my 2 cents.

    Cheers!

    Thanked by 1uptime

    Have an Allwinner H3 device? Android? Check out H3Droid! | Lichee Pi Zero - The 6$ SBC | #SYSarm - Get It! | Atomic Pi - $35 x86 SBC
    21+ Years IT Experience in Linux/Windows Hosting, Administration and Development Services

  • Kiwi83Kiwi83 Member

    Uploading ISO works flawlessly now, but yeah it was buggy as hell back when it was first implemented.

    Thanked by 1edoarudo5
  • yakblackyakblack Member

    Anyone has problem with their Chicago VPSes? They seem to be very slow recently and are completely down right now!

  • ernie88ernie88 Member

    @yakblack said:
    Anyone has problem with their Chicago VPSes? They seem to be very slow recently and are completely down right now!

    Although uptime in Chicago is great I'm experiencing similar issues on my production 2GB RAM VPS with the connection being slow. It all started all of a sudden about two months ago with getting 504 errors on WP admin from Cloudflare as the website is fully behind it. The next day support replied that no one else had reported similar issues so everything should be ok.

    I've checked every plugin and it didn't help to find the cause. Since I haven't made any changes into the VPS config for several weeks I thought the ufw or fail2ban could be a problem. Turning those services off and checking configs didn't help as everything was set up correctly. I have other 2GB RAM VPS at Hetzner configured the same way and it runs flawlessly.

    After that Cloudflare threw 504 errors at me a few more weeks. And now I don't see the errors but the network seems to be slower than before February. Sometimes WP admin area seems to be loading faster but sometimes slow. Luckily the frontend is behind several server-side caching layers and the site runs rather fast to the visitor. I'm not that great in investigating network issues but would appreciate any hints.

    Thanked by 1yakblack
  • lentrolentro Member, Provider

    Agreed. My storage machine with them works **very ** well. Seems they have gone to the premium side with few ultra low end prices.

    Thanked by 1edoarudo5

    FluidStack: Up to $600 Monthly For Your GPU(s) or Rent Affordable GPU Machines | VC-backed | 2,000+ Machines (aff link)
    ISODME: Web hosting | Managed VPS services | U.S. based support | High Uptime | isodme.com

  • Yeah. HostHatch is awesome.

    Thanked by 1edoarudo5

    PopularWidget.com - Get Popular Posts for Your Websites Without Plugin

  • yolo_meyolo_me Member

    @edoarudo5 said:
    Just want to say that my VPS @ HostHatch has been great. I have been using their service for 859 days now and the network has been stellar so far (275 days uptime so far since my last reboot) and had no problems with speed. The support is decent, not great. My problem with them was uploading a custom ISO on my account (that was in 2017), reply times were unimpressive and my ISO issue never got resolved. There was a ticket I submitted on 6/27 and they replied 7/27, stating "We are sorry for the delayed response. Are you still witnessing the issue?" LOL, at least they responded.

    No synthetic benchmarks on this review, just my experience on its real-world performance. Overall, great value since the quality of the VPS makes up for the subpar (in my opinion) support (though I understand I have an unmanaged service). These are the specs of the VPS I have with them:

    Virtualization: KVM
    Storage: 5 GB NVMe
    RAM: 1 GB
    Bandwidth: 537 GB per month
    Location: Amsterdam
    2 IP Addresses (1 DDoS Protected with Layer 7)
    1 /64 IPv6 Subnet

    Annual Price: $16

    what do you use it for ? Wish I could get a hosthatch storage server for my plex

  • GanonkGanonk Member

    thank for your ripiew

    don't forget to click Thanks

  • @yolo_me said:

    @edoarudo5 said:
    Just want to say that my VPS @ HostHatch has been great. I have been using their service for 859 days now and the network has been stellar so far (275 days uptime so far since my last reboot) and had no problems with speed. The support is decent, not great. My problem with them was uploading a custom ISO on my account (that was in 2017), reply times were unimpressive and my ISO issue never got resolved. There was a ticket I submitted on 6/27 and they replied 7/27, stating "We are sorry for the delayed response. Are you still witnessing the issue?" LOL, at least they responded.

    No synthetic benchmarks on this review, just my experience on its real-world performance. Overall, great value since the quality of the VPS makes up for the subpar (in my opinion) support (though I understand I have an unmanaged service). These are the specs of the VPS I have with them:

    Virtualization: KVM
    Storage: 5 GB NVMe
    RAM: 1 GB
    Bandwidth: 537 GB per month
    Location: Amsterdam
    2 IP Addresses (1 DDoS Protected with Layer 7)
    1 /64 IPv6 Subnet

    Annual Price: $16

    what do you use it for ? Wish I could get a hosthatch storage server for my plex

    I use it as a personal IRC/mail/web server.

  • ernie88ernie88 Member

    sudo bash bench.sh -speed

    sudo bash bench.sh -northamercia

    ## North America Speedtest
    Softlayer, Washington, USA : 0 B/s | N/A | ping 18.498ms
    SoftLayer, San Jose, USA : 0 B/s | N/A | ping 50.481ms
    SoftLayer, Dallas, USA : 0 B/s | N/A | ping error!
    Vultr, New Jersey, USA : 0 B/s | N/A | ping 20.782ms
    Vultr, Seattle, USA : 0 B/s | N/A | ping 42.369ms
    Vultr, Dallas, USA : 0 B/s | N/A | ping 26.129ms
    Vultr, Los Angeles, USA : 0 B/s | N/A | ping 56.871ms
    Ramnode, New York, USA : 0 B/s | N/A | ping 18.452ms
    Ramnode, Atlanta, USA : 0 B/s | N/A | ping 38.834ms
    OVH, Beauharnois, Canada : 0 B/s | N/A | ping 17.778ms

    Just tested network speed, my issue hasn't gone since February. HostHatch support is being looking at it as I re-opened my ticket yesterday. bench.log 2KB in size is opening forever. But what do you guys think, what could be the cause for this?

  • Kiwi83Kiwi83 Member

    @ernie88 said:
    sudo bash bench.sh -speed

    sudo bash bench.sh -northamercia

    ## North America Speedtest
    Softlayer, Washington, USA : 0 B/s | N/A | ping 18.498ms
    SoftLayer, San Jose, USA : 0 B/s | N/A | ping 50.481ms
    SoftLayer, Dallas, USA : 0 B/s | N/A | ping error!
    Vultr, New Jersey, USA : 0 B/s | N/A | ping 20.782ms
    Vultr, Seattle, USA : 0 B/s | N/A | ping 42.369ms
    Vultr, Dallas, USA : 0 B/s | N/A | ping 26.129ms
    Vultr, Los Angeles, USA : 0 B/s | N/A | ping 56.871ms
    Ramnode, New York, USA : 0 B/s | N/A | ping 18.452ms
    Ramnode, Atlanta, USA : 0 B/s | N/A | ping 38.834ms
    OVH, Beauharnois, Canada : 0 B/s | N/A | ping 17.778ms

    Just tested network speed, my issue hasn't gone since February. HostHatch support is being looking at it as I re-opened my ticket yesterday. bench.log 2KB in size is opening forever. But what do you guys think, what could be the cause for t

    Since February? That would be very annoying. Last year they had a NVMe disk issue that lasted for weeks. It made my VPS basically unusable. My ticket wasn’t answered until they actually fixed the issue. I guess if reinstalling the OS can’t solve the problem there is nothing you can do except waiting for them to fix it. Btw are you on a promotion plan or a full priced one?

  • RedSoxRedSox Member

    Kiwi83 said: Btw are you on a promotion plan or a full priced one?

    Does it matter? Support is support as far as I know...

  • ernie88ernie88 Member

    Kiwi83 said: Since February? That would be very annoying. Last year they had a NVMe disk issue that lasted for weeks. It made my VPS basically unusable. My ticket wasn’t answered until they actually fixed the issue. I guess if reinstalling the OS can’t solve the problem there is nothing you can do except waiting for them to fix it. Btw are you on a promotion plan or a full priced one?

    Yes, it is annoying and appeared out of nowhere which is frustrating. It is a promotional NVMe 2 GB plan.

    RedSox said: Does it matter? Support is support as far as I know...

    It does matter as providers may limit support for promotional plans. I don't contact support usually but in rare cases like this only.

  • DroidDroid Member

    @ernie88 said:
    sudo bash bench.sh -speed

    sudo bash bench.sh -northamercia

    ## North America Speedtest
    Softlayer, Washington, USA : 0 B/s | N/A | ping 18.498ms
    SoftLayer, San Jose, USA : 0 B/s | N/A | ping 50.481ms
    SoftLayer, Dallas, USA : 0 B/s | N/A | ping error!
    Vultr, New Jersey, USA : 0 B/s | N/A | ping 20.782ms
    Vultr, Seattle, USA : 0 B/s | N/A | ping 42.369ms
    Vultr, Dallas, USA : 0 B/s | N/A | ping 26.129ms
    Vultr, Los Angeles, USA : 0 B/s | N/A | ping 56.871ms
    Ramnode, New York, USA : 0 B/s | N/A | ping 18.452ms
    Ramnode, Atlanta, USA : 0 B/s | N/A | ping 38.834ms
    OVH, Beauharnois, Canada : 0 B/s | N/A | ping 17.778ms

    Just tested network speed, my issue hasn't gone since February. HostHatch support is being looking at it as I re-opened my ticket yesterday. bench.log 2KB in size is opening forever. But what do you guys think, what could be the cause for this?

    Getting the same issue here.

    Hosted by Comcast (Chicago, IL) [3.01 km]: 2516.886 ms
    Testing download speed................................................................................
    Download: 2.37 Mbit/s
    Testing upload speed................................................................................................
    Upload: 3.28 Mbit/s

    Thanked by 1ernie88
  • ernie88ernie88 Member

    Droid said: Getting the same issue here.

    Their support asked me to run wget -qO- bench.sh | bash which shows that DL is OK and to look into server logs. Since it's a production server I've got no time to mess with finding the culprit and going to reinstall the OS. If that doesn't help I'll go find another host.

  • kalimov622kalimov622 Member

    Solid experience so far as well, only had a small downtime of about 10 minutes last week that affected one of the VPS but except that no issues. Speeds are fine with UK and NL vps as far as I can tell.

  • ernie88ernie88 Member

    ernie88 said: ...going to reinstall the OS. If that doesn't help I'll go find another host.

    OS reinstall made no difference with the issue. On the contrary, it has become more obvious. Any SSH commands that involved network took at least 5 seconds to start. So I moved the VPS to another host as it's a production server.

Sign In or Register to comment.