Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
Debugging plesk. sw-engine.service failed and sw-cp-server.service failed
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

Debugging plesk. sw-engine.service failed and sw-cp-server.service failed

Hello!
I need some help with debugging Plesk Obsidian. I just fresh installed plesk and the sw-engine and sw-cp-server won't start ..

Log:
sw-engine
`systemctl status sw-engine.service
● sw-engine.service - Startup script for Panel sw-engine
Loaded: loaded (/usr/lib/systemd/system/sw-engine.service; enabled; vendor preset: disabled)
Drop-In: /usr/lib/systemd/system/sw-engine.service.d
└─respawn.conf
Active: activating (auto-restart) (Result: exit-code) since Sat 2020-01-18 10:57:24 EET; 3s ago
Process: 7454 ExecStopPost=/usr/bin/find /run/lock/lmlib/ -mindepth 1 -delete (code=exited, status=0/SUCCESS)
Process: 7449 ExecStart=/usr/sbin/sw-engine-fpm --fpm-config /etc/sw-engine/sw-engine-fpm.conf -c /usr/local/psa/admin/conf/php.ini --nodaemonize --pid /run/sw-engine.pid (code=exited, status=255)
Main PID: 7449 (code=exited, status=255)

Jan 18 10:57:24 server3 systemd[1]: Failed to start Startup script for Panel sw-engine.
Jan 18 10:57:24 server3 systemd[1]: Unit sw-engine.service entered failed state.
Jan 18 10:57:24 server3 systemd[1]: sw-engine.service failed.`

sw-cp-server
`systemctl status sw-cp-server.service
● sw-cp-server.service - Startup script for Plesk control panel server
Loaded: loaded (/usr/lib/systemd/system/sw-cp-server.service; enabled; vendor preset: disabled)
Drop-In: /usr/lib/systemd/system/sw-cp-server.service.d
└─respawn.conf
Active: activating (auto-restart) (Result: exit-code) since Sat 2020-01-18 10:59:56 EET; 4s ago
Process: 7914 ExecStartPre=/usr/sbin/sw-cp-serverd -q -t (code=exited, status=255)

Jan 18 10:59:56 server3 systemd[1]: sw-cp-server.service: control process exited, code=exited status=255
Jan 18 10:59:56 server3 systemd[1]: Failed to start Startup script for Plesk control panel server.
Jan 18 10:59:56 server3 systemd[1]: Unit sw-cp-server.service entered failed state.
Jan 18 10:59:56 server3 systemd[1]: sw-cp-server.service failed.
`

Any thoughts ?
Any help will be apreciated ..

Web and VPS hosting - Top notch performance

Comments

  • Have you checked the logs in /var/log/plesk? They should tell you what's wrong with the installation.

  • hostfactorhostfactor Member
    edited January 18

    /var/log/plesk/sw-cp-server/sw-engine.log

    [18-Jan-2020 19:16:25] NOTICE: fpm is running, pid 9245
    [18-Jan-2020 19:16:25] NOTICE: ready to handle connections
    [18-Jan-2020 19:16:25] NOTICE: systemd monitor interval set to 10000ms
    [18-Jan-2020 19:20:02] NOTICE: Terminating ...
    [18-Jan-2020 19:20:02] NOTICE: exiting, bye-bye!

    Cant understand..
    I disabled selinux, but with no luck

    Web and VPS hosting - Top notch performance

  • @zuby2402 said:
    /var/log/plesk/sw-cp-server/sw-engine.log

    [18-Jan-2020 19:16:25] NOTICE: fpm is running, pid 9245
    [18-Jan-2020 19:16:25] NOTICE: ready to handle connections
    [18-Jan-2020 19:16:25] NOTICE: systemd monitor interval set to 10000ms
    [18-Jan-2020 19:20:02] NOTICE: Terminating ...
    [18-Jan-2020 19:20:02] NOTICE: exiting, bye-bye!

    Cant understand..
    I disabled selinux, but with no luck

    Check the following:
    https://support.plesk.com/hc/en-us/articles/213413189-Plesk-and-its-command-line-utilities-do-not-work-due-to-missing-Plesk-packages

  • xaocxaoc Member

    Read this and try installing it again if it's a fresh install. If all the install requirements above are met, you should not be getting any errors.

    So Say We All

  • Reinstalled and all good now.
    Restore tinme :) ..

    Web and VPS hosting - Top notch performance

Sign In or Register to comment.