Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
Changes on html files does not reflect
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

Changes on html files does not reflect

LikloveLiklove Member

Hi
Whenever i change html files via filezilla and they do not reflect
i tried incognito, cleared cloudflare caches etc. but nothing changed.

Comments

  • hi,

    maybe simply you loaded it in the wrong directory or used wrong filename? maybe with our without spaces eg "testfile.html" vs "testfile .html"?

    and browser cache (see google on how to clear it) is cleared?

    Best site for discovering & tracking Crypto dapps: www.DappStatCentral.ml

  • donlidonli Member

    Webservers can cache too.

  • Try to disable cloudflare and check the headers on your pages. Maybe its still being cached.

  • If you are using cloudflare, always use development mode when editing website files if you want to see changes in realtime.

  • @VPSoffshore said:
    If you are using cloudflare, always use development mode when editing website files if you want to see changes in realtime.

    tried dev. mode but still nothing changes, also cleared browser cache and tried different browsers but no success.
    the panel is webmin/virtualmin.
    and it has perl based script

  • vovlervovler Member
    edited June 2019

    Are you running the website behind a nginx reverse proxy? Clear its cache

    "They said it's RAID 5" - geekypixal

  • @vovler said:
    Are you running the website behind a nginx reverse proxy? Clear its cache

    no
    there should be something which prevents changes on html but couldnt figure it out

  • hyperexperthyperexpert Member, Provider

    Couple of things to try/troubleshoot:

    • Bypass CF by editing your local hosts file.
    • Make sure your web server is serving the correct directory
    • check your web server access logs
    • move/delete/rename the file completely and see if your server is still serving it or not.
    Thanked by 1Falzo

    Hyper Expert | Launch a high performance VPS in New York or Seattle in under 60 seconds | KVM plans starting at $2.99

  • agentmishraagentmishra Member, Provider

    try deleting the local cache files in your browser

    skype id : agentmishra, gtalk id : agentmishra, email : [email protected]

  • t0ny0t0ny0 Member

    ctrl+shift+r to force reload the page

  • @hyperexpert said:
    Couple of things to try/troubleshoot:

    • Bypass CF by editing your local hosts file.
    • Make sure your web server is serving the correct directory
    • check your web server access logs
    • move/delete/rename the file completely and see if your server is still serving it or not.

    tried local hosts file but still no change
    there are www and siterootname directories changed same files on them but still no effect
    apache access logs contains no info about this
    but i saw this on error log:

    AH01630: client denied by server configuration: /home/mysite/public_html/.html
    script not found or unable to stat: /home/mysite/cgi-bin/php5
    script not found or unable to stat: /home/mysite/cgi-bin/php

  • @agentmishra said:
    try deleting the local cache files in your browser

    this is not about browser
    its about webserver configuration i am sure of it

  • hyperexperthyperexpert Member, Provider

    Is this your own web server or a web host?

    Hyper Expert | Launch a high performance VPS in New York or Seattle in under 60 seconds | KVM plans starting at $2.99

  • LikloveLiklove Member
    edited June 2019

    @hyperexpert said:
    Is this your own web server or a web host?

    own webserver (dedicated) which i have root access via webmin and filezilla sftp.
    i also deleted file but it still shows that html.

  • hyperexperthyperexpert Member, Provider

    At this point we are going to need more details. Is this a framework or just static files? Does it happen to .html files only? What if you created simple .txt file, can you browse to it? How many sites are you managing with webmind? If more than one, does it happen to others as well? If you can provide temp access to the server, will you be able to PM the details?

    Hyper Expert | Launch a high performance VPS in New York or Seattle in under 60 seconds | KVM plans starting at $2.99

  • OP is using Filezilla's Edit file feature.

    It's unreliable. I've spent too much time cleaning up after PHP/HTML coders who tried to use it.

    Just use a real IDE with FTP support.

    250GB USA RAID6 StorageKVM from €13/yr (no-torrenting, TopProvider)
    (affiliate for 🥰 ) https://clients.inceptionhosting.com/aff.php?aff=401&gid=30

  • Liklove said: its about webserver configuration i am sure of it

    Open up your browser console, look at the requests done. If you're getting a 304 it's the server returning a cached version. Anyways, Use the "copy as curl" function chrome and FF has. Try that from the command line, remove any cache headers from the request.

    Thanked by 1vimalware
  • LikloveLiklove Member
    edited June 2019

    @hyperexpert said:
    At this point we are going to need more details. Is this a framework or just static files? Does it happen to .html files only? What if you created simple .txt file, can you browse to it? How many sites are you managing with webmind? If more than one, does it happen to others as well? If you can provide temp access to the server, will you be able to PM the details?

    yes html files , static files, created a test txt and it gave "file not found" error by perl script.
    2 websites in webmind
    i've also tried virtualmin's file manager but the result is same.
    i also realized that same perl script installation on different directories like:
    home/mysite/....
    root/mysite/....
    www/....

    etc..

  • @ricardo said:

    Liklove said: its about webserver configuration i am sure of it

    Open up your browser console, look at the requests done. If you're getting a 304 it's the server returning a cached version. Anyways, Use the "copy as curl" function chrome and FF has. Try that from the command line, remove any cache headers from the request.

    ok i am now realized that the problem and it was silly.
    the directories are just confused and same installation seen on different folders.
    should i delete www and root/mysite folders completely?

  • ITLabsITLabs Member

    Open the webserver's access log and note the path from which the file is being pulled. Is it the same where you're editing?

    #lexit | FatPal - Official LET payment gateway

  • vimalwarevimalware Member
    edited June 2019

    @Liklove said:
    2 websites in webmind
    i've also tried virtualmin's

    I've seen this issue before with a virtualmin server.

    You're using the ProFTPd FTP right, and not SFTP?
    IIRC there's a File overwrite setting in proftpd conf that needs to be toggled ON.
    edit: sauce I'm off to sleep.

    250GB USA RAID6 StorageKVM from €13/yr (no-torrenting, TopProvider)
    (affiliate for 🥰 ) https://clients.inceptionhosting.com/aff.php?aff=401&gid=30

  • SaharDevSaharDev Member
    edited July 2019

    Maybe cache, if you are using Google Chrome browser, try shift + F5 or just check on incognito mode.

  • Op already solved the problem. It's literally the first reply on this thread.

Sign In or Register to comment.