Open_basedir disbale in Debian based server? How to?
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

Open_basedir disbale in Debian based server? How to?

clatimeclatime Member
edited October 11 in Help

The thing is I am running a website on Debian 8 server with apache and php5.6.33, and I want to diable open_base dir value to none. https://i.stack.imgur.com/tbhud.png

I am talking about local value, as master value is already none.

Now I have done changes in php.ini files and restarted everything, but it simply doesn't work. I have tried all solution from using php.ini. Last night one recommended me to make changes in apache2. Conf, as there is no httpd.conf on Debian server.

Asked me to add this line "php_admin_value open_basedir none" in my apache2.conf file, as there is no such line exists in the file, so I added it here http://prntscr.com/l4iks8 , Restarted everything still no luck.

Please help

Comments

  • From the /etc/php5, sometimes we have cli and fpm. Try to change all php.ini on both directory and restart php again

  • FalzoFalzo Member

    please don't do things you don't understand.

    open_basedir is probably there and enabled for a reason. if you need something in php accessing some specific path, why not adding that first to open_basedir (after you made sure it can cause no harm) instead of removing that restriction at all - without knowing why or what they are for.

    UltraVPS.eu KVM in US/UK/NL/DE: 15% off first 6 month and cheap 750G / 2TB storage offers
    Netcup KVM: 2GB 40TB BW - 16,14€ 6m or 2 dedCore 6GB 320GB - 78,88€ 12m /w 5€ off: 36nc15279180197 | 36nc15292244387

  • @Falzo said:
    please don't do things you don't understand.

    open_basedir is probably there and enabled for a reason. if you need something in php accessing some specific path, why not adding that first to open_basedir (after you made sure it can cause no harm) instead of removing that restriction at all - without knowing why or what they are for.

    you are right i think i fucked up my server, now i am trying to install wordpress but wp-activate page not redirecting properly

  • FalzoFalzo Member

    @clatime said:

    @Falzo said:
    please don't do things you don't understand.

    open_basedir is probably there and enabled for a reason. if you need something in php accessing some specific path, why not adding that first to open_basedir (after you made sure it can cause no harm) instead of removing that restriction at all - without knowing why or what they are for.

    you are right i think i fucked up my server, now i am trying to install wordpress but wp-activate page not redirecting properly

    which should not be an open_basedir issue at all, as usually wordpress won't need access to anything outside it's location. maybe you better want to check owner/permissions for the files. and no 777 is not a valid one.

    UltraVPS.eu KVM in US/UK/NL/DE: 15% off first 6 month and cheap 750G / 2TB storage offers
    Netcup KVM: 2GB 40TB BW - 16,14€ 6m or 2 dedCore 6GB 320GB - 78,88€ 12m /w 5€ off: 36nc15279180197 | 36nc15292244387

Sign In or Register to comment.