Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
[HELP] HOSTSOLUTIONS: Failed to allocate directory watch: Too many open files
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

[HELP] HOSTSOLUTIONS: Failed to allocate directory watch: Too many open files

It happened on hostsolution's new VPS (the 1T storage one). The terminal always shows Too many open files when I want to set up something. I have tried to update some configs with google, but nothing worked. I also opened a ticket, no response.
How can I solve this BIG problem or is it something wrong with host server?

Comments

  • This is not hostsolutions help desk. Contact your provider

    Wordpress Hosting - Home made!

  • your SOLUTION is to contact hostsolutions.

    I like what she said, not what it means.

  • Contact @cociu here. BUT you must wait for ticket reponse...

    hostfactor.eu $0.40/month DirectAdmin | $9/month Unmettered OpenStack KVM VPS

  • MKHostingMKHosting Member, Provider

    Hi,

    what exactly do you trying to execute?
    Which OS? Please give us some more informations :)

    Backups | Instant online | 99,9% uptime | DDoS-Protection | Gbit Uplink| Linux & Windows
    LXC and KVM Server from 1,90€ | Domains | No fees | Germany (Frankfurt)

  • @MKHosting said:
    Hi,

    what exactly do you trying to execute?
    Which OS? Please give us some more informations :)

    I have tried to update the /etc/security/limits.conf and /etc/sysctl.conf for nofile and fs.file-max;
    Debian 8/16.04 amd 64/CentOS7, every OS has the same problem.

  • MKHostingMKHosting Member, Provider

    Which hypervisor do you use?

    See this page here: https://www.tecmint.com/increase-set-open-file-limits-in-linux/

    It helped me to increase the number of open files easily and on the fly.

    Backups | Instant online | 99,9% uptime | DDoS-Protection | Gbit Uplink| Linux & Windows
    LXC and KVM Server from 1,90€ | Domains | No fees | Germany (Frankfurt)

  • WebProjectWebProject Member, Provider
    edited September 2018

    @PACI said:

    @MKHosting said:
    Hi,

    Debian 8/16.04 amd 64/CentOS7

    I thought it was some restrictions with latest OS on hostsolutions nodes.

    VPS Price Match Guarantee on: All our range of DDOS protected XEN-HVM VPS Plans
    Are you looking for best price for self-managed VPS? See WebProVPS website for more details.
  • @MKHosting said:
    Which hypervisor do you use?

    See this page here: https://www.tecmint.com/increase-set-open-file-limits-in-linux/

    It helped me to increase the number of open files easily and on the fly.

    I found that the sysctl fs.inotify may be the limit:

    fs.inotify.max_queued_events = 16384
    fs.inotify.max_user_instances = 128
    fs.inotify.max_user_watches = 8192
    

    When I try to update it, it shows sysctl: setting key "fs.inotify.max_user_instances": Read-only file system

  • those are LXC containers, your provider needs to change the settings if needed. contact their support.

    most recommended Provider: First-Root KVM Power-Edition /w SSD
    UltraVPS.eu KVM in US/UK/NL/DE: 15% off first 6 month | Netcup VPS/rootDS - 5€ off: 36nc15279180197 (ref)

  • jsgjsg Member
    edited September 2018

    I understand that to be meant as a - reasonable - sharing mechanism and protection from the provider.

    You should think about why that's not enough for you.

    Thanks no.

  • PACIPACI Member
    edited September 2018

    @jsg said:
    I understand that to be meant as a - reasonable - sharing mechanism and protection from the provider.

    You should think about why that's not enough for you.

    What do you think I can do when I just reinstall OS and try to install nextcloud on it?
    Did I use this VPS to destroy the world? Or have I simulated galaxy on it? :)

  • PACIPACI Member
    edited September 2018

    @WebProject said:

    @PACI said:

    @MKHosting said:
    Hi,

    Debian 8/16.04 amd 64/CentOS7

    I thought it was some restrictions with latest OS on hostsolutions nodes.

    Yeah! I have tried to reinstall centos 6 and it works now!

  • @paci What are you trying to do that needs so many open files?

  • @lowendusername said:
    @paci What are you trying to do that needs so many open files?

    Some form of fileshare.

    Own a piece of internets history.

  • @lowendusername said:
    @paci What are you trying to do that needs so many open files?

    I tried to install snap, the snapd.service cannot start by itself and showed too many open files. It did not work when I used systemctl start snapd to start it (the same reason). I thought there were something wrong with host server(might fs.inotify config).

  • cociucociu Member, Provider
    edited September 2018

    this problem will be resolved today , also when you open a tiket please do not open multiple tikets with the same problem , do not push in the tiket , all this will delay the response , i dont tell is your case but is good to know.

    This problem will be resolved today or tumorrow because we need to test the settings first.

  • @cociu said:
    this problem will be resolved today , also when you open a tiket please do not open multiple tikets with the same problem , do not push in the tiket , all this will delay the response , i dont tell is your case but is good to know.

    This problem will be resolved today or tumorrow because we need to test the settings first.

    thanks for the info, please reply to this thread when the problem got sorted out.
    I have same problem too. :wink:

  • cociucociu Member, Provider
    edited September 2018

    userandom said: thanks for the info, please reply to this thread when the problem got sorted out.

    first please open a ticket because we need to receive all this problems in our whmcs not in a forum. Also we have change the limit so if someone is still have this problems please open tickets.

  • @cociu said:

    userandom said: thanks for the info, please reply to this thread when the problem got sorted out.

    first please open a ticket because we need to receive all this problems in our whmcs not in a forum. Also we have change the limit so if someone is still have this problems please open tickets.

    Okay :)

Sign In or Register to comment.