Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
postfix smtp relay error -authentication Required
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

postfix smtp relay error -authentication Required

I have Sendinblue as a smtp mail relay server and I get this error when I send a mail out----

Sep 2 16:23:38 centos postfix/smtp[4398]: 9268C40940BA: to=xxxx@gmail.com, relay=smtp-relay.sendinblue.com[52.8.246.102]:587, delay=0.79, delays=0.1/0.02/0.59/0.08, dsn=5.0.0, status=bounced (host smtp-relay.sendinblue.com[52.8.246.102] said: 530 Error: authentication Required (in reply to MAIL FROM command))

What could be the problem?

And this is what I have in postfix main.cf::
.
.
mynetworks = 127.0.0.0/8
.
.
smtp_sasl_password_maps = static:myblahusername:myblahpassword
smtp_sasl_security_options = noanonymous
smtp_tls_security_level = may
header_size_limit = 4096000
relayhost = smtp-relay.sendinblue.com:587

Comments

  • RazzaRazza Member
    edited September 2018

    You need to add smtp_sasl_auth_enable = yes to make Postfix use sasl auth.

    Thanked by 1yongsiklee
  • @Razza said:
    You need to add smtp_sasl_auth_enable = yes to make Postfix use sasl auth.

    Actually it was enabled. I forgot to put it. Sorry for confusion.

  • yongsikleeyongsiklee Member
    edited September 2018

    @Razza said:
    You need to add smtp_sasl_auth_enable = yes to make Postfix use sasl auth.

    Actually it indeed worked!

    I originally had "smtpd_sasl_auth_enable = yes"

    And then after closely examining your suggestion, the only thing that differenciates this line from yours is a "d" that was missing from yours. So I experimented to remove a "d" from smtpd, and it started working.

    I learned that smtpd handles incoming mail. It's my mistake to see both the same at a glance.

    *Meanwhile I did "yum install cyrus-sasl cyrus-sasl-lib cyrus-sasl-plain." And I am not sure if that also did the trick.

  • @yongsiklee said: *Meanwhile I did "yum install cyrus-sasl cyrus-sasl-lib cyrus-sasl-plain." And I am not sure if that also did the trick.

    Postfix uses either Cyrus SASL or Dovecot SASL. In your case, it may be using Cyrus, though hard to tell from the info that you've shared.

    "Linux will run happily with only 4 MB of RAM, including all of the bells and whistles such as the X Window System, Emacs, and so on." (M. Welsh & L. Kaufman, Running Linux, 2e, 1996, p. 32)

Sign In or Register to comment.