Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
OVH - IP Failover Not Working At All
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

OVH - IP Failover Not Working At All

nvidiannvidian Member
edited May 2018 in Reviews

After read this post https://www.lowendtalk.com/discussion/145079/dedicated-server-xeon-e3-1245v5-32gb-ram-in-singapore-or-australia-59-99-recurring-offer-ovh - I decided to give OVH a try on May 25.

I also ordered 4 more additional IPs (IP Failover) and I plan to install Proxmox on it.

I installed proxmox with OVH template without problem (hardware and main IP works as expected).

I created virtual MAC on OVH panel, assign it to the VM network on Proxmox.
Setup correct gateway - which is similar to my main server IP but with 254 at the end (x.x.x.254). But still the IPs failover cannot reach the internet. I can ping my main IP from the VM, I even can ping to the gateway IP from VM, but I cannot ping to 8.8.8.8, google.com or any IPs outside.

This is not my first Proxmox server and I also followed the guide from OVH website and from Proxmox website about OVH network setting.

I contacted the support by creating a ticket 2655560307 on May 28 and got no answer after 2 days. I called their support and got useless response, and they reply it once with some instruction to do on Rescue Mode, I follow their instructions at email them back.

After 2 more days (4 days total) they haven't reply so I call them again on May 30. The support person only said that he will escalated it to higher support.

Because I need to get the server works, I tried to order 1 more IP failover and hope it will work this time. But again, like the /30 IP before , it failed to work.

And Today I got reply

We apologize for the delayed response. We've been informed that the routing issue should now be resolved. Now that the server is placed back on the disks, I've taken a look at the IPs but they are currently not responding. Are they still configured on your VMs?

But after turn the VM back on and test to ping, both VM (i have created 2 VM) still cannot reach the internet. Its still has the same problem as couple of DAYS ago.

Do you guys ever experienced the same IP failover problem with OVH ?
Am I allow for refund request - at least for $15 (5x failover IPs) ?

Comments

  • nvidiannvidian Member

    Is this valid for my dedicated server on OVH Singapore ? https://ovhcloud.com/legal/refund-policy

  • fkjfkj Member

    The same happened to me, yes, same machine, same offer, same Proxmox.

    I contacted the support and they fixed the routing on one IP block but left my other /29 unfixed. I asked if that means I had to contact them to run the fix again when I buy a new failover IP and the reply made me believe the support staff didn't understand the issue but merely send the ticket to network department.

    @OVH_APAC, hope you can contact network about the configuration issue with Proxmox in your SG dc.

  • ClouviderClouvider Member, Provider
    edited May 2018

    Just pick a provider with normal network setup that can help you when you get stuck.

    Clouvider Limited - Leading Hosting & Connectivity Partner || Dedicated Server Sale from £45/m - Our Latest LET Offer

    Cloud Web Hosting | SSD & SAS HA OnApp VPS | US, UK, NL & DE Dedicated Servers | Network Services | Colocation | Managed Services

  • fkjfkj Member

    @Clouvider, it's not that OP doesn't know how to assign OVH IP, it's actually a network issue with OVH SG (I guess), and clearly, OP didn't explain the issue well to the support. Besides, it's hard to find providers that only charge IP for one-time.

  • WebProjectWebProject Member, Provider

    Have you setup correct MAC address in your VM? As I have worked on Proxmox project in past and no issue with OVH network setup.

    VPS Price Match Guarantee on: All our range of DDOS protected XEN-HVM VPS Plans
    Are you looking for best price for self-managed VPS? See WebProVPS website for more details.
  • CdoeCdoe Member

    I have SG server from this offer also and additional ips work with proxmox without any problems.

  • ClouviderClouvider Member, Provider

    @fkj said:
    @Clouvider, it's not that OP doesn't know how to assign OVH IP, it's actually a network issue with OVH SG (I guess), and clearly, OP didn't explain the issue well to the support. Besides, it's hard to find providers that only charge IP for one-time.

    I’m not surprised burn I’ll stop at this.

    You should never rely on the price for this to stay the same. Having your business model tied to this cheap IP prices will definitely result in your business crashing not too soon in the future. As the history shows OVH have changed their mind on one off charges more than once in the past, and the current system is unsustainable long term given IP space is limited and sourcing costs are rising significibantly day by day.

    Clouvider Limited - Leading Hosting & Connectivity Partner || Dedicated Server Sale from £45/m - Our Latest LET Offer

    Cloud Web Hosting | SSD & SAS HA OnApp VPS | US, UK, NL & DE Dedicated Servers | Network Services | Colocation | Managed Services

  • nvidiannvidian Member

    nvidian said: same IP failover problem with OVH ? A

    @WebProject said:
    Have you setup correct MAC address in your VM? As I have worked on Proxmox project in past and no issue with OVH network setup.

    Yes, please read my first post "I created virtual MAC on OVH panel, assign it to the VM network on Proxmox. Setup correct gateway - which is similar to my main server IP but with 254 at the end (x.x.x.254)..... "

  • fkjfkj Member

    @Cdoe can you post your server and failover block IP range? Mine is in 139.99.8.*, and the two trouble failover block are all in 139.99.50.*

  • nvidiannvidian Member
    edited May 2018

    After some 'simple' thought, I think OVH is not for me. I could imagine if one of my hardware fail in the future, with this kind of support , its not worth it even with that very low price ( seriously, where else could you find E3 v5, RAM 32Gb, 2x 480 Intel SSD on Singapore location ???)

    Now I want to hear from you guys, does OVH ever refund dedicated server order ?

    @nvidian said:
    Is this valid for my dedicated server on OVH Singapore ? https://ovhcloud.com/legal/refund-policy

  • CdoeCdoe Member
    edited May 2018

    @nvidian said:

    After some 'simple' thought, I think OVH is not for me. I could imagine if one of my hardware fail in the future, with this kind of support , its not worth it even with that very low price ( seriously, where else could you find E3 v6, RAM 32Gb, 2x 480 Intel SSD in Singapore location ???)

    Don't worry about it, the hardware failures are handled pretty quickly as promised in the SLA.

  • experttechitexperttechit Member, Provider

    Ovh will transfer unused time to another server.

  • MikeAMikeA Member, Provider

    I don't know what your issue could be, but make sure to assign different vMac in the OVH manager for each FO IP. Assign one for each VM interface. I'm not that familiar with Proxmox now.

    ExtraVM - AMD Ryzen VPS starting @ $3.50
    USA (TX, VA, FL), CA, FR, UK, SGP, AU

  • BoltersdriveerBoltersdriveer Member, LIR

    I have had this issue with servers in the SGP data center for the past year occasionally now. Most recently, when trying to move the IPs from the old DISCOVER servers to the new DO servers, the failover IPs would not work until waiting a few days for their technical team to fix it. Additionally, I also encountered some problems even with the host IPs not being able to reach each other - again, due to routing issues that required them to fix on their end. This would normally not be a problem, but waiting 3 days+ for something like this to be fixed just leaves a bad taste in the mouth.

  • @MikeA said:
    I don't know what your issue could be, but make sure to assign different vMac in the OVH manager for each FO IP. Assign one for each VM interface. I'm not that familiar with Proxmox now.

    Every single IP has different vmac.

  • @Boltersdriveer said:
    I have had this issue with servers in the SGP data center for the past year occasionally now. Most recently, when trying to move the IPs from the old DISCOVER servers to the new DO servers, the failover IPs would not work until waiting a few days for their technical team to fix it. Additionally, I also encountered some problems even with the host IPs not being able to reach each other - again, due to routing issues that required them to fix on their end. This would normally not be a problem, but waiting 3 days+ for something like this to be fixed just leaves a bad taste in the mouth.

    Sometimes I think maybe they just dont care about their cheapest , already no profit product :)

    Or maybe im just unlucky

  • htunhtun Member

    I have the same issue and it's been resolved by OVH support. Obviously it is a routing issue. Kindly provide them below information to expedite the troubleshooting process. Of course, you still need to wait at least 1 to 2 days to get their response. :)

    • MTR from and to the IP address
    • cat /etc/network/interfaces or cat /etc/sysconfig/network (CentOS)
    • ifconfig -a (linux) or ipconfig /all (windows)
    • netstat -rn or route -n

    As far as I understand, you need to use subnet mask as 255.255.255.255 and default gateway as your main server gateway IP address.

    Hope this help.

  • nvidiannvidian Member
    edited June 2018

    @htun said:
    I have the same issue and it's been resolved by OVH support. Obviously it is a routing issue. Kindly provide them below information to expedite the troubleshooting process. Of course, you still need to wait at least 1 to 2 days to get their response. :)

    • MTR from and to the IP address
    • cat /etc/network/interfaces or cat /etc/sysconfig/network (CentOS)
    • ifconfig -a (linux) or ipconfig /all (windows)
    • netstat -rn or route -n

    As far as I understand, you need to use subnet mask as 255.255.255.255 and default gateway as your main server gateway IP address.

    Hope this help.

    Provided them my host ifconfig and netstat -rn on my last ticket reply. Still waiting for their response.

    And yes, I used netmask 255.255.255.255 on my VM and the same gateway as my main server gateway.

    Lets say the issue has been resolved for now, anyone has experience that the same routing issue happen again after they it ?

    I may want to keep the server if the routing issue wont (rarely) happen again and their support fast and good enough on hardware issue.

    Cdoe said: Don't worry about it, the hardware failures are handled pretty quickly as promised in the SLA.

    Does their support act differently on hardware issue (faster replacement etc) than routing issue ? isnt it the same support team ???

  • Hardware issues have pretty fast intervention, for network issues like these it takes quite a while unless you drop their support team a call to escalate the ticket quicker.

  • @fkj said:
    @Cdoe can you post your server and failover block IP range? Mine is in 139.99.8.*, and the two trouble failover block are all in 139.99.50.*

    arghhh.. i have failover ip of these two failover block. any advice ?

    "The quieter you become, the more you are able to listen" dgprasetya.com

  • @fkj said:
    @Cdoe can you post your server and failover block IP range? Mine is in 139.99.8.*, and the two trouble failover block are all in 139.99.50.*

    Hello my main IP is also 139.99.8.* and the problem failover block are also 139.99.50.*

    Later on, I order only 1 IP 139.99.51.* and it also has problem.

    It seems I;m not alone here with IP failover problem at OVH SGP.

  • nvidiannvidian Member
    edited June 2018

    @dgprasetya said:

    @fkj said:
    @Cdoe can you post your server and failover block IP range? Mine is in 139.99.8.*, and the two trouble failover block are all in 139.99.50.*

    arghhh.. i have failover ip of these two failover block. any advice ?

    I submit a refund request ticket, the latest reply was:

    The 30 day money back guarantee is if you are with OVH US. I will send a request to see if we can provide a refund and will also inform our specialists of the issue.

    Thanked by 1dgprasetya
  • This might not be a network problem but rather the way you configured your VM's. Have you double checked your VM config for CPU units and CPU%?
    Try assigning CPU units 1000+ and leave % on 0 and see if that helps.

  • FHRFHR Member, Provider

    @HostDoc said:
    This might not be a network problem but rather the way you configured your VM's. Have you double checked your VM config for CPU units and CPU%?
    Try assigning CPU units 1000+ and leave % on 0 and see if that helps.

    I assume this comment is a troll.

    Thanked by 1Clouvider

    SkylonHost - affordable hourly-billed KVM VPS in Prague, CZ!
    Featuring own high performance network AS202297 | RIPE NCC member | Contact us for IPs/ASNs

  • fkjfkj Member

    @HostDoc said:
    This might not be a network problem but rather the way you configured your VM's. Have you double checked your VM config for CPU units and CPU%?
    Try assigning CPU units 1000+ and leave % on 0 and see if that helps.

    There's like more than four people having the same problem, all having server in OVH SG. So doesn't look like a client's configuration issue to me.

    @dgprasetya @nvidian Basically you just submit all of those configs then let the genius support manually fix each failover blocks for you.

    Thanked by 1dgprasetya
  • @FHR said:

    @HostDoc said:
    This might not be a network problem but rather the way you configured your VM's. Have you double checked your VM config for CPU units and CPU%?
    Try assigning CPU units 1000+ and leave % on 0 and see if that helps.

    I assume this comment is a troll.

    And what made you reach that assumption?

  • ClouviderClouvider Member, Provider
    edited June 2018

    @HostDoc said:

    @FHR said:

    @HostDoc said:
    This might not be a network problem but rather the way you configured your VM's. Have you double checked your VM config for CPU units and CPU%?
    Try assigning CPU units 1000+ and leave % on 0 and see if that helps.

    I assume this comment is a troll.

    And what made you reach that assumption?

    I guess from the fact that someone suggest that CPU allocation for a VM will fix the routing issue.

    Thanked by 1FHR

    Clouvider Limited - Leading Hosting & Connectivity Partner || Dedicated Server Sale from £45/m - Our Latest LET Offer

    Cloud Web Hosting | SSD & SAS HA OnApp VPS | US, UK, NL & DE Dedicated Servers | Network Services | Colocation | Managed Services

  • Not at all. Someone else with the same issue changed those settings and their IP worked. Just offering some alternative idea. Not trolling at all.

  • @HostDoc said:
    Not at all. Someone else with the same issue changed those settings and their IP worked. Just offering some alternative idea. Not trolling at all.

    Explain the logic behind those

  • FHRFHR Member, Provider

    @HostDoc said:

    @FHR said:

    @HostDoc said:
    This might not be a network problem but rather the way you configured your VM's. Have you double checked your VM config for CPU units and CPU%?
    Try assigning CPU units 1000+ and leave % on 0 and see if that helps.

    I assume this comment is a troll.

    And what made you reach that assumption?

    CPU units = priority. Higher units basically means higher priority (there is some math behind it) between instances when the system is at high load.
    CPU % = absolute limit. 0% limit means you will limit the VPS to no CPU at all.

    I see a link to a host in your signature. As a host actually selling KVM VPS you should know these things.

    Thanked by 1Zerpy

    SkylonHost - affordable hourly-billed KVM VPS in Prague, CZ!
    Featuring own high performance network AS202297 | RIPE NCC member | Contact us for IPs/ASNs

  • @FHR said:

    @HostDoc said:

    @FHR said:

    @HostDoc said:
    This might not be a network problem but rather the way you configured your VM's. Have you double checked your VM config for CPU units and CPU%?
    Try assigning CPU units 1000+ and leave % on 0 and see if that helps.

    I assume this comment is a troll.

    And what made you reach that assumption?

    CPU units = priority. Higher units basically means higher priority (there is some math behind it) between instances when the system is at high load.
    CPU % = absolute limit. 0% limit means you will limit the VPS to no CPU at all.

    I see a link to a host in your signature. As a host actually selling KVM VPS you should know these things.

    I know exactly what those settings do and was also surprised to hear such a solution but was told it solved that particular situation on a OVH server so figured Id bring it up. There wasn't much more to input into this conversation and I remembered that particular solution reading through the thread. It was just a suggestion, not a set in stone solution.

  • @robohost said:

    @HostDoc said:
    Not at all. Someone else with the same issue changed those settings and their IP worked. Just offering some alternative idea. Not trolling at all.

    Explain the logic behind those

    Quite obviously, no logic was behind it. Just a solution I heard that rectified the connection issue on a OVH server. Apologies for leaving my brain at home this morning.

  • FredQcFredQc Member

    HostDoc said: Have you double checked your VM config for CPU units and CPU%? Try assigning CPU units 1000+ and leave % on 0 and see if that helps.

    You can also try to increase the swap space a little bit, it will give you free ips at ovh. Sometimes up to 128. To see the new ips just run this command: ip addr.

    Debian, thx

    Thanked by 1FHR
  • AkitoAkito Member

    Have you configured every single IP and their respective routing as well in your /etc/network/interfaces (assuming Debian/Ubuntu as main server OS) config?

  • @Akito said:
    Have you configured every single IP and their respective routing as well in your /etc/network/interfaces (assuming Debian/Ubuntu as main server OS) config?

    i'm sure configured correctly. I run two SYS server with proxmox and one Kimsufi server with proxmox also. never has problem like this before..

    "The quieter you become, the more you are able to listen" dgprasetya.com

  • nvidiannvidian Member
    edited June 2018

    Today the support replied that the problem has been resolved, and I can confirm all /30 IPs works now. BUT the issue still persist on 1 IP I order (different block).

    Thanks for the Genius Support at OVH that only spent 9 days to fix this issue. And 12 days in total since I order the server.

  • @nvidian said:
    Today the support replied that the problem has been resolved, and I can confirm all /30 IPs works now. BUT the issue still persist on 1 IP I order (different block).

    Thanks for the Genius Support at OVH that only spent 9 days to fix this issue. And 12 days in total since I order the server.

    which block IP range with /30 IPS ?

    "The quieter you become, the more you are able to listen" dgprasetya.com

  • nvidiannvidian Member
    edited June 2018

    @dgprasetya said:

    @nvidian said:
    Today the support replied that the problem has been resolved, and I can confirm all /30 IPs works now. BUT the issue still persist on 1 IP I order (different block).

    Thanks for the Genius Support at OVH that only spent 9 days to fix this issue. And 12 days in total since I order the server.

    which block IP range with /30 IPS ?

    139.99.50.*

    Thanked by 1dgprasetya
  • @nvidian said:

    @dgprasetya said:

    @nvidian said:
    Today the support replied that the problem has been resolved, and I can confirm all /30 IPs works now. BUT the issue still persist on 1 IP I order (different block).

    Thanks for the Genius Support at OVH that only spent 9 days to fix this issue. And 12 days in total since I order the server.

    which block IP range with /30 IPS ?

    139.99.50.*

    some range ips with single order 139.99.51.* doesn't work, but works with block order /30.
    also block order /30 at 139.99.6.* doesn't work.

    i'm still direct complaint with one of ovh people via email.

    "The quieter you become, the more you are able to listen" dgprasetya.com

  • @dgprasetya said:

    @nvidian said:

    @dgprasetya said:

    @nvidian said:
    Today the support replied that the problem has been resolved, and I can confirm all /30 IPs works now. BUT the issue still persist on 1 IP I order (different block).

    Thanks for the Genius Support at OVH that only spent 9 days to fix this issue. And 12 days in total since I order the server.

    which block IP range with /30 IPS ?

    139.99.50.*

    some range ips with single order 139.99.51.* doesn't work, but works with block order /30.
    also block order /30 at 139.99.6.* doesn't work.

    i'm still direct complaint with one of ovh people via email.

    ok solved. the Genius support save my life ! fast responses !

    "The quieter you become, the more you are able to listen" dgprasetya.com

Sign In or Register to comment.