Can someone help we to find what is wrong on this site? (webdesing or server issue)
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

Can someone help we to find what is wrong on this site? (webdesing or server issue)

One customer we host on our Cpanel server has some issue with their webpage. The webdesigner blame us, but I'm thinking it is a issue with the design.

If you take a look at http://overoslo.no or https://overoslo.no the page is working fine.
The issues is with the band pictures and when you click on any of the pictures on the front page. But everthing is working fine using the two links over.
But if you try http://www.overoslo.no the pictures is there, but when you click on any of the band pictures, nothing happens.
If you access https://www.overoslo.no the pictures is not appearing at all.

Where is the issue? It's seems like it is a java issue, but I'n not sure. As told, we have nothing with the webdesign, just the hosting.

Kenneth Myhre
WindowsTemplate.com - free Windows templates for OVH/Hetzner/Kimsufi/Online.net

Powered by Hetzner.com, backed up by OVH, Kimsufi and VULTR.com

Comments

  • definitelyliamdefinitelyliam Member, Provider
    edited January 11

    You have issues with mixed content:

    Mixed Content: The page at 'https://www.overoslo.no/' was loaded over HTTPS, but requested an insecure image 'http://overoslo.no/wp-content/uploads/2017/11/Gåte-01.jpg'. This request has been blocked; the content must be served over HTTPS.

    When the site is loading on https, make sure assets are loaded in https in the HTML too.

    Thanked by 1myhken
  • rumi4rumi4 Member

    Maybe it is problem with ROOT ... I mean redirecting http and https. Or, some issue with .htaccess file

    Thanked by 1myhken
  • So you can't see any issues on the page it self?

    Kenneth Myhre
    WindowsTemplate.com - free Windows templates for OVH/Hetzner/Kimsufi/Online.net

    Powered by Hetzner.com, backed up by OVH, Kimsufi and VULTR.com

  • Thanked by 1myhken
    * Centmin Mod Project (HTTP/2 support + ngx_pagespeed + Nginx Lua + Vhost Stats)
    * Centmin Mod LEMP Stack Quick Install Guide
  • definitelyliam said: When the site is loading on https, make sure assets are loaded in https in the HTML too.

    Sorry, did not see the quoted text. OK, so that is the https issue. What about the www ad not www issue? Why do the site work without www, but using www, and you can't click on the images.

    Kenneth Myhre
    WindowsTemplate.com - free Windows templates for OVH/Hetzner/Kimsufi/Online.net

    Powered by Hetzner.com, backed up by OVH, Kimsufi and VULTR.com

  • wa44io4wa44io4 Member
    edited January 11

    Mixed Content issue , the images are being loaded using non https when visiting https://www.overoslo.no/
    there's some more issue possibly due to CORS
    enable CORS here - https://enable-cors.org/

    Thanked by 1myhken
  • jetchiragjetchirag Member
    edited January 11

    "Mixed Content: The page at 'https://overoslo.no/' was loaded over HTTPS, but requested an insecure image 'http://overoslo.no/wp-content/uploads/2017/11/Dumdum-800x550.jpg'. This content should also be served over HTTPS."

    Because you are seem to be using WordPress:

    • Make sure you have https in URL and not http (in settings)
    • Some links might be hardcoded in the post. You can run database search and replace for that
    • If none of it helps, have a look at files if http is hardcoded in theme (have saw few cases)

    Edit: For www issue:

    "Access to Font at 'https://overoslo.no/wp-content/themes/evently/assets/css/font-awesome/fonts/fontawesome-webfont.woff?v=4.7.0' from origin 'https://www.overoslo.no' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'https://www.overoslo.no' is therefore not allowed access."

    Your www version is loading assests from non www version (probably due to non-www url in WordPress settings). You just need to change URL in the settings and possible hardcoded in posts or disable CORS

    Thanked by 1myhken
  • jetchirag said: Because you are seem to be using WordPress:

    Make sure you have https in URL and not http (in settings)
    Some links might be hardcoded in the post. You can run database search and replace for that
    If none of it helps, have a look at files if http is hardcoded in theme (have saw few cases)
    

    What I need to find out if it's our fault as a host or the webdesigner's fault. And the mixed content for https is then the webdsigner.

    But what with the www issue when you are NOT using https, only normal http?

    Kenneth Myhre
    WindowsTemplate.com - free Windows templates for OVH/Hetzner/Kimsufi/Online.net

    Powered by Hetzner.com, backed up by OVH, Kimsufi and VULTR.com

  • jetchiragjetchirag Member
    edited January 11

    myhken said: What I need to find out if it's our fault as a host or the webdesigner's fault. And the mixed content for https is then the webdsigner.

    But what with the www issue when you are NOT using https, only normal http?

    It's not your fault as hosting provider

    /

    Thanked by 1myhken
  • WebProjectWebProject Member, Provider
    edited January 11

    if the content stored on local server use path ( /path/to/image.jpg ) instead of hyperlink
    links or alternatively use hyperlink like: //mydomain.com/path/to/image.jpg - this way browser will adjust whatever protocol you do use.

    Thanked by 2vovler myhken
    VPS Price Match Guarantee on: All our range of DDOS protected XEN-HVM VPS Plans
    Are you looking for best price for self-managed VPS? See WebProVPS website for more details.
  • @WebProject said:
    if the content stored on local server use path ( /path/to/image.jpg ) instead of hyperlink
    links or alternatively use hyperlink like: //mydomain.com/path/to/image.jpg - this way browser will adjust whatever protocol you do use.

    Thank you for this, hope it was OK that I just copied the text to the customer and told them to contact their webdesigner to fix this issue. :D

    And as always, thank you to all that took their time to help me. Go *LET!!!

    Kenneth Myhre
    WindowsTemplate.com - free Windows templates for OVH/Hetzner/Kimsufi/Online.net

    Powered by Hetzner.com, backed up by OVH, Kimsufi and VULTR.com

  • The site is on WordPress..Ask the developer to install this plugin and be done... it is really a click and be done solution for this problem

    https://wordpress.org/plugins/really-simple-ssl/

    Thanked by 2ramesh_vish myhken
  • @WebProject said:
    if the content stored on local server use path ( /path/to/image.jpg ) instead of hyperlink
    links or alternatively use hyperlink like: //mydomain.com/path/to/image.jpg - this way browser will adjust whatever protocol you do use.

    Unfortunately, Wordpress loves to reference all URLs with its fully qualified URL (often making it a pain if you move content around, dev -> prod). @ez2uk's solution is good, I have used it to enable https after I installed SSL certs on existing websites.

    If you don't want a plugin that runs for every query and want to "Search & Replace", you can use this -> https://interconnectit.com/products/search-and-replace-for-wordpress-databases/ Run it once searching for http://www.overoslo.no and replacing it with https://www.overoslo.no

    PS: I think @OP should also advise his client to setup a CNAME redirection for www to non-www (or vice versa). It plays better with Wordpress settings (Site URL).

    Thanked by 2kkrajk myhken

    Are you looking for some textual fun?

  • FalzoFalzo Member

    jetchirag said: "Access to Font at 'https://overoslo.no/wp-content/themes/evently/assets/css/font-awesome/fonts/fontawesome-webfont.woff?v=4.7.0' from origin 'https://www.overoslo.no' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'https://www.overoslo.no' is therefore not allowed access."

    maybe not very likely but afaik the CORS problem could be an issue with a strict setting on the webserver/providers end, as it can be that some headers are set in the webserver-config (nginx reverse proxy eventually?).
    I have no experience about cpanel related stuff though, so can't tell if there is any option or setting regarding this...

    Thanked by 1myhken

    UltraVPS.eu KVM in US/UK/NL/DE: 15% off first 6 month and cheap 750G / 2TB storage offers
    Netcup KVM: 2GB 40TB BW - 16,14€ 6m or 2 dedCore 6GB 320GB - 78,88€ 12m /w 5€ off: 36nc15279180197 | 36nc15292244387

  • I wouldn't tell the web designer to install anything at all. Later on, if that plug-in proves to be problematic for whatever reason, you'll be the one they'll be pointing their finger to.

    Thanked by 1myhken
  • MikePTMikePT Member
    edited January 12

    @myhken said:

    @WebProject said:
    if the content stored on local server use path ( /path/to/image.jpg ) instead of hyperlink
    links or alternatively use hyperlink like: //mydomain.com/path/to/image.jpg - this way browser will adjust whatever protocol you do use.

    Thank you for this, hope it was OK that I just copied the text to the customer and told them to contact their webdesigner to fix this issue. :D

    And as always, thank you to all that took their time to help me. Go *LET!!!

    Man. Google wp database serialize. Download it, unpack, run, change http to https, change www to non www. Takes 5 minutes and it makes your customer happy.

    I hope you arent billing any premium price for the hosting because blaming the customer and get him possible spendings with the designer when you could have this fixed in less than 5 minutes makes you look really bad.
    This is also pretty easy to diagnose. Dev console, see the errors there.
    Not trying to be harsh, but you are just not bothering much and the poor customer is suffering.

    Toss me a pm and I will do this for you free of charge, but this is good faith to your client, not you. Do learn to pay some respect to your clients and learn this basic stuff.

    Thanked by 1myhken

    MXroute.io - SMTP Relay Service, powered by MailChannels, fully automated.

    New brand coming soon!

  • MikePTMikePT Member
    edited January 12

    @404error said:
    I wouldn't tell the web designer to install anything at all. Later on, if that plug-in proves to be problematic for whatever reason, you'll be the one they'll be pointing their finger to.

    Takes 5 min to solve it. There is no need to install any plugins. The lesser, the better, even if you need to edit the css, keep it simple.

    Thanked by 1myhken

    MXroute.io - SMTP Relay Service, powered by MailChannels, fully automated.

    New brand coming soon!

  • RizRiz Member

    LowEndSupport at your service!

  • WSSWSS Member

    ..or just use REPLACE() from a mysql client..

    I won't be back until @bsdguy is released.

  • imokimok Member

    @WSS said:
    ..or just use REPLACE() from a mysql client..

    Bad idea with serialized content.

    Thanked by 1WSS

    Janitor @ Netflix

  • WSSWSS Member

    @imok said:

    @WSS said:
    ..or just use REPLACE() from a mysql client..

    Bad idea with serialized content.

    Not when it comes to WordPress. It gives you the great option of replacing it with something functional and secure.

    I won't be back until @bsdguy is released.

  • @MikePT said:

    @404error said:
    I wouldn't tell the web designer to install anything at all. Later on, if that plug-in proves to be problematic for whatever reason, you'll be the one they'll be pointing their finger to.

    Takes 5 min to solve it. There is no need to install any plugins. The lesser, the better, even if you need to edit the css, keep it simple.

    It's a WordPress site, being full of unnecessary plug-ins is its nature. ;)

    That said, I agree with you.

    Thanked by 1MikePT
  • @404error said:

    @MikePT said:

    @404error said:
    I wouldn't tell the web designer to install anything at all. Later on, if that plug-in proves to be problematic for whatever reason, you'll be the one they'll be pointing their finger to.

    Takes 5 min to solve it. There is no need to install any plugins. The lesser, the better, even if you need to edit the css, keep it simple.

    It's a WordPress site, being full of unnecessary plug-ins is its nature. ;)

    That said, I agree with you.

    Indeed...

    MXroute.io - SMTP Relay Service, powered by MailChannels, fully automated.

    New brand coming soon!

Sign In or Register to comment.