Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

[HELP+ASK] about vps from my dedicated server
New on LowEndTalk? Please Register and read our Community Rules.

[HELP+ASK] about vps from my dedicated server

blackeyeblackeye Member
edited September 2013 in Help

hello .

yesterday i was bought dedicated server . i want make vps from my dedicated server . then i install openvz , template OS for vps , openvz web .

then after i make vps i can login via putty . but i got problem if using centos in my vps always get error .

here this error :

if using debian same i just got error . ( after apt-get update )

and i want asking . how to limit bandwidth per vps from dedicated server ?

sorry for my bad english .

thank you .

Regards

Comments

  • @Jack said:
    What does cat /etc/resolv.conf show?

    from dedicated server or vps ?

  • do you have connectivity from inside the VPS to outside your dedi?

    ping google, and telnet or nc an outside host. It seems that it's a problem with the network interface.

  • klikliklikli Member
    edited September 2013

    If you are not entering the container via vzctl enter, chances are the nameservers inside the container is not configured properly.

    Please see http://forum.openvz.org/index.php?t=msg&goto=23381& for more information on this.

  • blackeyeblackeye Member
    edited September 2013

    @john_k said:
    do you have connectivity from inside the VPS to outside your dedi?

    ping google, and telnet or nc an outside host. It seems that it's a problem with the network interface.

    here

    i am using tutor from here : http://e-padi.com/tutorial-cara-install-openvz-di-linux-centos-6.htm ( sorry if they bahasa indonesia languange you can using translate google )

    because i got problem here .

    1. Edit file sysctl.conf

    vi /etc/sysctl.conf

    search net.ipv4.ip_forward = 0 then change to:
    net.ipv4.ip_forward = 1
    net.ipv4.conf.default.proxy_arp = 0
    net.ipv4.conf.all.rp_filter = 1

    search line kernel.sysrq = 0 then change to:
    kernel.sysrq = 1
    net.ipv4.conf.default.send_redirects = 1
    net.ipv4.conf.all.send_redirects = 0
    net.ipv4.icmp_echo_ignore_broadcasts=1
    net.ipv4.conf.default.forwarding=1

    i am cannot found this line
    net.ipv4.icmp_echo_ignore_broadcasts=1
    net.ipv4.conf.default.forwarding=1

    Sorry For my Bad Write Comment in Here :(

  • john_kjohn_k Member
    edited September 2013

    put this line in the /etc/resolv.conf

    nameserver 8.8.8.8

    someone in previous comments told you to check that file.

  • SpeedBusSpeedBus Member, Provider
    edited September 2013

    Have a look at this,
    http://wiki.crowncloud.net/doku.php/suggested_nameservers

    Basically, add

    nameserver 8.8.8.8

    nameserver 8.8.4.4

    to your /etc/resolv.conf and restart the network service, to make sure it re-reads the resolv.conf, it might work without doing this, but i've always restarted networking/network to be sure.

    service network restart / service networking restart

    depending on the distro/Linux you're on :)

    EDIT: Also, try pinging a domain like google.com and not an IP, the IP will always ping, it's the domains that wont as your DNS - "Domain Name System" which resolves the domain into the IP behind it may not be working (check my above link/suggestion for the fix)

    CrownCloud - Internet Services | Los Angeles, California | Frankfurt, Germany | Amsterdam, The Netherlands

  • vi /etc/resolv.conf

    add

    nameserver 4.2.2.2
    nameserver 4.2.2.1
    nameserver 8.8.8.8
    

    to the beginning of the file

  • okay . next day i will try .

    thank you

  • are you Indonesian?

  • @ErawanArifNugroho said:
    are you Indonesian?

    any problem if i am from indonesian ?

  • Nope, just asking if you're Indonesian, I can help you using Bahasa Indonesia :)

  • @ErawanArifNugroho said:
    Nope, just asking if you're Indonesian, I can help you using Bahasa Indonesia :)

    thank you but i didn't know how to contact you sir .

  • thank you all my problem is solved . but i want ask how to limit bandwidth & port for vps ?

    thank you

  • wait, nobody thought about how he was able to log into ssh (remotely via ipv4) if his resolv.conf is fudged?

    vpsdash.com - Tips and tricks in life, information and technology news to get things done

  • @cosmicgate said:
    wait, nobody thought about how he was able to log into ssh (remotely via ipv4) if his resolv.conf is fudged?

    you right . I also do not know why it happened.

  • @cosmicgate said:
    wait, nobody thought about how he was able to log into ssh (remotely via ipv4) if his resolv.conf is fudged?

    well it should work fine without a proper resolv.conf, that's only required for resolving names

  • SSHd only uses resolv.conf to get the hostname of the connecting client. If it can't resolve (nameservers are down or missing/broken resolv.conf) you will notice a delay as the nslookup times-out but it won't stop you from connecting (unless you are using from="mydomain.com" in authorized_keys or something similar that isn't enabled by default)

Sign In or Register to comment.