Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Advertise on LowEndTalk.com
Install SSL problem in Nginx
New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

Install SSL problem in Nginx

WorldWorld Member
edited July 2013 in General

I got a SSL,and i do not know what to install and use in my Wordpress Website.Who can help me?

Comments

  • SaikuSaiku Member

    Google is able to help you?

  • WorldWorld Member

    @Saiku said:
    Google is able to help you?

    No..

  • SaikuSaiku Member

    @junjiang said:
    I got a SSL,and i do not know what to install and use in my Wordpress Website.Who can help me?

    http://www.digicert.com/ssl-certificate-installation-nginx.htm
    o,o;;

  • WorldWorld Member

    @Saiku said:
    o,o;;

    But i do not know how to use it in my Wordress.

  • anyNodeanyNode Member, Provider

    anyNode.netLA & Miami KVM & Miami Dedicated Servers

    http://twitter.com/anynode

  • edited July 2013

    What kind of ssl? And what file do you have?

    Usually, for Nginx, I use this kind of configuration, and it's working.


    server {

    listen 443 ssl;

    server_name erawan.me;

    ssl_certificate /etc/ssl/http/erawan.me;

    ssl_certificate_key /etc/ssl/http/erawan.me;

    rewrite ^/(.*) https://www.erawan.me/$1 permanent;

    }

  • WorldWorld Member

    @ErawanArifNugroho said:
    What kind of ssl? And what file do you have?
    Usually, for Nginx, I use this kind of configuration, and it's working.

    > server { > listen 443 ssl; > server_name erawan.me; > ssl_certificate /etc/ssl/http/erawan.me; > ssl_certificate_key /etc/ssl/http/erawan.me; > rewrite ^/(.*) https://www.erawan.me/$1 permanent; > } >

    I got a SSL from @centriohost

    Would you mind helping me to install?If you answer is yes,I will give you some information.

  • server { listen 80; listen 443 ssl; ssl_certificate /etc/nginx/ssl/your.certfile.crt; ssl_certificate_key /etc/nginx/ssl/your.server.key; server_name www.example.com example.com; root /var/www/example.com/public; index index.php; access_log /var/www/example.com/access.log; error_log /var/www/example.com/error.log;

    Thats how mine for my wordpress blog
    with plugin called WordPress HTTPS

    Hope that helps

  • I'm using the Wildcard AlphaSSL from CentrioHost about one hour ago, and also using that configuration for my blog.

    As in the received email, try to copy and paste it to a file, for example domainname.crt:

    -----BEGIN CERTIFICATE-----
    MIIEwMB8GA1UECk6zVnkLbO61NznKk7OqVHYS+ZHpo6g==
    -----END CERTIFICATE-----
    -----BEGIN CERTIFICATE-----
    +MPpZqmyIJ3E+LgDYqeF0RhjWw==
    -----END CERTIFICATE-----

    I cant make a correct quoting in here.

  • @junjiang said:
    No..

    Yes.

  • yywudiyywudi Member

    search google or baidu +keep trying, you can do it

    @junjiang said:
    No..

  • RalliasRallias Member, Provider

    cough /etc/nginx/sites-enabled/example-ssl cough

  • It's been solved, the website is working in http and https now :)

  • iCodexiCodex Member
    edited July 2013

    server { listen 80; server_name servername.com; return https://$server_name$request_uri; # enforce https } server { listen 443 ssl spdy; server_name servername.com; root /data/www/public_html; access_log /var/log/nginx/www/servername.com-access.log combined; error_log /var/log/nginx/www/servername.com-error.log; index index.html index.htm index.php; ssl on; ssl_certificate certs/wildcard_servername_com.crt; ssl_certificate_key certs/wildcard_servername_com.key; ssl_session_cache shared:SSL:10m; ssl_session_timeout 5m; ssl_protocols SSLv3 TLSv1; ssl_ciphers HIGH:!aNULL:!MD5; ssl_prefer_server_ciphers on; ... }

  • awsonawson Member

    AlphaSSL also requires the CA certificate to be set:

    ssl_client_certificate /etc/ssl/certs/AlphaSSL_Root.pem;
    

    (you'll need to get it from http://alphassl.com/support/roots/root.pem)

Sign In or Register to comment.