Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Subscribe to our newsletter

Advertise on LowEndTalk.com

Latest LowEndBox Offers

    redirect loop issues cloudflare
    New on LowEndTalk? Please read our 'Community Rules' by clicking on it in the right menu!

    redirect loop issues cloudflare

    Hi

    After activation of Cloudflare - Free and changing the required www settings and dns server.
    Flushed Cloudflare cache.
    Flushed all cookies in browser. (Chrome + Firefox)
    waited about 15 hours

    or are there other places I need to change things inside VB4's php or Nginx config files?
    Thanks inadvance.

    Comments

    • try changing ssl settings to "relaxed" in cloudflare ( in the tab "crypto" )

      Thanked by 1eraser

      Hosts I Recommend >> HVH | XiNiX | CloudCone | HostUs | BuyVM | VirMach

    • erasereraser Member
      edited February 2017

      There is no "relaxed" do you mean Flexible
      i changed if from off to relax (How long does it take until the settings work)
      i use self-signed SSL Certificate (Can be the probleme?)

      my SSL Setting in Nginx

      server {
      listen 80;
      server_name example.com;
      return 301 https://$server_name$request_uri;
      }

    • @eraser said:
      Hi

      After activation of Cloudflare - Free and changing the required www settings and dns server.
      Flushed Cloudflare cache.
      Flushed all cookies in browser. (Chrome + Firefox)
      waited about 15 hours

      or are there other places I need to change things inside VB4's php or Nginx config files?
      Thanks inadvance.

      If you have SSL on your web server change SSL in Cloudflare (Crypto tab) to full otherwise if you don't have a SSL on your web server then disable SSL in Cloudflare.

    • sounds like cloudflare(https) fetches from port 80 of real host which redirects to https on cloudflare. you probably need to tell cloudflare to fetch data from https of the real host OR get rid of your redirect in nginx.

      most recommended Provider: First-Root KVM Power-Edition /w SSD
      UltraVPS.eu KVM in US/UK/NL/DE: 15% off first 6 month | Netcup VPS/rootDS - 5€ off: 36nc15279180197 (ref)

    • erasereraser Member
      edited February 2017

      thank you

      @zafouhar i have SSl on my server and I did n't have any problems before i use cloudflare

      i set

      SSL cryto Full

      i get ERR_TOO_MANY_REDIRECTS on chrome

      Falzo said: Falzo

      said:
      sounds like cloudflare(https) fetches from port 80 of real host which redirects to https on cloudflare. you probably need to tell cloudflare to fetch data from https of the real host

      @Falzo
      How do I do that

    • eraser said: i get ERR_TOO_MANY_REDIRECTS on chrome

      Wordpress ? If so, disable Cloudflare, wait a bit, and put http:// and not https:// inside Wordpress URLs of Dashboard. Re-Enable Cloudflare and the problem is gone away.
      Otherwise change, its an example, with adminer.

      If at first you don't succeed, call it v1.0!
      OpenLitespeed, Litespeed and Nginx

    • @johnnymatt

      no i use vbulletin board

    • @eraser said:
      thank you

      @Falzo
      How do I do that

      I don't use cloudflare, so can't exactly tell, but at some point you most probably need to specify the target/your server/domainname whatever... I'd guess there has to be any option on what protocol to use for fetching that data.

      otherwise disable your redirect rule in nginx and work from there. as @johnnymatt suggested look if you can change the board-url/servername in your vBB control panel to have it use https:// ...

      most recommended Provider: First-Root KVM Power-Edition /w SSD
      UltraVPS.eu KVM in US/UK/NL/DE: 15% off first 6 month | Netcup VPS/rootDS - 5€ off: 36nc15279180197 (ref)

    • MridulMridul Member
      edited February 2017

      @eraser said:
      There is no "relaxed" do you mean Flexible
      i changed if from off to relax (How long does it take until the settings work)
      i use self-signed SSL Certificate (Can be the probleme?)

      my SSL Setting in Nginx

      Oops.. Yup.. I meant Flexible
      Its Usually Instant.. may be you can Try a Proxy to check the results.

      Hosts I Recommend >> HVH | XiNiX | CloudCone | HostUs | BuyVM | VirMach

    • erasereraser Member
      edited February 2017

      Ok now it work

      Changing SSl 2 Flexible
      Disabeling http to htts redirection on Nginx
      change the board-url/servername in vBB control panel to http://

      but How to set set the http to htts redirection with cloudflare without getting ERR_TOO_MANY_REDIRECTS?

    • I once helped one of my friends with this plugin (wordpress). https://wordpress.org/plugins/cloudflare-flexible-ssl/

      We suffer not from the events in our life, but from our judgment about them - Epictetus

    • Thank you @saf31

      but i dont use wordpress

    • MridulMridul Member
      edited February 2017

      @eraser said:
      Ok now it work

      Changing SSl 2 Flexible
      Disabeling http to htts redirection on Nginx
      change the board-url/servername in vBB control panel to http://

      but How to set set the http to htts redirection with cloudflare without getting ERR_TOO_MANY_REDIRECTS?

      1. Install the SSL on your Domain ( make sure the ssl is valid for www and non www )
      2. Add SSL to your domain ( via cpanel , CLI or whatever )
      3. Add This to your .htaccess :

      RewriteEngine On RewriteCond %{SERVER_PORT} 80 RewriteRule ^(.*)$ https://www.example.com/$1 [R,L]

      In the above code try experimenting with "https://www" or simply "https://" if u face any errors. Once its works without CloudFlare, Turn on the CloudFlare fr the domain.

      Lastly ,In cloudFlare Turn SSL Setting to "Flexible" or Whatver suits you.

      This is what im doing over 2 of my Forums using XenForo.

      Hosts I Recommend >> HVH | XiNiX | CloudCone | HostUs | BuyVM | VirMach

    • JonchunJonchun Member, Provider
      edited February 2017

      Give us your configs... No one can help you without seeing your configuration :)

    • @eraser said:
      Ok now it work

      Changing SSl 2 Flexible
      Disabeling http to htts redirection on Nginx
      change the board-url/servername in vBB control panel to http://

      but How to set set the http to htts redirection with cloudflare without getting ERR_TOO_MANY_REDIRECTS?

      just use, cloudflare page rules, set to always use https, you're good to go if you don't want change nginx conf.

      Thanked by 1Falzo
    Sign In or Register to comment.