Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Is there another way - CentOS 6.8 and PHP 5.6.xx
New on LowEndTalk? Please Register and read our Community Rules.

Is there another way - CentOS 6.8 and PHP 5.6.xx

Some years ago, I upgraded my PHP to 5.6.xx on my servers. I do it on every new server I create. Today I use:
wget https://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm rpm -Uvh remi-release-6*.rpm epel-release-6*.rpm yum --enablerepo=remi install php56 -y yum --enablerepo=remi,remi-php56 update -y

But to get my websites to work, I have to do something old Salvatore from Prometeus did find out when he helped me, I have to remove /etc/httpd/conf.d/php.conf and then edit my /etc/httpd/conf/httpd.conf and remove all php_admin_value engine Off entries.

If I don't do that, my websites is only blank when I try to access them. (WordPress sites).

The only issue I have, is that sometimes when I update my server, the system edit my /etc/httpd/conf/httpd.conf file automatically and add php_admin_value engine Off on every site in that file. I do not know why the system do that, and it happens not very often, but it happen. Then my sites goes blank to I have removed all php_admin_value engine Off lines from my httpd.conf file.

I think there must be another solution to this issue. How do you solve this issue, upgrading your PHP to 5.6.xx on your CentOS 6.8 64bit servers?

What easy way are I'm missing?

Kenneth Myhre
WindowsTemplate.com - free Windows templates for OVH/Hetzner/Kimsufi/Online.net

Powered by Hetzner.com, backed up by OVH, Kimsufi and VULTR.com

Comments

Sign In or Register to comment.