Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with OpenID
Advertise on LowEndTalk.com

In this Discussion

WHMCS "Complete Order" takes ages?

WHMCS "Complete Order" takes ages?

liamwithersliamwithers Member
edited October 2012 in General

Hey guys, not getting any response from WHMCS at the moment..

Just wondering if anybody else has been stuck with an order in WHMCS. I click "Complete Order" and it just takes FOREVER to load. It does go through eventually but takes forever.

I've moved the WHMCS to a different server to see if that was the problem, but the same issue is happening :S.

Any ideas?

VPN.sh - Secure and affordable VPN services

Comments

  • Are you using Nginx?

    Loading Deck - Cloud Consultants: Server Management | Consultancy | Software Development
  • @jhadley Nope, Apache

    VPN.sh - Secure and affordable VPN services

  • 24khost24khost Member
    edited October 2012

    what is your memory looking like on the vps?

    and what is your php memory max set to?

  • @24khost 319mb used 193mb free

    @joodle it's set to use PHP Mail(), this wouldn't be the issue would it?

    VPN.sh - Secure and affordable VPN services

  • Anything in the Apache error log?

    Loading Deck - Cloud Consultants: Server Management | Consultancy | Software Development
  • well, is it a xen, kvm, openvz vps?

    what is your php max memory set to in php.ini?

  • in your php.ini set it to 256m and then try it.

  • ZenZen Member

    Most likely email settings.

  • Reupload everyting - database corrupted? - php file permission, etc problem?

    Cheap $9/Year Hosting - Cheap Windows VPS & Linux Xen VPS at affordable price. FlameTix.com - cPanel/SolusVM/CloudLinux License - BTC/PM
  • @jhadley nothing in error log (other than forgetting to assign a favicon lul) @24khost OVZ, php max memory is set to 128M, I'll try at 256m now :).

    VPN.sh - Secure and affordable VPN services

  • I used to have similar issues setting max mem to 256 helps

  • I had pages freak out and take forever to load when I changed the hostname of my server to something invalid...PHP's mail function would just time out (well, take like 5 minutes to send the e-mail)

  • @liamwithers did the 256m fix it?

  • liamwithersliamwithers Member
    edited October 2012

    @winston that seems to have helped out a little :). Granted, it could still be quicker.. but that's at least took the load time down to something reasonable!

    Cheers

    @24khost no idea whether or not it's made much of a contribution.. but on it's own it done either nothing or very little (an unnoticeable amount) to help. My hostname wasn't valid, which once changed has sped things up.

    VPN.sh - Secure and affordable VPN services

  • joodlejoodle Disabled

    @liamwithers said: @joodle it's set to use PHP Mail(), this wouldn't be the issue would it?

    That was my problem, set to gmail smtp and whmcs was fast again

  • TazTaz Disabled

    Try disabling smtp and maxmind temporarily and see wat happens.

    Time is good and also bad. Life is short and that is sad. Dont worry be happy thats my style. No matter what happens i won't lose my smile!

  • I know it sounds stupid did you restart apache after you updated the ini?

  • @24khost yes Apache was restarted after each check.

    @joodle I'm down to about 15 seconds from "complete order" to "order confirmed" now, which will be ok for now as I'm not selling any services at the moment.. just setting up test accounts. I'll try this in the next day or two though to compare the difference, cheers.

    @Taz I disabled SMTP from the php.ini file, whatever I've messed around with has hugely improved it.. so will leave it for now until I setup SMTP properly.

    Cheers guys

    VPN.sh - Secure and affordable VPN services

  • which php are you using? php-fpm? suphp? php-fcgi?

  • TazTaz Disabled

    Remote smtp and maxmind might be the cause.

    Time is good and also bad. Life is short and that is sad. Dont worry be happy thats my style. No matter what happens i won't lose my smile!

  • RandyRandy Disabled
    edited October 2012

    You need to increse the timeout limit in httpd or at least that is how i got WHMCS to work when it did that to me . Please go ahead and pm me your httpd.conf and php.ini i will be happy to check it out for you

Sign In or Register to comment.