Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with OpenID
Advertise on LowEndTalk.com

In this Discussion

SSH sessions getting stuck but not disconnected?

SSH sessions getting stuck but not disconnected?

zhuanyizhuanyi Member
edited September 2012 in Help

I have this issue with both of my StylexNetworks VPS and after almost a month of being told they could not replicate the issue and then not responding my ticket for a long time until I ask, I decided to see if of the expert in LET could help me with it.

So basically to put it short, for both of my VPS, the SSH session would be "stuck" out of no reason, i.e., when I am typing a command or when a script is running, the screen will seem to "freeze" and not responding to any key stroke/not output anything at all. However, the session is not disconnected and after a while I was able to see what I typed a few minutes ago reappear on the screen or there is suddenly 10 lines of screen output showing up if I am running a script.

It happens at random time intervals and I have tried to use both the putty on my home PC as well as SSH on another 2 Linux VPS that I have, both with the same issue.

I am not trying to put in negative comments but I am really curious to see where the issue is and if it could be fixed, that would be really awesome.

And is there any other Stylex user with similar issue or I am the only unlucky dude?

http://BornIn.Asia - FREE shared hosting and subdomain service for LET members! Click here to see how to get one yourself! 96Forum: Low End VPS Discussions. Selling domains with GApp with various user counts (10 year reg incl. for some), PM for details.

Comments

  • Sounds like REALLY bad connection lag to me.

  • JarJar Member
    edited September 2012

    Definitely sounds like lag. Next time that happens run a traceroute and see if you can pin point it.

    Although...it could also be insane server load.

  • @zhuanyi said: And is there any other Stylex user with similar issue or I am the only unlucky dude?

    I am a user but I never felt something like that. If this persists, delete the VM and recreate from the control panel

  • @Asim said: I am a user but I never felt something like that. If this persists, delete the VM and recreate from the control panel

    That's a good idea, I am doing that now.

    http://BornIn.Asia - FREE shared hosting and subdomain service for LET members! Click here to see how to get one yourself! 96Forum: Low End VPS Discussions. Selling domains with GApp with various user counts (10 year reg incl. for some), PM for details.

  • @zhuanyi Pretty sure recreating the VM won't help, it looks like lag due to the network. Stylex servers are West Coast US I think.

    What ping reply time do you get to the server?

  • jaakkajaakka Member
    edited September 2012

    Assuming youre using OpenSSHd

    I would check and set values for :

    ServerAliveCountMax ServerAliveInterval

    in order to overcome the issue.

    Also learn the usage of screen.

    Most likely its due to the ISP connection using somekind of NAT. If youre using 3G connectivity or SOHO router.

    Other issues could be causing... wrong MTU.. the list is huge.

    Recreating the VM wont help.

    More of explanatory information: http://www.openssh.com/faq.html#2.12

  • @zhuanyi said: @Asim said: I am a user but I never felt something like that. If this persists, delete the VM and recreate from the control panel

    This actually worked, I just recreated the VPS and the problem seems to be gone for the whole morning

    http://BornIn.Asia - FREE shared hosting and subdomain service for LET members! Click here to see how to get one yourself! 96Forum: Low End VPS Discussions. Selling domains with GApp with various user counts (10 year reg incl. for some), PM for details.

    Thanked by 1Asim
  • Question though, I noticed here is how the eth port is set up:

    eth0 Link encap:Ethernet HWaddr 00:16:3e:e6:bd:74 inet addr:xxxxxxxxxxx Bcast: Mask:255.255.255.0 inet6 addr: fe80:: Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:196338 errors:0 dropped:0 overruns:0 frame:0 TX packets:68298 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:257554325 (245.6 MiB) TX bytes:10010862 (9.5 MiB) Interrupt:245

    and this value txqueuelen:1000 is set to 1000, is it a bit too high?

    and is the number of interrupts fine in this case?

    http://BornIn.Asia - FREE shared hosting and subdomain service for LET members! Click here to see how to get one yourself! 96Forum: Low End VPS Discussions. Selling domains with GApp with various user counts (10 year reg incl. for some), PM for details.

  • dataegdataeg Member
    edited September 2012

    I use stylex for 4 of my vps and never got affected by something like this. txqueuelen 1000 is the default value in linux its a little high. Put it to 200 but it may oversaturate your interface so keep testing. and you are the only one complaining about there support they usually answer in 10 minutes

  • @dataeg said: and you are the only one complaining about there support they usually answer in 10 minutes

    I agree, their initial response on this topic is really fast but the thread has been going back and forth after a while and there is a chance that they were trying and just could not figure out why...

    anyways, rebuilding VPS resolved the issue, which is something good with the "cloud" providers :)

    http://BornIn.Asia - FREE shared hosting and subdomain service for LET members! Click here to see how to get one yourself! 96Forum: Low End VPS Discussions. Selling domains with GApp with various user counts (10 year reg incl. for some), PM for details.

  • @zhuanyi nice that your issue solved. next time hit them between there eyes lol

  • and one good thing with them, they actually have Ipv6 available, which is rare among the US providers...

    http://BornIn.Asia - FREE shared hosting and subdomain service for LET members! Click here to see how to get one yourself! 96Forum: Low End VPS Discussions. Selling domains with GApp with various user counts (10 year reg incl. for some), PM for details.

  • edited September 2012

    @zhuanyi

    You mentioned that you haven't recieved a response to your ticket from us yet. Please PM me directly with your ticket ID and I will personally take care of this issue for you.

    StyleX Networks Cloud VPS on Xen & OnApp - FREE AnyCast DNS

  • zhuanyizhuanyi Member
    edited September 2012

    @stylexnetworks said: You mentioned that you haven't recieved a response to your ticket from us yet. Please PM me directly with your ticket ID and I will personally take care of this issue for you.

    That is fine, I have got the issue resolved by deleting and re-adding the VPS. Thanks for offering your help!

    http://BornIn.Asia - FREE shared hosting and subdomain service for LET members! Click here to see how to get one yourself! 96Forum: Low End VPS Discussions. Selling domains with GApp with various user counts (10 year reg incl. for some), PM for details.

Sign In or Register to comment.