Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with OpenID
Advertise on LowEndTalk.com

In this Discussion

SCP Help

SCP Help

dominicldominicl Member
edited August 2012 in Help

Hi

I'm trying to move files between one Dedicated Server and another Dedicated Server. I am running the following command on the server that has the files on:

scp -r /home/minecraft/ root@ipofservertogoto:/home/minecraft

For some reason it doesn't seem to be allowing the connection to move the files. I've stopped iptables on both servers and there are no firewalls running. Is there another way I can move the files?

Thanks

Comments

  • ZenZen Member

    yum install httpd tar folder/files mv tar /var/www/html/

    on remote node

    wget http://yeahtotally.com/files.tgz

  • For some reason the yum install command doesn't want to work. This server is rubbish. Lol. Any other way? I need the files.

  • rsync -avz /home/minecraft root@ipofservertogoto:/home

    Hostigation High Resource Hosting - SolusVM OpenVZ/KVM VPS
    Thanked by 1TheHackBox
  • @Zen said: yum install httpd tar folder/files mv tar /var/www/html/

    on remote node

    wget http://yeahtotally.com/files.tgz

    Trying this at the moment - hopefully it will work

  • Apparantely there is no httpd directory for some strange reason, created it but that doesn't work either. It's blocking rsync too. Wtf??

  • ZenZen Member

    If apache didn't install it wont exist..

  • @Zen said: If apache didn't install it wont exist..

    It displays the apache default page, but there is no /var/www/html directory or /var/www directory. I created it but still doesn't work when I upload an index page.

  • ZenZen Member

    OS?

  • I'd concentrate on why scp isn't working first. What's the error?

  • @Zen said: OS?

    CentOS

    @MartinD said: I'd concentrate on why scp isn't working first. What's the error?

    Just hangs when the command is executed.

  • ZenZen Member

    IDK then, without access I'm too busy to think what the issue could be :)

  • Try a local copy: scp -r /home/minecraft root@localhost:/home/minecraft2

  • @MartinD said: Try a local copy: scp -r /home/minecraft root@localhost:/home/minecraft2

    That's working, haven't a clue where it put it though...

  • Try the command with the -v switch as well: scp -rv ...... Post the output.

    Lead Developer - HostGuard Control Panel

  • Executing: program /usr/bin/ssh host 198.15.89.170, user root, command scp -v -r -t /home/minecraft OpenSSH_4.3p2, OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008 debug1: Reading configuration data /etc/ssh/ssh_config debug1: Applying options for * debug1: Connecting to 198.15.89.170 [198.15.89.170] port 22. debug1: Connection established. debug1: permanently_set_uid: 0/0 debug1: identity file /root/.ssh/identity type -1 debug1: identity file /root/.ssh/id_rsa type -1 debug1: identity file /root/.ssh/id_dsa type -1 debug1: loaded 3 keys debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3 debug1: match: OpenSSH_5.3 pat OpenSSH* debug1: Enabling compatibility mode for protocol 2.0 debug1: Local version string SSH-2.0-OpenSSH_4.3 debug1: SSH2_MSG_KEXINIT sent debug1: SSH2_MSG_KEXINIT received debug1: kex: server->client aes128-ctr hmac-md5 none debug1: kex: client->server aes128-ctr hmac-md5 none debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP debug1: SSH2_MSG_KEX_DH_GEX_INIT sent debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY debug1: Host '198.15.89.170' is known and matches the RSA host key. debug1: Found key in /root/.ssh/known_hosts:4 debug1: ssh_rsa_verify: signature correct debug1: SSH2_MSG_NEWKEYS sent debug1: expecting SSH2_MSG_NEWKEYS debug1: SSH2_MSG_NEWKEYS received debug1: SSH2_MSG_SERVICE_REQUEST sent debug1: SSH2_MSG_SERVICE_ACCEPT received debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password debug1: Next authentication method: gssapi-with-mic

    Hangs there.

  • Any other ways to move?

  • Try adding GSSAPIAuthentication=no to your ~/.ssh/config

    Thanked by 1dominicl
  • @gsrdgrdghd said: Try adding GSSAPIAuthentication=no to your ~/.ssh/config

    On which server?

  • The client, alternatively also add it to the server config.

    Thanked by 1dominicl
  • @gsrdgrdghd said: The client, alternatively also add it to the server config.

    You're a star!! THANKS,.

  • gsrdgrdghdgsrdgrdghd Member
    edited August 2012

    lol thats the first result when you Google "gssapi-with-mic"

  • @gsrdgrdghd said: lol thats the first result when you Google "gssapi-with-mic"

    -.-

  • Didn't think there was that many files :P

Sign In or Register to comment.